Seasonal Textures

I used the seasonal texture tweak in MDL Tweaker successfully for my LOWK-scenery two years ago. For some reason (maybe it is my growing age ;) ) I am now a little bit confused how to proceed in the workflow.

  • I understood that all textures with the defined extensions (eg "roof_sp.bmp", "roof_fa" and so on) will be displayed automatically, if the model has an assigned texture named "roof.bmp" - of course I have stored the textures in the same folder like the "basic" texture
  • In the second step I would have to define the range of days in which the suitable texture will have to be used

But the list of textures only shows the "basic" texture (in my example "roof.bmp". What the hell am I doing wrong? Or am I really getting old?

greetz
 

Bambi_007

Resource contributor
Hi Gianni,




Did you have the bmp on the same place how the mdl is?

On the Picture above do you see it work.
I have in the MDL Tweaker II Folder:
the mdl and the bmp= Dach - Dach_sp - Dach_wi - Dach_fa

The bmp Dach.bmp is default the summer bmp.
 
Thank you for the clarification, Sandra.

This fact should be explicitly stated somewhere in the tutorial, because normally texture files will be stored in a dedicated folder and not commonly with the model files.

Anyway, this was a great help. :)

greetz
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Gianni,

There is no need at all for them to be in the same folder.

When you first load the MDL file it will only show the one default texture, as no seasonal textures are defined. Which the checkboxes you can then select the seasons you want to activate and their days. After you press update texture they should appear in the texture list.
 
Hi Arno,

ok. So the problem lies somewhere else. I learned that AFTER definition of the days for the range for the relevant texture and pressing UPDATE the (already filed) textures will appear in the box.

As I have troubles with the acceptance of the days (I always get an error message saying that the defined days are are correct) it is now clear for me why the textures do not appear in the box. I have inserted the range

Winter: 1 - 77
Spring: 78 - 138
Summer: 139 - 239
Fall: 240 -365
So this must be correct - isn't it?

I will give it a try once again. I am quite certain that the problems is lying between my ears. ;)

greetz
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Let me check if the checking of the days maybe has a bug. I'll report back.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Gianni,

I think it is a bug with the end of the year. The code that checks if you dates are valid is not working OK for that. So if you use day 1 and 2, instead of 365 and 1 I think it should work.
 
OK Arno, I can confirm this bug. I switched the day for the change from fall to winter texttures to January 2 and it works fine.

So the workflow is:

1) choose the texture in the box (per default it is the assigned texture to the relevant material)
2) fill in the days for the seasonal change (avoiding days #365 and #1)
3) press <UPDATE TEXTURE> - the suffixes will be added to the default texture; the set of textures must be of course filed accordingly and transferred to the textures-folder in MSFS9).
 
Top