Shadow cast from land to object - P3Dv4

#1
I am in the process of developing an alpine grass airport scenery with underground hangar, where a 3d-object represents part of the land, blended into the mesh. Also, photo tiles are used for the surrounding ground and the 3d-object is textured using parts of the same photo tiles and the default detail1.bmp is applied to it.

While testing different times and seasons to check some bump maps on textures, I realized that the shadow cast from the mountain is not applied at all to the 3d model that represents the hangar and the rocks around it. However, it is nicely cast on the factory building 3d object just next to it. The same also applies to the general lighting of the ground compared to the object, as in low light you can clearly see where the object stops and the ground starts, while the difference is more subtle at midday, with more direct light on the surface.



At first, I realized that the factory texture has a bump map assigned while the grass has not. So I assigned a quick bump map to it just to check but that did not work. I checked all texture settings in MCX and they are identical. The only other difference between them is that the factory is made by a friend in FSDS, while the rock object is made by me in Sketchup. However, both were recompiled in MCX. To keep backwards compatibility, I still use the FSX SDK in MCX to compile models.

Any thoughts or ideas would be appreciated.
 

=rk=

Resource contributor
#2
FSDS applies very specific material settings which Sketchup does not use. You need to apply the "Set Default Opaque" material settings template to anything compiled by FSDS.
 
#3
Thanks Rick! It seems though that whatever settings FSDS applied accept the shadow while mine in Sketchup do not. Settings do look the same in MCX. I'll try default opaque in both and see what happens.
 

=rk=

Resource contributor
#4
If the procedure affects your transparencies then you'll have to export those as a separate model and apply the set default transparent template to that and then apply set default opaque to the remainder. Don't really want windows casting or taking shadows anyway.
 
#5
The material settings indeed were identical/opaque in both objects so nothing changed. However, after some fiddling I found that if in the lighting settings in v4 I also set "simulation objects" to receive shadows, I get the land shadow cast on my rock/hangar object too:



So that leaves me with the question why v4 thinks my bgl is a sim object and not a building. Also the weird different lighting on the object and the ground still remains. This does not happen at all in v3:

 

=rk=

Resource contributor
#6
I would compare material attributes line by line. To be a simobject, a .mdl file has to have a .cfg file, aircraft.cfg or sim.cfg for example, alongside within the parent folder containing them and any texture folders. If yours does not, then the setting does not apply to simobjects only. Therefore, the distinguishing difference between the two models is far more likely to be material attributes, as opposed to the circumstance of one being rendered as a scenery object and the other being rendered as a simobject.
 
#7
Rick, first of all, I really appreciate your valuable input in this and other questions I have asked on this forum. Your long experience in this hobby is valuable. I did check material attributes line by line many times and they are identical. The object is in the sim as a bgl file only, no cfg or mdl, like the simobjects. The fact that the behavior in v3 is more "normal" so to speak, leads me to believe that this is a new quirk introduced by the new animal in the game, v4. I have posted the question in the P3D forms as well but usually answers there are rare.

In any case, I'm at least happy that by checking this setting I get the shadow cast, whatever the reason behind it.
 
Top