• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Shake on engine running

Messages
17
Country
norway
Hey I have a shake effect that I want on my compass when the aircraft engine is running, what code do I do to make it only when the engine is running? Thanks in advance.
 

tgibson

Resource contributor
Messages
10,221
Country
us-california
The condition is (A:GENERAL ENG1 COMBUSTION, bool) where this is for engine 1. You can test for engines 1 through 4.

A bit of sample code would be:

(A:GENERAL ENG1 COMBUSTION, bool) if{ CODE FOR SHAKING GOES HERE }
 
Messages
17
Country
norway
The condition is (A:GENERAL ENG1 COMBUSTION, bool) where this is for engine 1. You can test for engines 1 through 4.

A bit of sample code would be:

(A:GENERAL ENG1 COMBUSTION, bool) if{ CODE FOR SHAKING GOES HERE }
<Component ID="Flight_compass_shake" Node="Flight_compass_shake">
<UseTemplate Name="ASOBO_GT_Anim">
<ANIM_NAME>Flight_shake_compass</ANIM_NAME>
<ANIM_CODE>(A:GENERAL ENG1 COMBUSTION, Bool) 300 *</ANIM_CODE>
<ANIM_LENGTH>300</ANIM_LENGTH>
<ANIM_LAG>100</ANIM_LAG>
</UseTemplate>
</Component>

Thanks for the reply, this is how I have it set up now. Do I need to do anything here to make it loop?
 
Messages
1,873
Country
us-ohio
That is because the variable is either 1 for running or 0 for not running. During the start phase, it switches between 0 and 1.
 
Top