• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Simconnect disconnects immediately after connection is established

Messages
22
Hello everyone, I'm desperately looking for help about this issue.
I had this working on FSX but since I migrated to P3D it stopped doing it.

As title says the problem is I the connection is closed as soon as it's established.
I have my own implementation but to discard any mistake I can be doing I use the example that comes with the PMDG NGX addon.
This is the main loop:

C++:
 while( quit == 0 )
        {
        // receive and process the NGX data
            SimConnect_CallDispatch(hSimConnect, MyDispatchProc, NULL);

            Sleep(1);
        }

SIMCONNECT_RECV_ID_QUIT is sent in the first iteration so the communication is lost.
I don't have idea why tho, as I said few years ago I had this working on FSX SP2.

I'm using Prepar3D v4, SimConnect headers and .lib are from its SDK

I'm not really familiar with the SimConnect API, not sure how can I add some extra debug.

Please if there is anything you think it's worth to try let me know, I'm totally frustrated :/
Thanks!
 
Messages
10
Country
china
the same issue with you
quit=1 even takes place with the sample code provided in the p3d sdk, so maybe your code isn't to blame
 
Top