P3D v4 [SOLVED]3DS MAX material export and Alpha channel problem

#1
Hi all,

I ran into really annoying problems these days ,just sorted out some of them, but this one is too hard that I had to seek for exact help with.:(

First, I'm new to 3DS MAX, currently using version of 2017 with SDK version Prepar3D v4 SDK 4.2.21.

I followed the tutorial that LM provided for 3DS users step by step, using P3D material when I export the model with a ".x" extension, but there is no any materials in MCX showed up, and the model just has a gray color by default(no specific material texture loaded).Here are what I got and my 3DS export settings.
1.jpg
2.jpg


I tried to export the model by ".3ds" ,and read it in MCX, it shows the same result.

So I gave up the P3D materials and used 3DS "Standard" ones. IT WORKED !!! My model was successfully converted into BGL files and showed up normally in P3DV4.

Unfortunately, another problem prompted, my textures using Alpha channels not displaying correctly in P3D (not transparent), but it showed transparent in 3DS Max. And further more, my ".dds" textures actually has alpha channels .

3.jpg
4.jpg
5.jpg



So there are two main problems : 1. How can I export a model which requires P3D materials? How do I set my 3DS export settings?

2. How do I manage to get my transparent textures display well ?

Wish you guys could help with me it ;););)
 
Last edited:
#2
Hi Rustam,

To get the transparent textures to show in your sim, you need to have the P3d material selected within 3dsmax when applying the texture. Next you need to set the material properties to - default transparent- or change the entry within mcx material editor from Zero/One to InvSrcAlpha/SrcAlpha. I’m not infront of my computer but I do believe that’s how it goes. Regards, Ridz_yssy

Edit* - you also need to have the game pack installed to have these options
 
Last edited:
#3
Hi Rustam,

To get the transparent textures to show in your sim, you need to have the P3d material selected within 3dsmax when applying the texture. Next you need to set the material properties to - default transparent- or change the entry within mcx material editor from Zero/One to InvSrcAlpha/SrcAlpha. I’m not infront of my computer but I do believe that’s how it goes. Regards, Ridz_yssy

Edit* - you also need to have the game pack installed to have these options

Hi Ridz,

Problems solved !!!! Thank you so much.:cool:
 
Top