*[Solved] *P3D v4.5 Ground poly flickering

Hi guys
I used 3ds max to create GP for P3D v 4.5 , but this flickering issue Driving me crazy, I did every possible solution that i find in this forum but the result is same flickering and flickering ; for your info i did the flowing:
1- The airport is completely Flatten (Used ADE flatten airport polygon)
2-The MDL file exported using P3D v4.5 SDK (Both 3dsmax and MCX)
3-Enable No shadow and No Z write in MCX (Set to TRUE)
4- used negative numbers for Z-Bias in MCX for Each texture
I will Attach MDL files and a shot from flickering GP

Can anyone help me to solve this issue?

Best
M@jid
 

Attachments

Last edited:
Hi guys
4- used negetive numbers for Z-Bias in MCX for Each texture

M@jid
If you used MCX GPW I think you must not enter negative zbias values.
You have to enter the values as used in FSX and MCX does the conversion by itself.
I would also suggest that the zbias values have at least a difference of two (i.e. 2, 4, 6 etc). I use a value difference of 4

-=Manwlo=-
 
Last edited:
If you used MCX GPW I think you must not enter negative zbias values.
You have to enter the values as used in FSX and MCX does the conversion by itself.
I would also suggest that the zbias values have at least a difference of two (i.e. 2, 4, 6 etc). I use a value difference of 4

-=Manwlo=-
Hi Manwlo
Thanks for your reply , I followed your suggestion and and put the positive numbers with value difference 2 and 4 (Try Both method)
, Unfortunately its not working for me .
any other suggestion?
 
Have you entered the TRUE ALTITUDE value in MCX respective box before exporting?
Make sure that it is the correct altitude in Meters

-=Manwlo=-
 
Ok I just checked the files you sent again. It seems that they are not "sliced" every 100m. Do you select this option and DEselect the 500m before compiling? If not your polygons will not follow earth curvature.
If that doesn't work either then try to slice the polygons every 100m in 3dsmax before exporting.

-=Manwlo=-
 
Ok I just checked the files you sent again. It seems that they are not "sliced" every 100m. Do you select this option and DEselect the 500m before compiling? If not your polygons will not follow earth curvature.
If that doesn't work either then try to slice the polygons every 100m in 3dsmax before exporting.

-=Manwlo=-
usually Deselect those ticks about Slice and grouping because some grooves and tracks appear on surface after export , anyway I will try this too and let you know about the result , could you please tell me how to Slice polygons in 3dsmax ?
 
This is probably the reason for the flickering.
Select ONLY slice 100m not the 500 and grouping. All ground polygons MUST be sliced to less than 100m so that they follow the earth curvature.

could you please tell me how to Slice polygons in 3dsmax ?
If slicing from GPW does not work:

Here is a video. After 3:30 it also mentions how to copy-paste a slice modifier for multiple use. I suggest that you place a slice modifier a few meters inside the left side of thgp (i.e. 10m) and then copy-paste it and place it 100m on the x axis to the right. Do the same procedure until all polygon area is sliced.
Repeat the same for Y axis starting from top to bottom.

-=Manwlo=-
 
This is probably the reason for the flickering.
Select ONLY slice 100m not the 500 and grouping. All ground polygons MUST be sliced to less than 100m so that they follow the earth curvature.



If slicing from GPW does not work:

Here is a video. After 3:30 it also mentions how to copy-paste a slice modifier for multiple use. I suggest that you place a slice modifier a few meters inside the left side of thgp (i.e. 10m) and then copy-paste it and place it 100m on the x axis to the right. Do the same procedure until all polygon area is sliced.
Repeat the same for Y axis starting from top to bottom.

-=Manwlo=-
Hello guys
I have a Good news , the problem is Solved, Appreciated to All of you Specially Manwlo and Arno thanks for Sharing this useful video I will check it out later, this 100 Slice poly solution was great and solve flickering issue ! now i can continue my work to create more polys.

Best
M@jid
 

jtanabodee

Resource contributor
Hi M@jid,
I have the same problem. But it is weird that I have a successful ground poly without flickering before. The I do other works and I found later my ground poly with native material flickering a lot.
I was wondering if it my P3D program problem. One day P3D freezed up, then I have to shut down my laptop. After that I got this problem.
Would you mind checking this in your computer? I will send my file.
Thanks,
Tic
 
That's OK. The problem is from p3D4.5 sdk. I switch to P3Dv3 sdk and it works just fine.
Good news , wish you good luck for your project , I was busy for a few days and still don't have much time to create ground poly for wet rain effect , I will inform you when i Start my project again.
 
Last edited:
Top