FSXA [Solved]Skinned mesh animation lost when exporting

Kekelekou

Resource contributor
#1
Hello fellow Blender modellers!

I am having a go at a very simple skinned mesh animation as a warm-up for a more complex project. The top 4 vertices of a cube rotate (I told you it was simple!).
Thanks to capt_x mini-tutorial, creating the mesh and assigning the anim is now pretty straightforward. Everything works fine in Blender.
The "skinned mesh" box is ticked in the material editor. The "skinned mesh" box is ticked in the export window. The export itself runs smoothly.
Reading the MDL in MCX (today's dev release) shows that the anim is included (correct name in the anim manager, and correct code in the ModelDef.xml reader).
But the top vertices do not move at all.

I must be missing something obvious one again. So any insight from a seasoned Blender modeller will be appreciated!

Have a nice day,

Blender 2.79b + Blender2FSX 0.94 (ii)
 

Attachments

Kekelekou

Resource contributor
#7
Merci FSX3D. I have just had another look at the file. I tested the wrong version in FSX...
So now the MDL reacts as it should to the Lvar change in-game, but still no visible animation in MCX. Better than the otherway around, but I'd like to know the issue with MCX though.
Investigations on-going...
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#8
Are you using the simple shader in MCX maybe? That doesn't support skin and bone animations.
 

Kekelekou

Resource contributor
#9
I had no idea this could be changed! The "ForceSimpleShader" is set to "False" in the Renderer tab of Options window.
I have just deleted the whole MCX folder, redownloaded and reinstalled it. Same result.

What is puzzling is that if the "Show Bones" box is selected, the bones animate just fine. So the textured rendering is the only item that does not move as expected, all other features react the right way.

PS : The cube's top face rotates (albeit not as specified by the bone's rotation) in "Inspect Normals", "Inspect Texture Mapping" and "Inspect Bone Weight" render modes.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#10
Did you assign the vertex weights in the model? Else the skin does not follow the bones.
 

Kekelekou

Resource contributor
#11
As far as I know, there are two methods to link the armature to the vertex groups :
- Adding a "armature" modifier to the mesh
- "Making parents" the armature and the mesh, then "deform the armature with automatic weights"
I have created two MDL following each method. Both work in FSX but the skinned anim is not depicted in MCX.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#12
And in MCX in the toolbar there is an icon with a red teapot (simple or complex shader), is that one set to simple maybe?
 

Kekelekou

Resource contributor
#14
Nailed it Arno! The FSX-approved MDL deforms if the red teapot is checked. The deformation is not exactly the one in Blender, but at least I can check if the anim is exported. That's all I wanted in the first place.
Thank you to both of you for your help.
 
#16
As far as I know, there are two methods to link the armature to the vertex groups :
- Adding a "armature" modifier to the mesh
- "Making parents" the armature and the mesh, then "deform the armature with automatic weights"
I have created two MDL following each method. Both work in FSX but the skinned anim is not depicted in MCX.
Oops! It seems to me that bones animation for FSX works only with vertex group! Am I wrong?
JMC
 
Top