• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v3 [SOLVED] Sode jetway Strange problem(don't move) in P3d

Messages
6
Country
china
Hi everybody! I learn to make a Sode jetway these days. I met a strange prob in the game the static jetway looks all good before i select the gate number, i don't know somehow after selecting the number jetway gose to a strange gesture.
At the beginning i do not know how to make a custom one so i use the default MAX file from Sode jet SDK.
After using Script and exporting it to mdl. I put it in MCX looks like this.(MCX.jpg)

MCX.jpg

In the game before i select the gate number (Before_select_gate_number.jpg)

Before_select_gate_number.jpg

After i select it (After_select_gate_number.jpg)

After_select_gate_number.jpg
I'm now learning to make this. So there may have some details i did not understand jet!
The SimObject Display Engine is really perfect. Can anybody help me? It would be extremely grateful!
 

Attachments

  • SODE.zip
    306.7 KB · Views: 227
Last edited:
Messages
611
Country
switzerland
Hi there,

Did you increase the model radius as per my SDK using the MDL Tweaker tool from within MCX?
Since you use a static variant, you can set the radius to around 500m. That's what I use.

If you don't increase the radius, the simulator will not animate/initialize SimObjects when the viewpoint is far away (e.g. in outside spot view)
 
Messages
6
Country
china
Hi there,

Did you increase the model radius as per my SDK using the MDL Tweaker tool from within MCX?
Since you use a static variant, you can set the radius to around 500m. That's what I use.

If you don't increase the radius, the simulator will not animate/initialize SimObjects when the viewpoint is far away (e.g. in outside spot view)
Hi Jeffrey
I don't increase the radius. I just export the MDL file and put it in the SODE file.
The jetway don't move when i chose inner viewpoint too.
INNER.jpg
 
Messages
611
Country
switzerland
Inner viewpoint is not a solution, it still can be too far away. Only solution is to increase the model radius.
 
Messages
6
Country
china
Inner viewpoint is not a solution, it still can be too far away. Only solution is to increase the model radius.
Hi Jeffrey.
Inner viewpoint is not a solution, it still can be too far away. Only solution is to increase the model radius.
Hi Jeffrey thank you very much for replying me! From your first message, I've already changed the radius(500) and it didn't work no metter in inner view or outside view!
For now i'm confused ! I really don't know what is my real problem! :banghead: I really need your help thank you !
 
Messages
611
Country
switzerland
Hey,

I have inspected your model in a hex-editor and saw that the animations in there are not linked to the respective simulation variables! SODE is controlling those variables and since they are not defined in your model, the parts do not move.

It is really strange, the animation keys and everything are in the model, it's just that the variables are not assigned to the animations. The modeldef.xml is looking fine!

I suspect something went wrong during the export of your jetway into mdl-format. So some questions:
  • What modelling tool are you using?
  • Which Modelling SDK are you using?
  • What is your method to export the model?
 
Messages
6
Country
china
Hi Jeffrey

I use 3DMAX to create model. Since i downloaded your (SODE_JetwaySDK_v1.6) I found that 2014 3DMAX(I use this version to create model) version is unable to open it. So i use the 3DMAX 2017 to export it.

SDK is P3D version (Prepar3D v3 SDK 3.4.14.18870)

And export tool is Aces Tools !

My step to create a Sode Jetway is:
1.Open (SODE_Jetway_A_HoodNG) file in 3DMAX 2017
2.Run (SODE_Jetway_Creator) script create the jetway (All options are default). the jetway will be made in a few seconds.(PS. I changed both modeldef.xml in P3D SDK and FSX SDK )
3.then i use Aces Tools to export the model (Export skin and animation all selected) .
4.I followed your SODE DEMO to do my jetway.


Then you know the jetway is not move in P3D!


MDL.zip contained the MDL file I exported yesterday! Hope it could help you to find the problem!:)
 

Attachments

  • MDL.zip
    24.5 KB · Views: 153
Messages
611
Country
switzerland
Checked your mdl file, and still there are no sim variables defined in there.

The crucial step is how did you convert the x and xanim files into mdl?
I suppose you tried it with the "Build only MDL file?" checkbox in the Aces Tools -> Export Tools.
Did the same before and surprisingly, in my mdl there were no sim variables, too!
So I think that function of the exporter is broken if you have animations with custom code. Checked the forums and found this thread, where I found that the "build only MDL file" is not working properly: liniar vs euler and tcb animation rotation

The "standard" way for 3dsmax is to export the x and xanim files and the manually convert it to mdl with the XtoMDL.exe tool provided in the SDK.
I have made a little batch scripts that does that for me. This will for sure create a correct mdl with sim variables and everything in it.
I am confident that this (manual) step will make your jetway work finally :)
 
Messages
6
Country
china
Checked your mdl file, and still there are no sim variables defined in there.

The crucial step is how did you convert the x and xanim files into mdl?
I suppose you tried it with the "Build only MDL file?" checkbox in the Aces Tools -> Export Tools.
Did the same before and surprisingly, in my mdl there were no sim variables, too!
So I think that function of the exporter is broken if you have animations with custom code. Checked the forums and found this thread, where I found that the "build only MDL file" is not working properly: liniar vs euler and tcb animation rotation

The "standard" way for 3dsmax is to export the x and xanim files and the manually convert it to mdl with the XtoMDL.exe tool provided in the SDK.
I have made a little batch scripts that does that for me. This will for sure create a correct mdl with sim variables and everything in it.
I am confident that this (manual) step will make your jetway work finally :)
Hi Jeffrey

I'm very thank you for having much patience to help me ! I really appreciated! I hope I'm not bother you as well. ^_^

Here is my step:
1.I followed your standard way to export only x and xanim files.

2.I pasted those two files to P3D SDK file and dragged and dropped x file to XtoMDL.exe. Then MDL file was compiled.

3.Here another prob come. The MDL file didn't have any animation.

4.So i drag and drop the X file to MCX. The event log said "could not find linked animation" etc.

5.Then i tried to export object from MCX. The log said "ModelDef contains duplicate guid".


Here I have no idea how to do next ! Hope you could help me ! Really thank you!
 
Last edited:
Messages
611
Country
switzerland
The XtoMDL tool is command-line driven, you can't just drag and drop your x file onto that.

So, you either type in the commands in a cmd window, write a batch script or even easier, use the tool here: http://www.fsdeveloper.com/forum/threads/xtomdl-ui.432039/
The important part is that you need to set the /XANIM flag, this will tell XtoMDL to include the animations into your model.
 
Messages
6
Country
china
HAHA;) Finally the jetway worked very well!
I really really really appreciate that you give me such a big help ! :D
Done.jpg
:rotfl::rotfl:
 
Messages
75
Country
pakistan
Checked your mdl file, and still there are no sim variables defined in there.

The crucial step is how did you convert the x and xanim files into mdl?
I suppose you tried it with the "Build only MDL file?" checkbox in the Aces Tools -> Export Tools.
Did the same before and surprisingly, in my mdl there were no sim variables, too!
So I think that function of the exporter is broken if you have animations with custom code. Checked the forums and found this thread, where I found that the "build only MDL file" is not working properly: liniar vs euler and tcb animation rotation

The "standard" way for 3dsmax is to export the x and xanim files and the manually convert it to mdl with the XtoMDL.exe tool provided in the SDK.
I have made a little batch scripts that does that for me. This will for sure create a correct mdl with sim variables and everything in it.
I am confident that this (manual) step will make your jetway work finally :)
Can u plz share the scripts? Thanks
 
Top