• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Specific blender file ruins package building, need help!

Messages
17
Country
norway
So i have spent around 200 hours modelling in blender, all of a sudden when I try to build the package with the models I have created I get the errors attached as a picture here in the console. I have another file which is from the early stages of my project, this loads fine into MSFS, its this specific blender file that doesnt. I think it has something to do with the objects, as appending everything into a new blender file does not solve the issue. There are no modifiers applied, and building the package worked fine about 30 hours of work earlier. I am desperate for help, if I dont get this fixed it would put countless hours of labor to waste. I dont even know where to start trying to fix this, and other than the general mesh of the main building I dont have a file that works.
 

Attachments

  • errors.PNG
    errors.PNG
    250.2 KB · Views: 53
  • ENRT blender file.PNG
    ENRT blender file.PNG
    937.1 KB · Views: 57
Messages
17
Country
norway
I tried exporting a specific object from the scene only that had worked previously with exporting only selected object, same error
 
Messages
292
Country
unitedkingdom
Sorry if you have already tried this but everytime I have had a failure to load a model so far the problem was caused by a badly sized texture file. That is, one that is not 1024x1024,2048x2048 etc.

Sent from my SM-T813 using Tapatalk
 
Messages
17
Country
norway
Sorry if you have already tried this but everytime I have had a failure to load a model so far the problem was caused by a badly sized texture file. That is, one that is not 1024x1024,2048x2048 etc.

Sent from my SM-T813 using Tapatalk
This is not the issue, thanks for trying to help out nevertheless
 
Messages
78
Country
france
Hello, witch version of exporter do you use in Blender ?
I remember have an issue like you, with a error message in GLTF around line 6, after creating materials with détailled textures.

The 0.40.0 version had a problem with detailled textures materials. Somes lines about extensions not anderstood by the compiler was added in the Gltf file.

You must use the 0.40.2 or 0.40.2.5 version to correct this problem.
 
Top