• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MCX Strange Interior Model Render

Messages
43
Country
unitedkingdom
Have a strange issue with the Carenado B1900D interior, rendering parts in the wrong positions. It displays correctly inside P3D, so the model should be fine.
Can replicate on latest Dev Release and 1.5 stable, also reinstalled the add-on fresh to rule that out.


Screenshot 2022-07-10 123825.png
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,412
Country
netherlands
Hi,

I don't have that model myself, so not sure how I can debug this issue.

There was a similar report a few months ago, but I could not reproduce that on my machine.
 
Messages
43
Country
unitedkingdom
If I shared the model file privately would that be ok? Understand if not of course!

Any idea what it could be?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,412
Country
netherlands
Hi,

Just to let you know I have been able to reproduce the issue. In version 1.4 the model shows up fine, so it must be a bug that has been introduced a while ago. I'll try to figure out where it is.
 
Messages
43
Country
unitedkingdom
Glad to hear you have managed to reproduce it. Thank you for taking time to look at it, really appreciate it.
 
Messages
131
Country
netherlands
Just a thought: If a model has parts where x, y or z scaling is not equal 1.0 (which technically should not be used for FSX/P3D models), MCX 1.4 imports them well but later versions do not - parts come out with wrong proportions.
 

tgibson

Resource contributor
Messages
10,674
Country
us-california
Hopefully this is the same issue where parts are displaced when Merging them.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,412
Country
netherlands
Might be Tom, although that issue I could not reproduce, while this one I can.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,412
Country
netherlands
Just to let you know investigating and testing this issue will take longer, our summer vacation is approaching and I don't think I will be able to fix this beforehand.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,412
Country
netherlands
Hi,

This morning I spend some time to test this issue with different builds of MCX. I have found out that a change made in December last year to fix an animation bug has caused this issue. Now I need to figure out what is wrong with that fix :)
 
Top