Stuffed by Windows 10


Resource contributor
I'd like to use a very much more coarse and accurate expression but... This applies to both FSX and P3D. Initially, I'm going to keep it simple and start digging deeper with detail if necssary.

None of my SimConnect stuff works correctly to start with. Many switches simply don't work and those that do still work, operate all the other switches as well. They also try to operate the control levers (mixture, throttle, etc.). My save flight routines no longer work in either FSX or P3D. In FSX, if I leave Notepad++ open during a flight save, it tells me that the .flt file has been changed and do I want to reload it? Yes please - only, no change, no additions where I'm writing to it. Ditto the P3D fxml file. Running the debugger while the relevant flightsim is active shows that the code is being stepped through correctly.

No change if 'Run as administrator'.

What part of 'it's my ##@@!!!# PC' doesn't Windows 10 understand? I've had the misfortune to have been forced to work with this POS since the beta days and I don't like it any more now than I did then. I had to rebuild my PC after a M/B failure and found that the current generation of motherboards that are compatible with Intel Coffee Lake all seem to require Windows 10.

I suppose the only good side is that I found this problem now and not at beta test/release point.

[Edit] Neither FSX nor P3D is on the C:\ drive. Both are on the D:\ drive.

Roy Holmes

Resource contributor
I find that users have more issues like these when they do not have the sim in C:/Program Files.
No real idea why except it is the default place to put it.
As they say on TV ads, "Your experience may be different"


Resource contributor
For years I've kept my boot drive separate from my data drive(s) and my data drive(s) backed up because it makes disaster recovery simpler and quicker. My boot drive is a small SSD and it simply doesn't have the room to install everything there. Now Windows 10 is telling me I can't do that and I have to go out and spend $K on a big SSD? Either that or go back to spinning rust.

It can't hurt to give it a try though. I'll get back to you.

I've assembled another Windows 7 machine just to make sure it's not me that's screwed up, but FSX has just told me that I need to by another copy of both it and Acceleration. Licence terms are licence terms but it really does feel like adding insult to injury.

[Edit] Just got a copy of both from eBay for £21 / $US27.30.
Last edited:


Resource contributor
Well, that didn't work (installing to the default path). Pending the arrival of the just-ordered copies, I just have to assume I've screwed something up. I tried my other Win7 PC but the kit is so old (it's just my data backup server running an early AM3 processor) that FSX runs like a very poor slideshow. New s/h kit arriving from work colleagues on Monday, so we'll see what happens once that and the bits I've assembled are installed in a new case. I can't run FSX in demo mode because I need Acceleration and that won't install unless FSX is registered.


Resource contributor
Okay, now I'm confused but happy. I'd tried compatibility mode Windows 7 (should have mentioned that in post 1) but it failed. Since then it's been installed on the C:\ drive in the default folder and then moved back to the D:\ drive. I fired it up just to register Acceleration and on closing it, the Windows 10 'I've set this to compatibility mode (not stated), try the program now' dialog popped up (wanted to say 'pooped up' but...) So I did, and apart from coming up on the wrong screen, it behaved itself! I pulled it back to the main screen, closed it down and checked to see what Windows 10 had done with it. Compatibility mode 'Vista Service Pack 2'. Wha - ? I set that to 'Windows 7' again and tried it - lo and behold, perfect behaviour.

Give up. I doubt anything is ever going to really make me like this operating system.

P3D is still misbehaving but hey, I can live with one for now.


Resource contributor
P3D fixed and the last step really was my own fault. I still had 'Virtual Cockpit 00' checked in the P3D menus. Once that was unchecked, it all started working correctly.


Resource contributor
Thinks INTEL CPU #Spectre, @#meltdown faults which recently have been found last weeks:

- What type of CPU do you have installed your Windows10 laptop?
- If that CPU is known to be affected by the most recent Intel Spectre / meltdown hardware flaws?
- Did you already applied (software) patches on your machine before these errors started to occur?
- Does the problem also occur on other (Non-windows10) machines you might have (if you have any)?


Resource contributor
Good thought but no. The CPU is vulnerable (it's a Coffee Lake) but I've refused all updates since the news broke. Patches are being rushed out because the public 'needs someone to be seen to be doing something'. The vulnerability has been there for years, so the need is for a tested working patch, not a bit of sticking plaster. The only people who will be well p!ssed off about this are the various security agencies who will have been exploiting the vulnerability for as long as it's existed.