• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v3 Suddenly cannot compile GP

Messages
141
Country
germany
I have been using ADE 1.76.6715 for some time developing airports without really having any problems. Today I am working on LJLJ airport and compiled it just fine, now when I try to enter some GPs (Lines etc) I get the following message and the compiler fails. Just updated WIN10. ADE GP Version is 2.2.23.8.

Unable to compile GPs The system cannot find the file specified.

Settings / Options / Folders.
Scenery cfg Folder :- C:\ProgrammData\LockheedMartin\Prepar3Dv3.
FS Main Folder :- J\Prepare3D v3.4\
SDK
BglComp Folder ;- D:\P3D SDK\Environment SDK\Bgl Compiler SDK\
Shp2Vec Folder ;- D:\P3D SDK\Environment SDK\
 
It appears you have recently updated ADE-GP but are still using an old, long-since updated version of ADE., There may be some incompatibility.

I suggest you install a more recent version of ADE (1.78 or later) and try again. If that doesn't work, please zip up your:
  • .ad4 file
  • your Textures and Textures_Dpy folders
  • your Textures_Def.txt and Lines_Def_txt files
together with specifics of the line/poly of concern and send to me at don at stuff4fs dot com
 
Hi, here is a short summary of what I have done.
Downloaded the ADE 1.78 Production and the ADE-GP_22238 zips.
Extracted the ADE zip into a folder of the same name. Checked in the ADE_GP folder, only the Mdls were present. Extracted the ADE-GP zip to this folder. Opened ADE and went through the setup procedure ignoring the request for transfer from another ADE.
I then made a simple GP line to see if it worked. Once again the Compile failed with the same message as before. I then tried to compile again but noticed that in the Compile Parameters Dialog window the box for Generate FS8-Style GP's was ticked so I unticked and pressed the Continue button. Compiler then ran. At the airport the line was flickering and sometimes not visible. Closed the sim, back to ADE and ran the compiler once again but this time in the Compile Parameters Dialog window for in the Offset GP Elevation by box I entered 5. Once again pressed the Continue button, Compiler ran. Now in the sim I could see the line perfectly. I must say that some times, as in my case, it pays to read the manual. Many thanks for your input, ADE is a wonderful program.
 
Glad it's now working for you.

Based on what you've told me, the only reason I can think of to cause your earlier problem, i.e., file not found by the compiler - given that the P3D compile worked - is that BGLC9.exe was not in your ADE folder.

That you had to enter "5" is unusual. Normally, that box is initialized to "7". The reason for this parameter is explained on Page 19 in the manual. Is there anything unusual about your system?
 
Back
Top