• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

tabdock.ocx problem when starting ObPlacerXML

Messages
537
Country
canada
Hi,

Just got a new system, with Vista.

I used the same folder I have in my old system for ObPlacer XML 0.83 (copied the folder over).

Then I ran mwgfxdll.exe. Vista gave me some sort of a warning about it possibly not being compatible, but I went ahead.

Then I ran ObPlacerXML, but it gives me the error "Component 'tabdock.ocx' or one of its dependencies not correctly registered: a file is missing or invalid."

Any hints?

Thanks

Fern
 
Hi Fern,

I think it is better to run the installer for ObPlacer XML again, so that you are sure you have all runtime files. Else you will have to register those files manually as the message says.

On XP that works with the regsvr32 command, but I don't know if it is the same on Vista.
 
ObPlacer now works but doesn't generate bgl

Hi, Arno

It worked for the install. No problem starting ObPlacer 083 now.

But when I create any project, just a simple library object located somewhere, when I tell it to compile bgl, ObPlacer closes (windows tells me "Ob Placer has stopped working"), and no bgl is to be found anywhere.

Any thoughts?

Thanks!

Fern
 
Hi Fern,

Does the error contain any additional information on what is going wrong? Sounds like a crash, but without more information that is hard to debug.
 
ObPacer, Vista, now working. Strange...

Hi, Arno

I did some work on it and it is now working. I thought you might be interested in what I found, so here it goes.

1. I used the installer, as you suggested, and the problem with "tabdock.ocx missing" went away.

2. ObPlacer XML 083 (from now on I'll call it "ObPlacer") then started without problems.

3. ObPlacer would do what it had to, including save the xml file with all the objects properly coded.

3. Then the problem of closing occurred when I told it to compile bgl. I couldn't troubleshoot that, because there was no more error information, only that ObPlacer had "closed".

4. Then I tried to manually compile the xml that it had created and that worked, all objects appeared where they should. The only thing is that I used my own bglcomp.exe, in my BGLCOMP folder.

5. That's when I decided to try to compile manually using your bglcomp.exe, in the ObPlacer folder, and it didn't work. It says it works, but it doesn't.

6. Then I moved your bglcomp.exe and bglcomp.xsd to a "Cuts" folder and copied my own files into it. Same thing, wold not compile the "test.xml" file.

7. Then I moved your original bglcomp.exe and xsd files to another folder OUTSIDE Program Files and... it worked!

8. Then I copied the entire ObPlacer XML folder from C;\Progam Files\SceneryDesign.org\ to a folder OUTSIDE Progam Files, in My Documents, and it all worked.

9. Just for testing, I made a "Temporary" folder inside the original ObPlacer XML folder in Program Files, placed bglcomp.exe and xsd in there, and it didn't work either.

For some reason the bglcomp.exe and xsd do not want to work inside the C:\Program Files\SceneryDesign.org. I have no idea why.

So, my immediate problem is fixed (ObPlacer folder moved to My Documents), but there must be something funny there, and I don't know what it is. Probably some Vista peculiarity, but it may be worth investigating.

Thanks, Arno

Fern
 
I think the program files folder is marked read-only in Vista. I got so fed up with r-o folders I disabled UAC and have no more problems.

George
 
Thanks Fern, hopefully this can help other users as well. I guess it could indeed be a read-only problem as suggested by George.

I must say I don't have Vista installed myself, so I can not really debug this kind of problems. Also, after having tried Vista, I am sure I will not install it again soon.
 
Vista Program Files folder is read-only?

Hi, Arno and George

I bought a new HP system to replace this old HP (Windows XP), which is my workhorse. Unfortunately, at the store level, there is no choice: It is Vista or nothing. I hear that HP will downgrade to XP on request, but I haven't investigated that yet.

By the way, Vista has problems with FS: FS only works properly in "full-screen" mode. It doesn't work well with other windows open, which is what we need for scenery... There are tonnes of reports about this all over the Web. (I am a Microsoft sympathiser, but one would count on Vista working well with its own cousin-software...

So, as soon as I have some time, I'll investigate the "read only" thing about the Prgoram Files folder and report back to you fellows.

This may affect other of Arno's tools, the ones I use the most, such as the Tweaker and the Library Creator.

Thanks

Fern
 
By the way, Vista has problems with FS: FS only works properly in "full-screen" mode. It doesn't work well with other windows open, which is what we need for scenery...
That's not true Fern, I ran FSX pre and post SP2 in windowed mode (even in DX10 preview mode) and it works perfectly on 64 bit Vista.

George
 
Hi Fern,

I guess the problem here is that while compiling a temp file is written in the folder where the program is installed. I guess that is no longer allowed on Vista, I would probably have to use an "application data" folder in the user profile or so.
 
Had the same problem and I have Windows 7 64 bit. I corrected it by changing the compatibility mode to Windows XP. Works from there.
 
On Windows 8 I get this:
C:\ObPlacer XML>bglcomp compile.xml
INTERNAL COMPILER ERROR C1003: Failed to create MSXML object! (0x80040154)

Parsing document: compile.xml

ERROR C2470: Unrecoverable error parsing XML!
ERROR C2006: Parse failed (0x80004005)
ERROR C2003: Failed to process file: compile.xml

Been trying to get this fixed, but still no cigar!

Cees
 
The msxml error means that you need to install version 4.0 of it.

Did you use the installer to install obplacer xml? That should take care of the tabdock issue.
 
Yes, I used the installer and tabdock.ocx is in the obplacer folder, but obviously it is not registered. :)
 
Hummm let me check it's a long time ago I tried to install the tool. Might also be something windows 8 specific.
 
Back
Top