Terrain Sculpture Pro V0.1.09 compilation problem

gadgets

Resource contributor
Thanks for the additional info, Gary. The initially-reported slope issue was due to hydro-polys not needing (or wanting) the slope=0 definition added by TS Pro. The solution was simply to delete those definitions.

Conrad, as I reported a short time ago, the current issue is two-fold. First, the vertices for hydro polys were being submitted to xml2vec in the wrong order. (TS Pro maintains all poly vertices in counter-clockwise order. xml2shp - and Flightsim - expects the vertices for hydro polys in clockwise order.) TS Pro now conforms.

But, as I reported earlier, while this put the water where it was supposed to be, the "outside rectangular area" remained and operated as a large flatten. Since TS Pro did not define any such area, its source could only be xml2shp or shp2vec - both outside my control. Upon further investigation, I discovered that your project lies on a QMV15 boundary and, in fact, the "outside rectangular area" extends over both QMV15 areas. To test whether this bisection of your project was the cause , I offset the latitude of each vertex as the project was loaded sufficient for the project to clear that QMV15 boundary. Lo and behold, the "outside rectangular area" was no longer there.

TS Pro follows the SDK recommendation of using QMV11 clipping in the absence of freeway data and there is no freeway data in your project. Nonetheless, I tried using QMV15 clipping with your project and all is well, i.e., there is no "outside rectangular area". So, it would seem that one or both of those other apps has an undocumented sensitivity to projects lying over a QMV15 boundary.

I will modify TS Pro to check for QMV15 boundary overlap and re-release later today.
 
Hi Don, as usual, you have done a great Job once again! Cordial thanks for your great efforts! I will download the new Version and do some testing this afternoon.
 
Hi Don, as promised, I did some testing and it Looks much much better:

7AK Akutan Harbor-2.jpg


one Problem I found is, that there where water should be is land:

7AK Akutan Harbor-3.jpg


7AK Akutan Harbor-4.jpg


TmfViewer-4.jpg

But it can be also my mistake, because of the proximity to the sea and perhaps a wrong usage or understanding of TS Pro. I had to make some Excludes, because in the Flight Simulator the Harbor was not part of the Standard scenery, the Harbor was built in 2008. I had to add Water-Polys in order to get water there.
 

Attachments

Hi Folks, the following Picture shows how much help Terrain Sculpture Pro (TS Pro) can be for the Terrain Builder as compared to the first Picture above::

7AK Akutan Harbor-5.jpg


The Hovercraft is the one from the "Cambria Icefield Research Project" or CIRP-Project over at Return to Misty Mooring (RTMM): https://return.mistymoorings.com/
 

gadgets

Resource contributor
Glad things are improving. Re the absence of water, from a brief inspection, it seems water is missing only in those areas not included in the two exclusions. Try extending one of them.

Don
 
The strange thing is, that it only happens with the from TS Pro created CVX-file. If I remove the from TS Pro created CXV-file and only use the one from SBuilderX, everything is again ok. The difference between the two files should only be the additional triangulated and other flattens created by TS Pro. But anyway, no need to hurry, I'm thinking of rebuilding the whole thing anyway. SBuilderX is a good tool, but sometimes drives one crazy, because there is no locking-mechanism and no selective Hide-function for individual objects. You just want to move one vertex, without notice, sometimes the whole polygon is moved, thats another reason why I became gradualy frustratet. If I would be 25 years younger, I would look at SBuilderX and implement those functions. I would also, like in ADE, add a listing function with Attribute Display and Manipulation and the capability to draw Helper-Shapes.
 

gadgets

Resource contributor
I have confirmed that extending the large exclude so it overlaps the smaller one results in all the expected water appearing.

Unfortunately, TS Pro (at the moment) won't allow you to do that in the usual manner since the exclude uses an empty guid (all 0's, exclude everything) and TS Pro doesn't recognize such an exclude. (Presumably, that exclude was imported from SBuilder.) That may also be responsible for the differing results between TS Pro- and sBuilder-generated .bgls.

I have temporarily added such an exclude to TS Pro and that seems to have fixed the issue - on my system at least. That version is now available as the latest Development Release from http://stuff4fs.com. Assuming it also works for you, I'll implement a permanent fix over the next few days and re-release generally
 
Once again, you are the greatest! Thanks a lot for your great efforts, I will download and test the new Change. I wish you a very relaxing and enjoying Weekend.
 
Hi Don, testing with the new Version did not change anything, still Land there where water should be. I did also extend the Waterpoly further into the Waterregion, as you suggested, same negative result!

TS Pro Triangulation Result-2.jpg


I have attached everything to this post here:
a) the scenery
b) the SBuilderX V3.15 Project files
c) the TS Pro relevant files

by the way, there is no Copyright on this material, it is free for use!

There is no hurry, this is a Freeware-Project, so there is no pressure!
 

Attachments

gadgets

Resource contributor
That's unfortunate. The attached .bgl file (compiled with 0.1.10(a) on my system from the project files you sent earlier) displays in PV4 (on my system) water in the areas shown as missing in your earlier post. Please check it on your system.

Also, please send me your .bgl file so that I can see how it displays on my system.

Incidentally, I had asked you to extend the large exclude, not the water poly, not that it should have made any difference.

Don
 

Attachments

Hi Don, I need a psychiatrist soon, this issue makes me maniac! None of the ones I did send you worked here, I can assure you, the one you sent me back worked perfectly:alert:
Please find attached a collection of the non-working ones. The test with the Extended exclusion, I will do that tomorrow. It is getting late here and I'm embarrased and exhausted now.
 

Attachments

gadgets

Resource contributor
Conrad, both .bgls you sent work on my system - which is PV4 "from the box", i.e., no addons So, it would seem that there's something on your system that is preventing proper display of your .bgls. The first thing to look for are any addons the affect the area, in particular, the terrain. That would include ORBX Pacific Fiords and any more localized offers such as Holdger's Tongrass Fiords (which I recall you mentioning earlier). Please disable any such addons and try again.
 
Problem recognized and solved!!!!

Hi Don, I was already in the bed as certainly it clicked and someone called "Heureka". There, I climbed again from the bed, started up my Computer and run TS Pro again, started FS and made a test. Here is the reason for the Problem:

TS Pro Prompt-3.jpg

That was it!!!!! Perhaps a note in the message could warn the user. I feel so sorry, causing you so much work and stealing your time! Thanks so much for all the help and efforts!!!!

Edit:

This Problem is directly related to Scenery-Addons, like Don had suspected, because with FS "Out of the Box", or a virgin FS, such Users didnt have this Problem! So this fact has to be considered!

End-Edit:
 
Last edited:

gadgets

Resource contributor
Not clear why that action, by itself, would have caused this particular problem, but I'll take the "win" anyway. As you suggest, I will update the user manual for the next release which will allow you to manipulate "exclude all" polys.

All's well that ends well. We did identify a couple of issues in TS Pro along the way, so it was a worthwhile effort.
 

gadgets

Resource contributor
The underlying cause of the earlier reported issue has been resolved in General Release 1.1.00 - just posted to http://stuff4fs. Terrain "Exclude All" can now be selected from the Terrain List.
 
Top