Textures not working in MCX

#1
Hey everyone,

I stumbled across this failure and can't really solve it. I was exporting a .dae file from blender, as usual loaded a .dds file as a texture. Could anyone help me, please? I would appreciate every kind of help. :D

Nieggou
Fehler_06022018.PNG
 
#2
Check the folder that blender placed the dae file in , then check where the dds file has been placed. Its very possible blender created a folder inside the dea file folder. If it has done that copy the dds file from the new blender folder and paste it in the same folder as the dae file is. Next import again. The textures
Will fail to load. Open the material editor and scroll down to defused again. Use the browser (3 dot box on the left) search the dea folder then for the dds file and select it. That should update and the texture(s) load again.
 
#3
Mhh :/ maybe I'm doing something wrong? I think that doesn't work. Maybe some other ideas? Anyways, thanks for your fast reply :)
 

Pyscen

Resource contributor
#4
Hello...

Where is the dae file located? and where is the dds file located.... they should be... mostly likely in the same location or folder.... Blender doesn't create a different folder
 
#5
If Blender doesn't create a root folder (no info on that as I don't opt for it , I use sketchup) then in the first instants if you save or export a model check where it's being saved/exported. Then navigate there. Also run a file search using a *.dae as the search criteria. Blenda settings will also have its save folder name and export folder name if my old memory serves me right. I'd start at the save/ export option first
 
Last edited:

Pyscen

Resource contributor
#7
Hello...

Did you have textures in Blender that were viewable? How was the texture created? The dds file?

I assume the above image, the model with checkerbox, is the place they are in at the time the dae file and texture was created through Blender?

Move the dds file with the dae file.
 
Last edited:
#8
I think doug may be on to something here!

However, I can open the model itself in Blender, Sketchup and MCX

The accompanying DDS file will not open in DXTBMP at all. - The file name for that DDS bears no resemblance to that of the model, not that it naturally does, but by using naming conventions it may be that you name the texture e..g HANGER_1_TEX or something like it so you can trace it after. This is especially important if you've a number of projects on the go at the same time

Ive attempted to bring in that texture to MCX but its not having any joy! - I just get the familiar checker effect.


From my distant memory Blender doesnt have a DDS file extension in its save options ( Im sure someone will correct me on this one) - It has BMP, Iris, PNG, Jpeg, Jpeg2000, Targa, Targa Raw and Tiff - It used to default to PNG when exporting the texture -

Are you using a DDS plugin for blender?

Is this a model that you made yourself or is it one from a site that was downloaded?

Its nice little Model pity the Textures are not playing the game
 
#9
mh.. I think, I messed up creating the dds-file.. I converted it online, 'cause I didn't really have anything working to convert my textures.. but I exported the .dae file related to that .dds file.. and the model's mine, so it's not relating to any other textures..
 
#10
Right . best option I,d say is export the sea again. Set blender jpeg for textures. Name textures something commencing with hang_roof, hang_front if it will allow this. It will help if they all save separately.
Import in to mcx and use the highlight feature to check all textures are on the right faces. You then have the option of duplicating the day time textures and renaming each ending with _LM to show it will be a night texture. Edit that file in a paint package so you have a darker version plus light effects for your night texture.

Use mcx to convey all textures to dds. Then you can either export as as model or bgl file.
 

Pyscen

Resource contributor
#13
What was the texture filename after you had exported to the dae file? That's before you had converted the texture to a dds file. Btw... What version is Flight SIM is this for?

Replace the dds file with the texture file that was with the dae file within MCX (make sure the texture and dae is within the same folder). You should have the texture showing... then convert the texture through the material editor in MCX to a dds file. Make sure to export after the model after converting the texture.
 
Last edited:
#14
Nieggou, dont worry about what it look like now. We ALL have to start and develop skills. As you learn Im sure youll go back and tweak all youve made.

Try and follows dougs advice here
 
#15
It should be for P3D v4, but when I open the .dae file up, the Hangar's white, and when I apply the texture, it gets that black-white texture :/
 

Pyscen

Resource contributor
#16
Show a picture of the dae file loaded and the material editor showing the texture please...

Before trying to change the texture to the dds... there should be a texture in the diffuse slot...If nothing is showing in the diffuse slot... then what you need to do is re export it... within blender.
 
Last edited:

Pyscen

Resource contributor
#18
Hello...

As I suspected... as I said before, if nothing appears in the diffuse slot in MCX, you will need to make sure on export in Blender that the texture is saved along with the model. The Texture wasn't uvmapped on the model correctly. Therefore, it makes no difference what texture you try to put in the diffuse slot.

If the problem persists within Blender... seek help within the Blender Forum here...

https://www.fsdeveloper.com/forum/forums/blender.136/
 
Last edited:
#19
Thanks! Now it's working in MCX. I'm dumb.. I thought, Blender would create a link to it if I would load it up in Blender.. so.. but now I've got another problem: The texture I applied is corrupted in P3D

1518575956329.png
 
Top