• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

This Model Does Not Import Correctly

Messages
946
Hi

I'm trying to import a KBHM New Terminal into Blender for MSFS 2020 but it's not working correctly. I've imported several Collada files into Blender and they all worked fine. I've never seen a weird problem like this before. Here is a screenshots of my model in Sketchup that I'm trying to import into Blender:


Imported Collada Model in Sketchup.jpg


I exported the model from Sketchup as a collada file. Then I Imported the file into Blender. Below are 2 screenshots that show what the model looks likes:




Imported Collada Model in Blender_1.jpg


The lines that look like guide lines in Sketchup were not there at the time of export. They were all erased. It doesn't look like the complete model was imported, or some of it is missing.




Imported Collada Model in Blender_2.jpg


Here, the model doesn't show correctly and I cannot even zoom out to get a wider view. If I try to zoom out any farther than I am now, the model disappears. It has not done this before. I don't understand why it's doing that. Apparently, I've most have done something wrong in Sketchup to cause this problem. What are some of the things that would cause this to occur when importing a collada model file into Blender?


Ken.
 
Last edited:

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
You might try using MCX as a go-between. Import the model to MCX and then export as OBJ or glTF. Then import that to Blender.
 

=rk=

Resource contributor
Messages
4,408
Country
us-washington
Indeed, when I import Sketchup models directly into 3ds Max it just causes havok, despite the fact 3ds Max has a native .skp importer. I'm still more comfortable modeling in Sketchup, but to animate and complete the model for gltf export, I have to remove any mapped textures, export to .3ds, import with MCX, re export to .3ds, before importing to 3ds Max, to be sure to remove all the oddities and unwanted transformations.
 
Messages
946
You might try using MCX as a go-between. Import the model to MCX and then export as OBJ or glTF. Then import that to Blender.

Thanks Dick. I can import the files now and the model looks correct. But the problem is that when I export the files from Blender, it doesn't export all of them. It only exports a gITF file and an xml file. There is no bin file nor a texture folder. But when MCX exported these files, it exported all of them. It exported a gITF file, a bin file, an xml file, and a texture folder with all the textures. When I exported all my other projects from Blender, I always get a gITF file, a bin file, an xml file, and a texture folder. Should I be getting a gITF file, a bin file, an xml file, and a texture folder?

Ken.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
Should I be getting a gITF file, a bin file, an xml file, and a texture folder?
I would think that, as well. We're just guessing now. You could zip the source files and attach to a post, or give us a link to a zip containing the model and textures.
 
Messages
946
I would think that, as well. We're just guessing now. You could zip the source files and attach to a post, or give us a link to a zip containing the model and textures.

Hi Dick,

Did you want a Sketchup file, a collada file, or the files that were exported from MCX?

Ken.
 
Messages
946
I had no problem importing the gltf to Blender, exporting the files, and saving a .blend files that can be opened, rather than imported. Here's the .blend file:
KBHM New Terminal Project.zip

Hi Dick,

I also had no problem importing the files into Blender. But when I export them, it doesn't export all the files - a bin file, a gltf file, an xml file, and a texture folder with all the textures. It only exports a gItf file and an xml file. See the winzip attachment below:


For some reason, it's not exporting a bin file and a texture folder. The file you sent me has all the files - a bin file, a gltf file, an xml file, and a texture folder. Why is my Blender not exporting a bin file and a texture folder? I must have something set wrong in Blender.

Ken.
 

Attachments

  • My Exported File From Blender.zip
    1,014 bytes · Views: 40

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
Maybe a screen shot of your Asobo multi Export tab showing settings and another showing objects Or just save a .blend file of your failing export?
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
In the view Layer panel to the right:
left-click node13, then SHIFT-left-click node0 to select all the nodes. Right-click and move the nodes to KBHM_New Terminal Collection. Then you are OK.
In the exporter, you selected the collection, but there was nothing inside it, so it compiled nothing. Part of the Blender journey...
 
Messages
946
In the view Layer panel to the right:
left-click node13, then SHIFT-left-click node0 to select all the nodes. Right-click and move the nodes to KBHM_New Terminal Collection. Then you are OK.
In the exporter, you selected the collection, but there was nothing inside it, so it compiled nothing. Part of the Blender journey...

Hi Dick,

I think I got it now. I've noticed that with all my other files, and I import them in collada, they were in Collection. But when I imported the gltf file from MCX, it was under, or outside the Collection. Even though I re-named Collection to KBHM_KBHM_New Terminal, it was still outside of Collection. So, I need to make sure that my files go to Collection and not outside of it. Thanks so much for all your help.

Ken.
 
Messages
946
Hi Dick,

I'm just curious. Why is it that when I import my gLTF file into blender that it goes to the wrong place, outside of Collection? Is it because I need to set the export preference in MCX or set the import preference in Blender? There must be some reason why it does that. Could it be the version number I'm using? I'm using Blender version 3.1. What version are you using? I know 3.6 is the latest version but I've heard that the MSFS2020 gltf 2.0 will not work in versions overs 3.3. But I don't know if that's true.

Ken.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
It's just how Blender imports gltf. I haven't had problems importing on any version of Blender.
I've found the best exports from MCx are plain gltf, without the Asobo extensions. The PBR imports OK, vertex colors are correct, even Decals are OK. Some things like PArallax would need to be set in Blender's Asobo panel, but the Standard can be ignored. Plain gltf displays just fine in MSFS.
 
Last edited:
Top