• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Trying to get Prepar3D 1.4 SDK to work, having an issue

Hey all,

I must have done something wrong the last time I reloaded the 1.4 SDK. For some reason, the tool set will not fire up in 3ds Max.

I use 2014, and it worked fine in the 2012 SDK (way back then) but now for some reason, its not.

Any suggestions?

These are screenshots of the error messages during 'one' bootup of Max.

Just now looking at BaSys' quote on the readme of this section. Is posting this here allowed? This is the P3D SDK, not the FSX SDK. :S
I decided to try to reinstall it. I didnt find it at Prepar3d, so I went here in the resources department and found the link to it.
Downloaded, removed it, then reinstalled it.

Booted up this time with only one window error popup; Missing DLL for Prepar3D. ?

This causes the tools to not work. But at least its booting up smoother without half a dozen error messages. Getting closer.

I wonder if bringing DLL's over from V4.5 to V1.4 will work? No explosions will occur, will there?

This is what I get when I boot up the Animations Manager or Attach Tool.
In the SDK pack for V1.4, there is a file called 'ConfigSDK.exe'. I remember in FSX we would click that and it would setup the SDK to the various locations on our computers to the right files. I ran this just now. 3 times... It asks 'yes/no' for your permission to link or setup the configurations on the 1.4 SDK. I clicked y and enter. I tried yes and enter also. When booting up Max, same message, and when accessing Animation Manager, it still doesnt know how to handle that, and Animation Manger is a white window with nothing in it. :(

Any idea's?

It used to work. I wonder what happened....
I remembered a bit ago. I can run a V4.5 through MCX and convert to FSX which MCX uses the V1.4 to do the conversion. There was an issue of tooltip errors when I ran it last. That is my active option right now.

I wonder if its possible to repair tooltips inside the MDL file?

Has anyone ever worked on coding inside a MDL file? Is it a HEX file? (see how much I know? lololol... )
Your 3DS 2014 is 32 bits or 64 bits ? If I read right on the 5th image you use 2014 - 64 bits.
To work withs the SDK of P3D v1.4 ... I think it should be 32 bits only !
Thanks Lagaffe. I had noticed that too. But I was using this before. Perhaps when I had reinstalled it I used an older backup.

When I re-installed the SDK yesterday, I believe the auto-installer installed a 64bit version this time. The error messages about 32bit went away. Now it only says it needs DLL's. Still not working, but most all of the errors have left.
IT WORKS.............................!!!!!!!!!!!!!!!!! :)

I went in to install my own personal updated (massive) ModelDef.XML, and found it didnt have one. For some reason, the installer didnt install a new ModelDef. Working. :) Booted right up, Animation Manager working excellent.

Sorry to bother you all... Except you, Tom. I learned about Scoooot-lahn..
Well, it doesnt work. Seems if you re-route your Addon Tools to the other Plugins folder, you need to reboot Max. It was using-running on the V4x Plugins folder. When you boot up again with the V1.4 plugins folder selected, it still isnt working. Screen doesnt show for the Animation Manager and Attach Tools.



Resource contributor
Does Max 2014 have this feature where you can define multiple locations for modeldef.xml file? It's found in File/File Properties/Custom tab. Since this is stored as a per project definition, it allows one to keep a specific modeldef.xml file in the same folder as your .max file! :cool:

Does Max 2014 have this feature where you can define multiple locations for modeldef.xml file? It's found in File/File Properties/Custom tab. Since this is stored as a per project definition, it allows one to keep a specific modeldef.xml file in the same folder as your .max file! :cool:

Hey Bill,

Thanks for the heads up on this. I do not see where I can enter this in the list, nor is the ModelDef listed in mine. Looks exactly the same as this, but ModelDef isnt listed.


Resource contributor
Try entering a "Name" and "Add" (or vice-versa)
Enter the exact path to the modeldef.xml in the "Value" box. Use file explorer to copy/paste the path, then add \modeldef.xml manually to the end of the path.
Click on OK to complete entry.

Note in the example I posted that there are two possible locations that will be searched. If not found in either one, then Max will look for the complete path normally entered in the Customize tab.

I know nothing about 3DS MAx but,

All recent versions of 3ds Max (2016/2015/2014) require 64 bit. The latest version for 32 bit is 3ds Max 2013.

So if you download ver 3.x of the SDK will that give you a version of the MAX files you need to run the 64-bit MAX?

Sine ver 3.x SDK is still 32 bit, it has some files for 64 bit MAX.


NOTE - copy from my answer on P3D forum.
Hey Ron,

It has to be specifically P3D SDK 1.4.

The Lockheed team did create a 64bit version, and I think the installer has a built in 32bit or 64bit version auto select installer, so if you run the installer, it installs the version you need. But its not working. And... it shouldnt be asking for 32bit files... So maybe I have the pre-64bit installer.

I tried to download the Lockheed version from their link on that post I found, but it no longer exists. It was taken down.

A shout out to anyone that has the 3ds Max 64bit version installer for the P3D SDK V1.4. I would be massively grateful.