• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSXA TS does not import BGL file

Messages
606
Country
germany
Hi Don,

Today I tried to import a BGL file from FSXA that I'd just produced with ADE (of course the CVX containing the airport background). It seems that something happens as there is no error message and the imported file name shows up. Nonetheless the aircraft symbol disappears and there is no visible polygon. When trying to close the file TS tells me that there is unsaved data, but when attempting to save it the function is not available.

Further observations:
The aircraft is not repositioned (even if positioned correctly before, after booting TS, it's shifted to the North Pole without any effect on FSX).
When positioned via FSX or ADE or Plan-G above the airport, TS still doesn't show anything even if forced to show the respective airport area. --> see picture

upload_2017-8-6_20-13-16.png


It's strange, as existing projects are loaded successfully, but trying to import the related BGL that had been their base, failed as well. I do have the latest version of TS.

Regards,
Axel
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
I suspect it's got something to do with the "stuff" in the .bgl that TS knows nothing about. The import function is intended to import simply flatten files. The CVX files generated are likely to contain much more.

I'm away from my development system until at least tomorrow evening. If you don' get it working before then, please send me the .BGL file (and the .ad4 file so I can determine what's in thee bgl), and I'll take a look.

Don
 
Messages
606
Country
germany
Here you are, both files are attached. It's just a try correcting the airport's position (quick and dirty). The CVX contains a background exclusion, the airport flatten, and three LC polygons

However, I cannot remember experiencing such a problem before. However, it might have been good luck up to now.

Edit: I just compiled the project again after deleting all other polygons and it still doesn't work as it seems...
 

Attachments

  • VYPT_ADEX_AB.ad4
    16.7 KB · Views: 128
  • VYPT_ADEX_AB_CVX.bgl
    909 bytes · Views: 251

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
It looks like it going to be Wednesday before I return home. Try exporting only the flatten from ADE (i.e., temporarily delete the exclusion and the LC polys.)

It's not clear what you were attempting to accomplish by importing this file, since TS handles only flattens. (TS should have extracted the flatten and allowed you to edit it, but you would not be able to re-import it back into ADE.

Don
 
Messages
606
Country
germany
Don, I just want to re-use the already existent airport background poly to fit the airport into the waving landscape around. At the moment it's partly elevated and partly sunken. I'm not interested in importing any other poly-types at all. I'm using your nice tool from time to time without any intention to re-import anything into ADE. The whole thing is part of a measure preparing legs for a trip around the world for a couple of guys (online) striving to cover even some remote areas. This particular airport will be our intermediate station likely this week and I decided to work it out in ADE yesterday. However, it would be nice knowing what is going on here as specifically remote airports are often misplaced in FSX and the elevation had been realised sometimes by confusing Meters and Feet as it seems (not in this case - the default is wrong, nonetheless). Of course I would prefer reading directly ADE files (obviously a future function?).
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Sounds reasonable. But, you will have to separate the flatten from the rest of the polys. Otherwise, you will have 2 flattens (with all that implies). So, what I suggest is that you export all the terrain polys except the flatten in one CVX .bgl, and (after I investigate the current issue) load the existing CVX (or a .bgl containing only the flatten) into TS and do your thing with it. Then, of course, you would load the 2 CVX files into Flightsim.

I'll get to work on this ASAP.

Don
 
Messages
606
Country
germany
But, you will have to separate the flatten from the rest of the polys.
Indeed, after transferring the results into TS I usually change the airport background into a LC type poly or whatever fits in specific cases.
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Axel, I'm now back home and have run you .BGL file. As you reported. my screen also is blank.

I'll make a new release ASAP.

Don
 
Top