• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

TS Pro Alpha V0.025 Available for Evaluation

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
I have just uploaded TS Prop Alpha version 0.0.25 to http://stuff4fs.com. Navigate to the Terrain Sculptor Pro page and click the Development Release menu item.

I expect this to be the final alpha release of TS Pro. I had planned to make it the first beta release, but with the errors reported yesterday, I felt another alpha was appropriate.

Don
 
Messages
606
Country
germany
Don, I've started with loading an existent project, that had been imported from an ADE produced CVX and where the airport flatten was defined as "AB Flatten Exclude Autogen". It had already a blend poly outside and saved including a profile. Before triangulation I ran the profiling function again (unfortunately without deleting the existent profile), and surprisingly I suddenly saw a fraction of blend nodes only and the airplane never appeared on screen. As you can see, in the picture below, I didn't interrupt the process as the procedure took way longer than it would have taken with only a few nodes and got again a polygon shaped as previous one.
1520586163900.jpg


Then I started triangulation and got this result:
1520586565288.jpg


It looks like the central flatten is handled like single sculpt nodes. I tried to continue nonetheless, selected a single node of the yellow coloured flatten and changed it successfully via "Edit List/Node" to "AB Flatten". Unfortunately its neighbours remained untouched.

At this point I stopped proceeding, loaded the project again, deleted the profile, added sculpt nodes, profiled and triangulated and got nonetheless a picture similar as above.
1520592639832.png


After compiling it, the result looked like this (ADE's CVX was disabled, by the way).

1520592823430.png


Now I have to follow some other duties, but will try the procedure again, beginning with importing the ADE CVX file. Both exclusion are not touching the coastline, the central one excludes airport backgrounds, the second just roads.

EDIT: What I forgot writing: The new version didn't care for any previous settings. A bit later I saw why: "TS Pro.ini" became "TS_Pro.ini" in the new version.
 
Last edited:
Messages
790
Country
us-northcarolina
Tried this release. Now when I save the project and come back to it, the sculpt nodes have no altitude information and attempting to edit one throws an "unhandled exception"

Edit: Nevermind! Saved it as a separate project, now it appears to work!
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Jon, is there any way you can repeat the unhandled exception. If so, please send me the details. Re the initial problem, it would seem that your initial save did not fully replace the earlier data. I'll have a look at that.

Alex, I can't explain your issues with creating a profile. It appears like the process stalled or was interrupted, since the progress bar is still active. If you attempt to create a profile when one is being displayed, TS Pro should ask you if you want to replace the existing profile. It appears like the process stalled or was interrupted, since the progress bar is still in view. In 0.0.25, does ask about the existing profile -but only after it completes the new profile. (to be fixed).

Re the apparent triangulation of the flat poly, I can duplicate that. It would seem I missed something in the recently re-worked elevation handling.

Another release ASAP.

Don
 
Messages
606
Country
germany
Don, there are some issues, at least for me.
I've just created a fake airport with ADE as close to a lake (even closer) than above. It got just an airport flatten poly and a runway. Everything looked okay after compiling.

Now I imported the ADE-created CVX to TS Pro as a new project and wasn't able to save it as such (everything was grayed) until I added a single sculpt node (later I deleted it again).
Next planned step: creating a simple boundary. I selected Start -> Blend Poly List and got the message "A blend poly list exists" and whether I want to delete it.
I confirmed this and got the dialogue box where I was asked for the name (preset "AirportBounds 2" was given) and confirmed.
I added the vertices CCW and had to take care not clicking next to the line connecting the last node with the first one. The result is visible below.
1520616500203.png


Finally I profiled the blend poly and exported the result to a BGL.

Before enabling the test file:
1520617874642.png


After enabling the test file:
1520618108481.png


When disabling the file being compiled (exported) by TS Pro and re-booting FSXA the lake is complete again. I've nowhere used any exclusion, TmfViewer shows just innocent flatten triangles
1520618974445.png

and TS Pro loads its own file without any problem (surprisingly now the original airport background flatten not divided in triangles).
1520619024245.png


I added a ZIP for playing. It contains all files in compiled form and the non-profiled TS Pro project file. The scenery is only "enhanced" by old FSG Mesh. It's somewhere in Nowhere, west of UTDL (Tajikistan) at the northeast end of the Kairakum Reservoir. The airport has been placed about 600 m away from the shore.

EDIT: Wrong ZIP file exchanged against the correct one.
 

Attachments

  • TestCase.zip
    3.6 KB · Views: 186
Last edited:

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Thanks, Alex. Re the "a node already exists here" message, the way to complete the blend node set (and any other poly is to left click afer setting the last node.

I'll have to spend some time on then rest. It would be helpful to also have the .bgl you imported from ADE. (The .zip file only included the resulting project file.)

Don
 
Messages
606
Country
germany
It would be helpful to also have the .bgl you imported from ADE. (The .zip file only included the resulting project file.)
Oops, sorry - it had been even the wrong project. I've exchanged it now in my previous post. All ADE files and the project file are included now - as intended.
 
Messages
606
Country
germany
Re the "a node already exists here" message, the way to complete the blend node set (and any other poly is to left click afer setting the last node.
I've provoked the screeny by placing the "hot cursor" in the vicinity of the line pointing to about 1 o'clock from the last, red node in the related picture in my first post. It happens easily while placing the nodes on their way back to the starting point.
 
Top