• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Using MdlCommander and GMax

Messages
305
Country
us-california
Hello all,

I have worked for 4 hours browsing and searching endlessly, piecing together bits of information to figure out how to make ground polys with GMax.

What I figured out so far is that I needed to use MdlCommander since I dont have the FSExp.dll thing for FS2002. So, I downloaded MdlCommander and set it up in my Plugins folder for a seperate FS2002 Gmax installation.

Then I did everything they said to do, with the MyModel.par file and such.

However, when I export the scenery object the MakeMDL (FS2004 version is installed in the plugins folder) program pops up, so I set it as Scenery Object and check "Keep Files" in the options.

When I export it I only get 2 ASM files and the MDL. There is no .X file.

-Yes I did export the mdl with the same name as the .par (MyModel)

I also checked the 2 ASM files for the lines I need to edit to make the ground poly.
They aren't there.

So, could anyone tell me what's going wrong? I'm not getting any errors.

What do I need to do in order to get CORRECT asm files and then export it to BGL?
Please recognize that I have searched and experimented for almost 4 hours and I am out of ideas and links.


Thanks, help would be really appreciated and is needed!

-KObbe
 
Hi,

Did you put the line +savexfile in your par file? Without that line no X file will be saved.

It is correct that the ASM files you get now don't contain the lines you need to tweak, because you used the Fs2004 gamepack now. That is the reason you need to run that X file through the Fs2002 MakeMDL first.
 
Yes, that line is in the par file.
Its set as follows

+savexfile
+batch
+nocompile

Also, the "Plugins" in my FS2002 gamepack located inside of GMax is set up as:
181hk1.jpg


-I do have the FS2002 Gmax icon set to start up the FS2002 version, I open it first then I open the scenery object.

When I open the FS2002 game pack version of GMax I get this error, but can continue to open GMax:

2kf8.jpg



Thanks Arno
 
Hi,

You should use MDLCommander in the Fs2004 gamepack. As you don't have the FSModelExp.dle file for Fs2002, it does not really make sense to setup a Fs2002 gamepack folder.

All you need to do is export from the Fs2004 gamepack with MDLCommander and capture the X file. Then that file needs to be run though the Fs2002 MakeMDL manually.
 
AH!

I was tired last night so I didn't realize I was posting the wrong images. I read through so many different posts about this (And each time it worked for them) that I tried almost 18 different options to make it work. None have worked. So, yes I have used the FS2004 game pack from the start and it never worked either.

When I run it through the FS2004 gamepack the MDL Maker pops up
3hz0.jpg


I change hte MDL type to scenery object, then in the options tab I set "Keep Files". However, it doesn't keep the X file.

=====
This is the log from MDL Commander:
mdlcommander version: 1.03
(C) Doc Moriarty - 2002
original commandline:
argv 0 : C:\gmax\plugins\makemdl.exe
argv 1 : -b
argv 2 : -scenery
argv 3 : -xml
argv 4 : C:\gmax\meshes\kavx rwy\KAVX_rwy
no special parameterfile C:\gmax\meshes\kavx rwy\KAVX_rwy.par found
extracting mdlcommander parameters
looking for model: KAVX_rwy
calling mkmdl with: mkmdl -scenery -xml "C:\gmax\meshes\kavx rwy\KAVX_rwy"
created process: 1312
exiting mdlcommander with rc=0

What's going wrong? I did everything exactly the same as all the others.

BTW, I am making this for a sloping runway. The plane I made in GMax is flat though, will it mold to the surface of the ground when I place it in the simulator?
 
Last edited:
Hi,

Looking at that logfile, the PAR file was not found by MDLCommander. Did you save the PAR file in the same folder where you exported your MDL file to? And did you give it the same name as the MDL file?
 
Yes, I do have it named the same. However I don't add the .PAR extension since it says it doesn't know how to export that.

Here's exactly what my process is:

Fs2004 Gamepack Plugins folder set up as:
1-1.jpg


The Export Folder Set Up:
2-1.jpg


After select Export Scenery Model in GMax this pops up
3-1.jpg


I then select the Keep Files option
4-1.jpg


This is what I get after exporting... what's happening?
5-1.jpg



What's going wrong? It is set up perfectly.
 
Shouldn't the "Input File" for MakeMDL be an nnn.X file? Why are you trying to load a nnn.par file?
 
Well for one the .X file is what I want.
That MakeMDL thing pops up when I export. Not sure what exactly it is using as the input file because it doesn't specify an extension like it does with the output file.

I guess thats another path to explore...

---edit

Ok, I narrowed down the problem to the MDL Commander thing. It's the barrier. It won't work correctly, it doesn't keep the X files even if you ask it to. I tried doing this with Middleman installed too and it didn't work.

Anyone want to volunteer to get the .X file for me, from my GMax project?
 
Last edited:
It is very easy to see that you must not be setup correctly. When you export to save as an X file you should not see the REAL makemdl.exe pop up at all and the process is totally transparent. You will be compiling the finished product manually anyway.

Here are my suggestions.

It is a good idea to turn on file extensions or turn off "Hide file extensions for know file types" in Windows Explorer > Folder Options > View.

1.) Make a directory in your gamepacks directory.. ie:
C:\gmax\gamepacks\FS20024

You can name the directory anything you want just substitue your name where I have FS20024.... like it could be Gmax_2_X.

2.) Recreate the sub-directories in this directory. Most are not really needed but just to stay uniform. The important ones are in red:
C:\gmax\gamepacks\FS20024\backups
C:\gmas\gamepacks\FS20024\meshes
C:\gmax\gamepacks\FS20024\plugins
C:\gmax\gamepacks\FS20024\scenes
C:\gmax\gamepacks\FS20024\scripts
C:\gmax\gamepacks\FS20024\textures

3.) Place copies of these files in C:\gmax\gamepacks\FS20024\plugins
FSModelExp.dle (the one from the FS2004 gamepack, 165kb)
makemdl.exe (this is the renamed mdlcommander.exe, 34kb)

4.) Place your par file in C:\gmax\gamepacks\FS20024\meshes
My_Model.par

5.) The contents of the par file should be:
+savexfile
+batch
+nocompile

Note: you can use the same par file over and over if you export your model as My_Model.mdl each time, then just rename the captured X file to what ever you want once you have a successful export.

6.) Place copies of your gmax.ini and plugins.ini from your C:\gmax\gamepacks\FS2004\ directory in:
C:\gmax\gamepacks\FS20024\

7.) Make a new shortcut to launch gMax with. Name it:
FS20024 gmax

Edit it so that it points to this new directory for it startup options:

Target: %GMAXLOC%Gmax.exe -i gamepacks\FS20024\Gmax.ini -p gamepacks\FS20024\plugin.ini

Start In: %GMAXLOC%

Put this new shortcut somewhere handy. I have mine tucked away in my Start Menu since I don't use it all that much.

8.) Launch gMax with this shortcut. Once the program has loaded, you need to fix the paths under Customize > Configure Paths... General and Plugin panels. Modify them so they point to the NEW C:\gmax\gamepacks\FS20024\ directories instead of the C:\gmax\gamepacks\FS2004\ directories. Exit gMax.

Now when you want to save an X file, just load gMax with this shortcut. Open the *.gmax file you want to export as an X file and you should be good to go.

Lou
 
Last edited:
I think Lou made a good point with the hidden file extensions. I think your par file is actually named .par.txt, so that MDLCommander will not recognise it (it also has the icon of a txt file). So turn on the extensions and check if it is really named .par
 
Arno I have the two gamepacks but...

I have got to the point where I already have the asm file tweaked as you described in the Wiki... but what do I do with it? I tried making the tweaked file read-only and rerunning the job and it didn't seem to work....would you be kind enough to extend your tutorial in the Wiki to describe what to do after the asm has been tweaked?:p
 
Hi,

Check this guide on ASM tweaking at the Wiki. It explains how to recompile your ASM files into BGL or MDL files that can be used again as if they came directly from the exporter :).

So in this case you would have to compile the ASM file back into a BGL file, which can then be loaded in FS.
 
WOW!
You have GOT to be kidding me.. all this mess just over a .par.txt

Dang.

I saved it as .par extension with notepad, it doesn't work though, how do I make it .par with no .txt ending?

Stupid computers have to be so technical with me.. :rolleyes:
 
Right Click and Rename to nnnnnnn.par

WOW!

I saved it as .par extension with notepad, it doesn't work though, how do I make it .par with no .txt ending?

Open Windows Explorer

Highlight nnnnnnn.par.txt

Right Click and Rename to nnnnnnn.par
 
After you have turned on file extensions, in Windows Explorer, right click on the *.par.txt file and then select Rename. Delete the .txt part of the name. Hit enter, a warning window will pop up, just click Yes.

Lou
 
Is GMax always such a pain?

In the window explorer it's shown as a .PAR file with no .TXT extension, but export in GMax and it's shown as .par.txt.
JEEZ.



I have no clue how to fix that problem now,

I even tried the procedure Firestriker explained for the export, and it didn't work. Can someone send me their PAR file? Either GMax or my computer is being a brick barrier.
 
Last edited:
Did you enable the display of file extensions as suggested earlier in this thread? By default Windows is hiding them for you, which I think is stupid. It is one of the first things I change after I have installed a new windows.

So in your explorer, goto Tools -> Folder Options. On the view tab you need to make sure that the option "Hide extensions to known files types" is NOT selected.
 

Attachments

  • folder_options.jpg
    folder_options.jpg
    48.6 KB · Views: 469
Back
Top