• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

uvw unwrapped textures don't show correctly.

Messages
130
Country
puertorico
Hello,
I am trying to convert runway markings which use the uvw unwrap modifier in gmax, however once in MCX they don't show up correctly. The only textures that work are those which I have applied uvw mapping. Any assistance would be appreciated.
 

tgibson

Resource contributor
Messages
10,770
Country
us-california
I've never heard of an error like that, so I would assume the error lies somewhere else?

Keep in mind for best results in GMAX use 24 bit BMP versions of your textures.

Hope this helps,
 
Messages
130
Country
puertorico
All of the textures are saved in 24bit. Like I stated, the textures show up, they just are not properly wrapped like it appears in Gmax. take a look.

BTW, the edge lines do not use the uvw unwrapper, they are simply mapped, which is why they show up in MCX.
 

Attachments

  • Untitled-2.jpg
    Untitled-2.jpg
    81.4 KB · Views: 371
  • Untitled-3.jpg
    Untitled-3.jpg
    83 KB · Views: 403
Messages
130
Country
puertorico
Actually the problem was that the original image was not flipped and MCX flipps the texture. However, Now I have another problem. All of the geometry does not show up.
 

Attachments

  • Untitled-2.jpg
    Untitled-2.jpg
    79.8 KB · Views: 369

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,705
Country
netherlands
Hi,

Unwrap or not should not matter. But if you are using DDS textures (FSX gamepack), then you need to flip the textures. ImageTool does this for you.

I am not sure what you mean with your last post. Do you mean that some textures are missing after you using the ground polygon wizard?
 
Messages
130
Country
puertorico
Hi,

Unwrap or not should not matter. But if you are using DDS textures (FSX gamepack), then you need to flip the textures. ImageTool does this for you.

I am not sure what you mean with your last post. Do you mean that some textures are missing after you using the ground polygon wizard?

Thanks for the reply Arno, but I actually just fixed the problem. You see, I had mirrored some of the planes, instead of playing around with the UVW to get a more dynamic scenery and make it look less copy paste. Apparently, MCX does not like mirrored planes for some reason, or perhaps the sdk doesn't like them.

either way, thanks for your time. You can close the thread if you like.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
31,705
Country
netherlands
Hi,

I think it will be an SDK issue. If ModelConverterX can not display the object correctly, it often means that FS will also not load it.
 

tgibson

Resource contributor
Messages
10,770
Country
us-california
Hi,

If you want to mirror something in GMAX, do NOT use the big mirror button at the top of the screen - this will cause polygons to be flipped in FS (and apparently in MCX). Use a Mirror modifier added to the stack instead.

Hope this helps,
 
Messages
168
Country
italy
Guys, my texture don't show up in MCX after exporting via 3ds max. Any help?

I can only see checkkered faces (black and white) but no texture, I toggled on the appropriate function "texture faces render mode".
 

Pyscen

Resource contributor
Messages
2,850
Country
us-texas
Hello...

If it is the black & white checkerboard that your seeing... That would suggest that that particular texture is not located along with the others....
 
Messages
168
Country
italy
Doug thanks, solved. I didn't export textures in .dds format in the same folder that store the .X model.

Now works perfectly.
 
Top