• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

VGDS tweaker - safegate

Hi to all.
Problem using VGDS tweaker in FSX. I have created a mdl file using Safegate no actigate version, and compiled with BGLComp ( FS9 ).
I can see the object in the simulator, but it is still diplaying only TOO FAR and STOP, and the 2 lateral bar are not working ( still unlighted at any distance of the aircraft from the system ).
What's wrong ?

Thanks for any suggestion.
Ciao
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Did you place the system with the same heading you used when creating it in VGDS Tweaker? These need to match exactly.
 
Hi,
Did you place the system with the same heading you used when creating it in VGDS Tweaker? These need to match exactly.
Yes, I did. To be sure i have repeated all the sequence but nothing change.
Here below my xml file used to compile.

<?xml version="1.0" encoding="ISO-8859-1"?>
<FSData version="9.0" xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xsi:noNamespaceSchemaLocation="bglcomp.xsd">
<SceneryObject lat="45 11.13" lon="7 38.80" alt="6" pitch="0" bank="0" heading="270" altitudeIsAgl="TRUE" imageComplexity="NORMAL">
<LibraryObject name="7A359DA1BE974604ADC44716F49BAF0D" scale="1.0" />
</SceneryObject>
<ModelData name="7A359DA1BE974604ADC44716F49BAF0D" sourceFile="safegate.mdl" />
</FSData>
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

That looks OK. So in VGDS Tweaker you entered a heading of 270 when creating the MDL and in the XML also. That's all that is needed normally. It would be better for your reference to keep the heading in the filename btw, that can prevent mistakes when placing them.
 
Hi,
That looks OK. So in VGDS Tweaker you entered a heading of 270 when creating the MDL and in the XML also. That's all that is needed normally. It would be better for your reference to keep the heading in the filename btw, that can prevent mistakes when placing them.
Thanks Arno for suggestion, but now what i can do or check to solve the problem ?
I also did another test by using a Safegate instead of Safedock with same result.
For your reference i am using FSX SP2 and SDK Sp2 on Win Xp Sp3

Good day
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

I have run out of ideas a bit. Last time I tried it they just worked fine. Maybe you can post the MDL?
 
Hi,

I have run out of ideas a bit. Last time I tried it they just worked fine. Maybe you can post the MDL?
OK, but i will do only tonight, the mdl file is in my home computer, and now i am in the office.
Thanks.
 
OK, but i will do only tonight, the mdl file is in my home computer, and now i am in the office.
Thanks.
Here the mdl file, and this the basic parameter : lat="45 11.13" lon="7 38.80" alt="6" pitch="0" bank="0" heading="270"
 

Attachments

Last edited:
Here the mdl file, and this the basic parameter : lat="45 11.13" lon="7 38.80" alt="6" pitch="0" bank="0" heading="270"
I don't know what i did, but know is working fine.
Just a question : no other chance for a fine placing than the coordinate in XML files for bglcomp ?
I have to move 1 mt right and 1 mt forward, but by reading the position in FS they are still same also in the new position.
Can ADE9x in FS2004 mode help me ?

Ciao
 
Top