FS2004 WARNING! Installing FS9 ATC SDK prevents any BGL compilation!

#1
Hello,

As the title suggests, I thought I'd just leave a warning here for anyone who designs scenery and whatnot for FS9 and still isn't aware of this (as I wasn't until today).
If you have msxml 4.0 installed in your computer (required for basically everything that compiles bgls. ex: ADE, MCX and so on) and running fine, be advised that installing the ATC vociepack SDK for FS9 will screw up the registry of msxml 4, and if you try to compile a bgl with any tool, you will most likely get the "INTERNAL COMPILER ERROR 1003". Also the solution of this problem is not extremely complicated, but it's still a bothersome and involves command prompts!
If you have already made that mistake and want to know a solution, or if you just want to read more about it, you can do so in the following threads: https://www.fsdeveloper.com/forum/t...-msxml-4-bad-install.73172/page-3#post-221527 & https://www.fsdeveloper.com/forum/t...ng-help-internal-compiler-error-c1003.442259/

Leonardo
 
Top