• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSXA What a wrong?

<Element>
<Select>
<Value>
(A:SIM ON GROUND, bool) 0 == (A:ENG COMBUSTION:1 , bool) 1 == (L:goxy_running , bool) 0.5 &gt; &amp;&amp;
if{
if{ 0 (>L:g_oxy_run2 , number) 0 (>L:g_oxy_run3 , number) 0 (>L:g_oxy_run4 , number) 0 (>L:g_oxy_run5 , number) 0 (>L:g_oxy_run6 , number) 0 (>L:g_oxy_run7 , number) 0 (>L:goxy_sound , number) 1 (>L:g_oxy_rel , bool) 0 (>L:goxy_running , bool) 0 (>L:goxyair , bool) }
-2 2.99 (A:G FORCE , Gforce) rng (L:goxyair , bool) 0 == &amp;&amp;
if{ 2 (>L:goxyair_sound , number) 1 (>L:goxyair , bool) }
I want to ring immediately after the start of engines
.... But not sound
 
You have no command to play the sound file in there.
you have the "if" but you lack the "then". I don't know if this is correct, but I think that's the problem...
 

n4gix

Resource contributor
You have no command to play the sound file in there.
you have the "if" but you lack the "then". I don't know if this is correct, but I think that's the problem...

The contents between the curly-braces are the "then!"
(condition true) if{ THEN }

XML does not support sound, at least not without a "helper module" such as Doug Dawson's dsd_xml_sound.dll or my commercial sound module.
 
The contents between the curly-braces are the "then!"
(condition true) if{ THEN }

XML does not support sound, at least not without a "helper module" such as Doug Dawson's dsd_xml_sound.dll or my commercial sound module.

Oh, sorry... I knew that, I just didn't express myself correctly... I meant he didn't have any "then" to activate the sound, which XML doesn't support... :D
 
thanks for the replies, I'm using dsd_xml_sound.gau for testing but I'm concerned
n4gix' form depending on how the work will come out :) I think I miss something in the script, or in the config about panel.cfg
 
in the panel.cfg
gauge16=*_sound!dsd_xml_sound3, 1,1,1,1 .\SimObjects\Airplanes\*.*\sound.ini
gauge17=name0fgauge, 0,0,1,1
Is it correct?
 
Last edited:
Top