• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS What causes shimmering of Blender made object

Messages
663
Country
australia
Firstly since I updated MSFS when I compile/build my project I now get the following error
ade build error.jpg

ADE then prompts me to copy to MSFS (which I do).
Is this a known issue? What do I need to fix it? Sorry if I have overlooked something posted earlier.

Also
I have recently created a floating dock in Blender and exported the correct files for MSFS and included the object in my ADE project and compiled to bgl for MSFS. Problem is that in MSFS the planking on the top of the floating dock shimmers.
What could cause this? Would spacing the planks (they are currently about 3mm apart) further apart fix this? Or is it more likely to be the (timber) texture image I used? Or is this related to the above?
I would attach a short and small (filesize) video file but cannot see how to do that.
 
Messages
557
Country
france
Hi John,
If you see scenery examples of the SDK you can find :
- several files under the root directory of the scenery: layout.json, MarketPace.json and Bussiness.json
Theses files are created and populated during the compilation via fspackagetool.exe. They are defined under PackagesDefinition.

A glance on the examples of the SDK is the first step before creating scenery.
 
Messages
663
Country
australia
Thanks Didier.

I had no errors a few days ago using exactly the same ADE project. Obviously ADE 'calls' a compiler (fspackagetool.exe?) to 'build' the project and create all folders and files required in the community folder. The compiler must have changed. I rely on ADE to 'build' these files which it was doing ok until a few days ago.
Also every other project I now try to 'build' has the same error. Everything the same (Ade project, Ade version) except that MSFS was updated yesterday.

I don't understand much about SDK except what it is for and have had no reason to have to work with it in the past.

I look forward to what Jon has to say.
 
Last edited:
Messages
663
Country
australia
I just read another thread (ADE crashes with new MSFS2020 update) and Jon had commented "There are warnings about a missing folder for Market Place but that is not affecting the build".
So it appear to be a known 'problem' which doesn't affect a 'build'.

Now please I would like a comment on why my scenery object 'shimmers' in MSFS. I have attached a zipped up very short video to demonstrate what I mean.

 

Attachments

  • dock1_04.zip
    1.4 MB · Views: 24
Last edited:
Messages
557
Country
france
Theses two warnings : Error@misc are due to the new compiler/packager (fspackagetool.exe).
I have also some news warnings with my aircraft version compiled with the last SDK. But this is warning message not error message since I can launch my aircraft without problems.
Theses warnings are for payware editors in order to solve all mistakes in their products. They had only ruggedized the warning steps
 
Messages
663
Country
australia
Thanks again Didier. Yes I now realise that they are not error messages merely warnings.
I would still like to get some ideas why my scenery object 'shimmers'.
 
Messages
585
Country
us-florida
I would still like to get some ideas why my scenery object 'shimmers'.

Shimmering usually occurs from two textured surfaces too close together and the display alternates between the two textured surfaces. Your video doesn't seem to show this in the manner it is usually seen, and I have no idea what textured surfaces are in your model. You mentioned individually textured planks in the dock which could result in shimmering between the texture on top of one plank and the side texture on the adjacent plank.
 
Messages
663
Country
australia
Thanks. I will try another timber texture and also the 'offset' (of the image of adjacent planks).
 
Messages
585
Country
us-florida
My approach would be to just have a flat surface on the dock and create the look of planks with the texture, even using alpha in the texture if I wanted to see through at the cracks.
 
Messages
1,045
I have seen this with a couple of default objects, mainly a timber stack, which I would think was very similar to your model. Looking at it now, it isn't so much of an issue, which probably means that either the sim itself or my settings have changed. It seemed to me that this was an issue rendering shadows, so art209's approach makes sense -- have less geometry overall.
 
Messages
663
Country
australia
Thanks art. I was starting to think of what you suggested and will look at that when I get home from my railway adventure tour. That would also reduce the vertices.
 
Messages
663
Country
australia
I replaced all the individual planks with a cube and applied an image of wooden planks and no more shimmering.
 
Top