FSXA What drives engine sound?

#1
Hi


I've made the sounds for my plane in FS Sound Studio. Inside the program everything looks good, but in FS at full throttle ( rpm is 2750 ) I can hear the 2000 rpm's sound. Idle speed is O.K.

As I know the engine sound of a piston engine controlled and mixed by the engine rpm variable and the values in the sound.cfg file. I projected the rpm value to a test panel in FS with text, it is good, as the rpm gauge shows correct value also

Is there any other variable that drives or can drive it?
 
#3
Hi, do you hear it on top of the 2750 sound, or does the sound only get to 2000 at full throttle?
At full throttle the rpm is 2750, but the sound "makes" only approx. 2000 rpm. I can compare the sounds in FS and in Sound Studio. So I can't get the full throttle sound in FS.
 
#4
Ok, there's another secret to be uncovered somewhere. and it may relate to gaspen's problem.
If I'm in vc view and run an engine [or all of them] to say 2000rpm, then back to idle without changing views, all is ok and I can switch through outside view and back to vc with no problems with the sound.
The same is true for starting in outside view.

But, if I run the engines up while in vc and cycle through outside view then back to vc, then bring the engines back to idle, if I then switch to outside view - all is ok, but when I come back to vc the engines are now stuck on the rpm I intitially brought them to.
Revving the engines up or pressing Q fixes the problem, but it's only temporary.
The same is also true if you start in outside view. Vc will now be ok but outside view will be roaring engines.

I loaded up the realair c172 and tried the same thing with it and there were no problems, perfect sound under all conditions, so I exchanged the b24 sound folder for the realair's and the b24 behaved perfectly....hmmm
So then I back up and mass deleted my b24 sound.cfg back to a single engine including number of engines = 1, but still the problem was there!!

So now I'm comparing the structure of the two cfg's to figure out why the 172 doesn't suffer the same problem.
There are a few differences such as non combustion in the 172 file and they're also using [prop] with flags 2 and 4, which as best I can tell is meant for variable pitch props :confused:

There are some structural differences but according to msdn esp, this shouldn't matter.
One thing's for certain, you can't have two parameter sets referencing the same wav file, that's instant roaring engines, at least on muti engine planes.


edit: Were I said -
"I loaded up the realair c172 and tried the same thing with it and there were no problems, perfect sound under all conditions,...",
this is not entirely true, it has a problem also - see post 10
 
Last edited:
#6
Here it is

VC :

Code:
[2000_b]
filename=zlin_b_2000
viewpoint=1
panning=0
rparams=0.644592,0.829787,1.000000,1.404255
vparams=0.657837,3.191489,0.688742,31.914894,0.728477,59.574467,0.770419,75.531914,0.812362,79.787231,0.874172,82.978722,0.933775,88.297874,1.000000,97.872337
link=alapjarat_k
External :

Code:
[2000_k]
filename=zlin_k_2000
viewpoint=2
rparams=0.620309,0.787234,0.997792,1.382979
vparams=0.646799,3.191489,0.666667,21.276596,0.688742,58.510639,0.719647,75.531914,0.810154,82.978722,0.871965,86.170212,0.931567,90.425529,1.000000,95.744682
 

n4gix

Resource contributor
#9
Yes, it is the same.

Other problem that FS plays the stater sound on and on, regardless of I start the engine or not.
That then is a starter gauge logic problem. After combustion, the starter should be turned off automatically.
 
#10
Regarding my issue as described in post 4, I have discovered that even the realair c172 does in fact have the same stuck revs issue, it's just bought about by a different method.
If I load up the realair c172 sim, bring up the revs in view 1 then cycle thru view 2 back to 1 then bring back to idle = no problems, but...
If I bring the revs up in view 1 then cycle to view 2 and bring it back to idle while still in view 2, when I cycle back from 2 to 1, then go back to 2 the revs are at max again.

If I load the B24 sim with it's original sound folder, it does exactly the same thing as the realair.

If I load the B24 with my modded sound folder, it has the problem in both view switching, rev up - idle scenarios.
All this has given me a clue as to what's going on and maybe how to defeat both problems.

I also tested changing the max rpm in a/c cfg from 2700 to 1700. It only affected the gauge, not the engine rpm.
 
#11
That then is a starter gauge logic problem. After combustion, the starter should be turned off automatically.
That's interesting, the original b24 sound had endless non combustion running when in vc with all engines off, though I think that was because of wav file sharing.

What triggers non combustion anyway? windmilling engines?

edit: It wasn't necessary to have all engines off to get the non combustion, just the correct one.

Another edit: I can confirm, windmilling engine is what triggers the non-combustion sound
 
Last edited:
#12
Here it is

VC :

Code:
[2000_b]
filename=zlin_b_2000
viewpoint=1
panning=0
rparams=0.644592,0.829787,1.000000,1.404255
vparams=0.657837,3.191489,0.688742,31.914894,0.728477,59.574467,0.770419,75.531914,0.812362,79.787231,0.874172,82.978722,0.933775,88.297874,1.000000,97.872337
link=alapjarat_k
External :

Code:
[2000_k]
filename=zlin_k_2000
viewpoint=2
rparams=0.620309,0.787234,0.997792,1.382979
vparams=0.646799,3.191489,0.666667,21.276596,0.688742,58.510639,0.719647,75.531914,0.810154,82.978722,0.871965,86.170212,0.931567,90.425529,1.000000,95.744682
Try increasing rparams to about 1.80 for the max setting and see what happens. The revs should be noticably higher at full throttle.

If so, then the scaling in fsss is not quite right for fsx - are you using fsx?

edit: I see your title for this thread lists fsxa - forget that question :eek:
 
Last edited:
#13
That then is a starter gauge logic problem. After combustion, the starter should be turned off automatically.
The plane stands on the ground, EVERYTHING is turned OFF, engine is STOPPED, and the starter sound just plays like a neverending record :)
 
#14
The plane stands on the ground, EVERYTHING is turned OFF, engine is STOPPED, and the starter sound just plays like a neverending record :)
Yes, I had the same thing with the B-24 with endless non-combustion sound. I stopped it by simply removing the entry in cfg.
A windmilling engine should be the only thing that triggers non-combustion, hardly needed on a mutli engine a/c anyway.

Will recreate the issue and try and hunt it down, maybe it will lead me to why you have endless start sound.

Is your a/c single engine or multi engine?
 
#15
Yes, I had the same thing with the B-24 with endless non-combustion sound. I stopped it by simply removing the entry in cfg.
A windmilling engine should be the only thing that triggers non-combustion, hardly needed on a mutli engine a/c anyway.

Will recreate the issue and try and hunt it down, maybe it will lead me to why you have endless start sound.

Is your a/c single engine or multi engine?
As suggested by n4gix, this definitely seems to be a problem elsewhere in the a/c sim configs and nothing to do with sound cfg
 
#16
Thanks the comments. I will check the codes for the XML gauges. There is stack operators in different codes, think I will find some "collision" there...

The plane has a six-cylinder inline piston engine.
 
#17
I copied the whole sound folder from default Maule : no starter sound, works good. Copied back the original sound folder, and deleed the entries from the original sound.cfg which use the starter sound : the starter sound plays looped again...:confused:
 
#18
I copied the whole sound folder from default Maule : no starter sound, works good. Copied back the original sound folder, and deleed the entries from the original sound.cfg which use the starter sound : the starter sound plays looped again...:confused:
Are you sure it's not non_combustion that's playing? Some use the same/similar sound.
 
#19
Yes I'm sure, but I solved : I deleted all the entries except the engine's combustion sounds, and after that I re-builded the sound.cfg and now the bad sound disappeared !
 
Top