P3D v4 XMLTools - XMLTABLES not functioning correctly

#1
Tom,

Is it possible something in XMLTABLES got broken with the upgrade to 64bit?

The reason I'm asking is that I use the tables a lot for engine code and code that was functioning 100% in FSX/P3Dv2/P3Dv3 with XMLTABLES suddenly isn't i'm getting 110 and 310 table errors spat out of it even though as mentioned the code worked fine before.

and example that is returning a 310 error on me is this which is about as simple as you can get :/

Code:
(>@t:TableBegin, bool)
            'Throttle' (>@t:TableAddName,string)
            '1.00' (>@t:TableAddHeader,string)
            '1, 00.00' (>@t:TableAddRow,string)
            '9, 00.00' (>@t:TableAddRow,string)
            (>@t:TableEnd,bool)
            (@t:TableError,number) (>L:0A_TC_TableError_1,number)
other times it seems to not throw 310 on tables instead on creation the error will be 0 yet when you go and try and interact with the table you get 110 which is table does not exist.

I've tried rewriting the code in lua to see if that would fix it .. no joy (and 6 hrs of rewriting).. everything keeps coming back to the tables not reading correctly.

-Rob.
 

taguilo

Resource contributor
#2
There's definitely something wrong with table names assigned to XMLTables variables.
Weird enough, this only happens in XML gauges; tables called from C++ gauges work flawless.

I have to do some tests. Hope to figure out a solution as soon as possible.

Tom
 

taguilo

Resource contributor
#5
Not yet Robert, sorry.

I've been very busy, without time to check it properly. Hope to do that very soon.

Tom
 
#6
Dear Tom,

I had created an XML gauge to calculate and set V-speeds for the Majestic Dash 8 Q400. The gauge makes extensive use of XMLTABLES to extract and interpolate the tabular data. Although designed for use in FSX (as I do not use any version of P3D), other users reported that the gauge worked reliably in P3Dv1-v3 as well.

However, with the upgradation of the MJC8Q400 to P3Dv4, users of the 64-bit version have reported that the gauge now displays erratic and spurious results from the V-Speed computation:
http://majesticsoftware.com/forums/discussion/2783/xml-gauge-to-calculate-and-set-v-speeds#Item_35
This appears to be another instance of the problem discussed in this thread, and I am reporting it to you for your reference.

Needless to say, we are all awaiting an updated version of your marvelous creation (XMLTools for P3Dv4).

Thanks and Regards,

Chakko.
 

taguilo

Resource contributor
#7
Guys,

I've been doing some tests and it's complicated. As I stated before, tables called from C++ gauges work perfect, XML ones are the problem.
I'm tempted to believe it is a v4.x bug in XML parser, but don't find it reasonable, so I keep testing.

Will let you know when I have positive results,

Thanks for your patience.

Tom

EDIT: I think I have an idea on what is going on, hope to fix it soon.
 
Last edited:

taguilo

Resource contributor
#9
Yes I have an "unofficial" version that should solve XMLTables and XMLVars issues.
Still pending an XMLKeys issue regarding limited number of events capturable, as reported by one user. Need to check that in deep.

You can give it a try and report back.

Thanks
Tom
 

Attachments

Top