• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

XtoMDL and BGLCompiler Issues

Hey guys,

I am trying to import a new static object (a bouy) into FSX.
I have created this in 3D Studio Max and have set up the GUID and proper
.dds texture on it.
I have completed the next step of creating the .x file and .xanim file without an issue. They are visible on the desktop.
Now the issue, I tried to convert these two files to MDL with the XtoMDL tool
by dragging them one at a time into the XtoMDL tool icon and when I do, I get a command window momentarily pop up with some text scrolling in it. It then goes away and deposits a MDL for each one of these files on my desktop. Is this correct? I cannot enter anything into this MDL as the command window does not stay active. I then did the same thing by dragging the MDL files to the BGL Compiler icon. This time, the command window pops up, some text scolls and it turns off with no file showing up anywhere. I read in the SDK that I should do some editing in this window but it will not stay activated to do this.
Does anyone have any suggestion to get past these first basic steps?:(

Thank you,


Staff member
FSDevConf team
Resource contributor

Both of these tools are actually command line applications, so to make best use of them don't use the drag and drop method :).

BGLComp compiles a XML file to a BGL file. So if you drop a MDL file on it you will not get a valid result. You will have to create a XML file first that defines the placement of the object. Have a look at the BGLComp SDK for more details or use the /XMLSAMPLE option in XtoMDL to get a sample file.

For XtoMDL, here is the usage information you get when you just run it from the command prompt. It shows the available options:


For simple objects just using it with the X file as parameter works fine. I have not really tried more complex object in this way. You mention having to X file for one object, I am not sure how that should work.