P3D v4 3ds Max PBR Materials Opacity Map?

Horst18519

Moderator
Staff member
Resource contributor
#1
Has anyone found a way of showing transparency in 3ds Max when using PBR materials? The new PBR material only has map slots for albedo, metallic, normal, emissive and detail - no slot for opacity. I thought maybe Max would finally use the PSD's alpha channel for transparency but that doesn't seem to be the case.
I wonder if anyone found a solution to this?
 
#2
I've never played with this, but in the Learning Center it mentions this:
Blend Properties -- Render Mode:
You can choose Opaque, Masked - for things like fences and vegetation, or Translucent. Masked and Translucent use the Albedo alpha.
I think you are on the right track, you just have to set the correct Blend Property.
 
#3
Hi

I just tried adding an alpha channel to the Albedo .DDS file (formatted to DXT1) and it seemed to work, it does not work with .psd files. In fact i would only recommend using .DDS files with Prepar3d PBS material in 3dsmax, I think that is what it expects and plus it automatically flips them the correct way up.

alp.jpg


Stevo ;)
 
Last edited:
#4
A gradient seems to work ok as well with the texture formatted to DXT3, I didn't have to do anything else, it applied it automatically. I would assume for it to show in P3d one would need to set the blend properties for it to show correctly.
234.jpg


Stevo ;)
 

Horst18519

Moderator
Staff member
Resource contributor
#5
Stevo, is that a screenshot from 3ds Max? I would've expected for it to look like that - but for some weird reason it doesn't in my Max, no matter if I use PSD or DDS.
Maybe it's easier if you see what I see...

I tried different settings using the Albedo color option but that doesn't seem to control transparence. You can very slightly see the alpha - but you would expect the black parts of the alpha not to be rendered at all instead of "slightly different but still opaque". I'm definitely missing something here but I can't figure what - especially since opacity works just fine as long as the material isn't PBR.
 

Attachments

#6
yes its in 3dsmax. I didn't do anything else except add the alpha channel to the albedo, it was just a guess and actually didn't expect it to be that simple so was a bit surprised when it worked first time.

Attach the same files here and I will try it on my version to see what happens, you may need to save the max file as 2017. My PC will be off for a few hours due to painting the room its in but I will be back later this evening.

;)
 

Horst18519

Moderator
Staff member
Resource contributor
#7
I just found out that it's more the way transparency is rendered in the viewport, not so much IF it is rendered. See attached screenshot. That's a PBR material (like you said: DXT5 with alpha works, PSD file doesn't). Transparency works fine BUT not if there's another transparent material behind it. Note how the transparent parts of the box don't show the opaque parts of the plane below.
So it looks like you can't stack multiple transparent objects onto each other like you can with opacity maps.


EDIT:

It looks like I've got some display problems in MAX rather than PBR material problems. Transparency sometimes seems to work (see below) and sometimes doesn't depending on the view (angle). That only applies to PBR materials though so it's still related to PBR but doesn't seem to be a general issue. Weird.
 

Attachments

Last edited:
#8
I think your viewport settings need to be set to the highest quality, "realistic" I think it's called. (not at the pc to check)
 

Horst18519

Moderator
Staff member
Resource contributor
#9
Thanks. I think that was indeed the problem - more or less. I had set my Viewports to "High Quality" but you need to use "Standard" instead. Weird but true.
 
Top