A strange problem with bones, please

#1
Hello

I try to animate an object with an armature in Blender.
It's not my first animation, but this time the animation don't work in MCX (and FSX). It work in blender however.
I Don't think I forgot anything and I don't understand where is the problem. I've tags, skinned mesh ticked in FSX parameters …

I join my file. Maybe someone will have time to take a look, it's just a simple animation for test.

I thank you for your help
 

Attachments

Pyscen

Resource contributor
#2
Last edited:
#3
Thank Doug.
Yes, I know but It's not my problem. I see the object, but his animation does'nt work in MCX or FSX.
The problem is with the animation

The animation of this cylinder work for you ?
 

Christian Bahr

Resource contributor
#4
I Don't think I forgot anything and I don't understand where is the problem. I've tags, skinned mesh ticked in FSX parameters …
For Bender I can not say anything, I use 3dsm. But for me I can solve the problem by changing the decimal separator of comma to dot (from "," to ".") in Windows in the Control Panel in Regional Settings. Then after the export from 3sdsm the animation in the MCX and FSX/P3D were back. Hope it helps you a little further :)

windows_regional_settings_mcx_animation.jpg
 

Pyscen

Resource contributor
#5
Thank Doug.
Yes, I know but It's not my problem. I see the object, but his animation does'nt work in MCX or FSX.
The problem is with the animation

The animation of this cylinder work for you ?
Yes.. I was able to see the animation in MCX.
 
#6
Thank you Christian. I've this setting. And it don't solve the problem :/

Doug, Can ask you if you can test my mdl ? If the animation work for you, maybe I've a problem with export ?
 

Attachments

#8
The animation work for you, in a strange way, but it work !!! And not for me.

I don't understand nothing, if it's not due to my file and to his export into mdl, what is the problem ?
 

Pyscen

Resource contributor
#9
Hello...

Make sure MCX settings are correct - Options -> Import settings - > under Use conditions = UserSpecified. Also -> Import settings -> Replace user variables = True, which is right above the Use conditions. If you are still having issues,... make sure you have the latest version of MCX.
 
#11
Hello

It work now. I think it was due to my version of MCX.
I've Always a problem with stretched out animation, when I use MCX to export. Not if i export directly from Blender !
May be have you an idea about this problem. May be in the MCX export parameters ?
 

Pyscen

Resource contributor
#12
Hello...

Actually, the stretching was the same in Blender. So I don't think its MCX settings. You can't just change one bone and expect the others to just take it (so to speak). Think of it like an arm on a body, the forearm moves but so does the rest of the arm, such as the biceps (also, each bone has limits or weigh).
 
#13
I made this animation quickly, just for test. I just create a new.
As I said : now, the animation work, in Blender, in MCX and in FSX. But the problem occur again in FSX only when I export the object via MCX.

It's not very important. I can export directly from blender to FSX. But ...
I use MCX to add night texture, because my object has 2 materials with a texture (Day an night) for each. And I don't know how add night textures directly in blender in this case
 
#14
On a new animation, 2 captures to explain better my problem :
The first after export directly from blender to FSX
The second, the same mdl file, in FSX, but after export via MCX (The problem does'nt appear under MCX though)

Maybe I should post on a MCX forum ?


 
Last edited:
Top