• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blender UV Map export issue.

Messages
41
Country
unitedstates
I'm attempting to add ports and guns to my P-51. In my first attempt I extruded the ports from the wing and since the wing already had a material assigned I tried to import the Plane into FSX (standard procedure to check shading ) and received
A python traceback error. I thought it might have to do with not mapping the new geometry first ( which has never happened any other time I've done this) but I mapped it anyway and tried again. Same error. Next I removed the UV map as well as the material then reapplied the material without the UV map and the model imported just fine. I remapped the model and tried to import it again just to receive the same error. Next I decided to scrap that file and try it again from a different approach. Instead of extruding from the wing I made the ports from a cylinder and joined it to the wing, mapped them and tried to export to FSX. Same error. Then I removed the UV map and it imported just fine. Next I tried importing the model with the ports as a separate part. As long as they had a UV map I receive the same error. No map, the model Imports just fine. I should note here that I'm making the model on one side then mapping it, adding a mirror modifier then applying the modifier. This way I only have to map one side and I can arrange the UV mapping later. Half the work. Same thing I do with wings, fuselage, etc. without ever having a problem. Next I deleted everything except the port and gun models from the scene, removed all materials and UV mapping from the port and gun models saved as a separate file then appended/imported the objects into the planes scene and tried again. Same result. As long as the new parts are mapped they would not export to FSX.
Now things get weird. I tried mapping and importing the model without mirroring it. It imported with map and material without issue. Then I mirrored it and I got the same error. Next I removed the UV map leaving the material on the model, mirrored the part and it exported to FSX without issue. Next I mapped the right and left ports and guns individually then tried to export. Same error again. The common denominator here is the UV map. I have attached pics.
I'm out of ideas. Also I have no idea how to find line 347, 203, 352 or any numbered lines in the export log at all. Are these lines in the MDL code?

Hope someone has some experience with this.

Aquilla


Error report.jpg

Guns.jpg
 
Last edited:
The error is from XToXML not from blender. You mentioned using the mirror modifier, did you apply it before attempting to compile or uv unwrapping? Did you apply scale and rotation before placing or uv unwrapping.

The modifier needs to be applied, for sure, along with applying scale and rotation before anything else can be done.

Most likely caused by the modifier though.
 
Last edited:
Yes. The modifier is applied as well as the scale and rotation. I also mirrored the part without UV mapping and it exported without issue. It will not export after being mapped.
 
Last edited:
Like I said, the modifier is most likely the cause of the error. XtoXML doesn't recognize the mirror modifier.
 
It doesn't recognize the modifier after it's Mapped. So how do I make it recognize it? It's recognizing it with all the other mapped and mirrored parts.
 
To XtoXML, are the guns also a part of the mirror or just the wings? It would help ro know how are rhey being mapped? Also, could help to see the model. Is that possible?
 
The wings, gun ports and guns are separate parts. Mirrored and mapped separately. I have also tried doing them as a joined part and got the same results.
Parts separated.jpg


Here I have exported the model to FSX with a material but no map coordinates applied to the Guns and Ports.

Guns in Sim.jpg


Next I prepare to apply map coordinates in the same way that I have applied coordinates to every other part without issue.

No map coordinates.jpg

I have tried applying the map coordinates by selecting faces based on their orientation as well as projecting from view. Neither have made any difference.
I'm doing simple mapping now to save time while testing.

Coordinates applied.
map coordinates being applied.jpg


Error message after attempting to export to FSX.

Export error pic.jpg


I look forward to your reply. Thank you for trying to help with this issue.

Aquilla
 
Last edited:
I will add that I have tried both mapping the left wing guns and ports and then mirroring them to the right wing and applying the mirror as well as mirroring the geometry first and then mapping, with the same result.
I have even deleted the parts and started from scratch, going back to an earlier save remaking them, with the same result.
However, I also made 3 cubes, mirrored them from left to right, added a material then map coordinates and exported them to FSX without a problem.
I am currently in the process of remaking the parts again. This time I am copying the original part, manually placing each one and making the necessary geometry adjustments so they fit as seamlessly as possible.
I will then map each one individually. I'll post the results as soon as I have them.
 
Last edited:
This sounds more like a scale, rotation, and location that need to be applied. If you already done so then you shouldn't be getting scale issues, along with rotationn.error messages.
Were any animations done and if so, before or after you have reset them or applied them?
 
Ok. There must be a limit to the number of faces that can be mapped to one texture. In one of my attempts to export I had deleted all parts from the scene accept the Wings, Guns and ports. All textured and mapped.
They exported fine. So I went back to the full scene and started playing around with deleting parts to see what would happen. If I deleted the fuselage the model would export without issue. The same applied to the exhaust pipes.
They share the same material with the Wings, Guns and Ports. So I assigned a different material to the Exhaust pipes and the model exported with UV Map and material on the new geometry. No problem. I'm going to tentatively say
this is solved.
Thanks for your attention to this Pyscen.
Aquilla
 
Last edited:
Yes, there is a limit, but I believe that limit is more so in FSX. I can't remember what that limit is.

Usually, it isn't a problem because textures aren't the same throughout a single object. Realistically, an object doesn't have the same color or texture. There are multiple areas where dirt and scratches can be found. So, there are differences everything.
 
The FSX hard limit max of 65k polygons per material can be spoofed by using two or more identical materials with complementary names.
 
Back
Top