• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Blender2MSFS support thread

Status
Not open for further replies.
I'm getting all sorts of problems with the third building on my airfield, first time round when I tried out the export with the fspackagetool .exe it goes right through and then I get about 5 lines saying that tangents can’t be exported? It’s strange because one of the models it refers to in the error message is just basically a cube? I tried unchecking the tangent box but then I only get the .xml file exported and not the.bin and gltf files. So I thought when in doubt rebuild it and try again but this time I only put a checkerboard pattern on the model. Using the fspackagetool.exe I get the attached? no tangent issues but I'm not sure what the 42 skipped files are and 0 done and 0 failed.

By the way I originally posted some of this in the wrong place but I couldn't delete it
42 skipped because they were already compiled in the bgl, or output file. 0 failed and 0 done because it didn't find any issue and didn't have new files to process.
If your export is missing .bin and / or texture files, check to have the "selected objects" unchecked, that serves as a filter only when you want to export some things of the Blender scene. If you check that and select no objects, you get a wrong export. Also check the LOD option which seems to be bugged right now, so don't check the box.
 
Make sure you are in object mode and have your model actively selected. Then uncheck the "tangent checkbox" and try it again. If you only get the xml its common that the object was not selected before exporting.
I don't agree..."Selected objects" ain't useful at all when exporting, is just a "they do in the tutorial so do I" thing, but it's not needed unless you need to export just one part of it.
Personal experience ;)
 
Has anyone tried importing an FSX native aircraft mdl into the latest blender version 2.91? What format do you export your model in MCX? When you import do you lose all your animation? Do you reconnect /reassign the animation in Blender or MCX? What format do you export out? I'm trying to apply a clear coat shading on an FSX aircraft model so that the aircraft has the signature shine in MSFS2020 and have to bring the mdl into Blender to apply this effect and then export it back out.
 
I don't agree..."Selected objects" ain't useful at all when exporting, is just a "they do in the tutorial so do I" thing, but it's not needed unless you need to export just one part of it.
Personal experience ;)
"Selected objects" are crucial! Right now there is a bug which does not export objects correctly when "batch export LODs" is enabled. I hope it gets fixed - there has not been an update for a while. For now the ONLY way to export LODs is:
1. Export with "batch LOD" checked and "selected objects" unchecked, so the correct file names and XML is created
2. Select LOD0 objects from the x00 collection and export overwriting the *_LOD00 file, with "selected objects" checked and "batch" unchecked - it's the only way.
3. Select LOD1 objects and overwrite *_LOD01 file, with "selected objects" checked

It SHOULD work with just everything done with batch LODs but it doesn't, the objects are broken (earlier somebody pointed exactly where was the problem). It only works this way. Tedious but the only way. I hope it gets fixed soon...
 
This has been done with Quixel Mixer.
Once you are done texturing, set the exporter like this:
View attachment 65274 View attachment 65275

This will generate one correct comp RGB texture, one albedo, and one normal, using all the correct maps from the materials you used, saving you a lot of work.
Also Mixer comes with A LOT of materials (just install all the libraries). And importing yours is really simple and has some good power!
So libraries 1,2,3 and 4 are all separate library’s not versions of same
 
Ok I have been using Quixel for a week now. Love it! Make model in blender, I UV unwrap and save. Then I set color ids (so quixel will recognize the various surfaces). Export that albedo of color ids and a/0 (optional) and then import into Quixel, texture it up and export 3 maps; albedo/diffuse-RGB (a/o/roughness/metal) normal wrap model in blender export to MSFS
 
I am trying to get the Color Multipliers to work. I have a TGA with a base color of white and an alpha layer set to white. I have set the Albedo Color in the Color Multipliers section of the MSFS Materials Params panel to blue. I left the Emissive Black. The color is displayed correct in I have set the Alpha Multiplier to 1.0. The object is colored correctly in Blender but nothing seems to affect the color of the object in MSFS.

I have tried several variations of alpha layers (black, white, mixed, gradient) and have verified in the DDS converted by MSFS that the alpha layer appears correct. I have tried various Alpha Multipliers from 0 to 1. I have tried adjusting the Emissive across various shades of grey.

Reading this thread, I have seen a couple of people that have gotten this to work, but I have not. Can anybody point me in the right direction? Thanks in advance.

material_test.png


Microsoft Flight Simulator Screenshot 2020.11.23 - 16.38.33.91.png
 
How did you make decal image work? What's your workflow for that? Sorry can't help with your question, I'm not using color multipliers...

My workflow is:
  1. Create a decal image. I used a TGA file with an alpha transparency (black for the area around the decal, white for the area of the decal).
  2. In Blender, create a plane and position it close to the object you want to apply the decal to. Originally, I snapped the plan to the face of the object but found that it was z-fighting in MSFS. So, I pulled it away from the face just a little bit. You could also use the shrinkwrap modifier to wrap the plan around a corner or curve. Again, slightly move the plane away from the object to avoid rendering problems in the sim.
  3. Create a material. Set the MSFS Material to MSFS Decal, select your image with transparency and check "no cast shadow". You may need to set the draw order to 1 but I believe this only affects overlapping decals.
  4. Export to MSFS, add to your project and compile. It appears that MSFS applies a multiplier overlay in the sim which allows the underlying texture (normal?) to bleed through which is perfect. (EDIT: I believe this has to do with the Alpha mode setting in the Render Parameters section of the Material Params panel. It is "Blend" by default). You can see that the bleed does not exist in the Blender image but does in the MSFS image.
I am just discovering the power of decals. The combination of decals for weathering along with the color modifiers (if I can get them to work) creates very exciting possibilities for texturing. For the airport I am working on, I several large hangars made from corrugated metal. It is largely the same materials but with different colors, age and wear. If I can get the color modifiers to work, I can use a single 1K texture set to cover all of the hangars, use the color modifiers to tint the hangars and then apply decals for mud, moss, streaks and grime to give the scenery variation and realism.
 
Last edited:
Hi Clements! I cannot get the decal to work. Is the plane the same mesh as your "Cube" in blender - or a completely separate plane (I don't see any in your blender object list)?

This is my test setup - the plane face is the same mesh as the object below, but I also tried it as a separate object, didn't change anything.

1606257258774.png


This is what I see in the sim, not quite what I expected.

1606257318351.png


The material is setup just as you described. Do you have any idea what I might be missing?

1606257364238.png


Thank you! :)
 
Hi Clements! I cannot get the decal to work. Is the plane the same mesh as your "Cube" in blender - or a completely separate plane (I don't see any in your blender object list)?

I have made decals work with planes part of and separate from the target mesh. Because your object’s face is not flat, I would recommend making it a separate mesh and make sure you apply the shrinkwrap modifier (you may need to add some subdivision as part of the shrinkwrap or before to make sure the plane lays down nicely against or near the target).
 
EDIT: I've made it to work finally, check the bottom of this post

Thanks! However, I seem to completely miss the point of the decal material. I've tried as you said, but there's no practical difference between a standard material with "blend" alpha mode and decal material. Is there any difference? I thought the decal would get projected on the underlying mesh or something like that. Here's a standard msfs material:
1606310499594.png


And here's the decal material:
1606310537623.png


I don't see any point in using the decal material. What am I missing? Maybe my expectations are a bit off.

----- EDIT -----

After playing with the blend factors, it works as expected!

1606311581558.png



1606311544666.png
 

Attachments

  • 1606311577546.png
    1606311577546.png
    13.2 KB · Views: 37
Last edited:
Well I sorted the export out, got my 2 files in the modellib. Textures in as well, however it's not showing up in Objects in order for me to place it on the Airfield, the other 2 models are there for me to add but not this third one, I'm sure I am missing something

DUH!!! left a gapin the title:rolleyes:
 
Last edited:

rhumbaflappy

Administrator
Staff member
Resource contributor
You guys should seriously consider starting NEW THREADS for new problems. I think I'm going to lock this thread...
 
Status
Not open for further replies.
Top