• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Bone Animation wrong in msfs

I'm trying to solve this problem for days without luck
In Blender i'm animating a cylinder (windsock) with bones
The animation Is a typical Windsock movement, the windsock start from down (180 degree) position, goes up a Little bit (150/120) and than back down.
If msfs, It start from 90 degree and goes up to 60 degree and back down to 90
I think It Is a problem with the bone axis, my Bones are configurated with Z axis pointing upwards, X axis to the right and Y pointing towards the bone tail
I'm animating only the X axes with a rotation of a few degree



Of course in Blender the animation works ok, all transformation applied in object mode etc
(In Windows 3d internal viewer works ok, and in visual studio code internal viewer works ok too)

Here's the full source model folder + Blender file



Hope someone can help!
e304d1ef2998bb1f9d511f738544136d.jpg
7f6b34a32db39b36aeea0a324a619851.jpg


Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
I had some issues with animations not following what I was seeing in blender and what I saw in MSFS and found it was the Transform order.

I see that yours is set to XYZ Euler, maybe change the order if you had used a custom transform alignment.
 
if you go to the "pose mode" of the armature and select the second bone you see that the rotation in the "n" key panel is set to XYZ Euler. default is here quaternions. your other bones also have the quaternions option enabled. Redo this animation with all bones set to quaternions. maybe this is the problem.
 
I've tried with all quaternion, all XYZ, tried rotating the bones with the Z axis pointing down, the animation Is msfs still look reverse or distorted
Even importing the windsock gtlf sample and exporting It gives abnormal distorsions
It's of course something wrong with my workflow (or maybe the exporter?)
Anyway, I've not seen any working example of a windsock in Blender exported to msfs, lots of tries here at fsdeveloper but no solution yet

I think i've to bit the bullet and try to get It working with 3ds Max (have to do this fast, my trial license wont last long)...uff!

Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
i made that animation:

i also tried to add more details to the animation but that was not working so i think it is limited to "basic" animations but a animation like the flag in that quality was working.
 
i made that animation:

i also tried to add more details to the animation but that was not working so i think it is limited to "basic" animations but a animation like the flag in that quality was working.
what kind of sorcery is it? lol

Can you share your blender file to see what's wrong with my flag please? :)
 
Not really, you add vertex groups to the mesh parts of the flag and then connect the vertex groups to bones using IK (inverse kinematics). Then you can bake the animation to the bones. After that you can push the animation to the nla track as usual.
 
so did some more testings and tried to do a tut with a windsock too.
now i believe that my flag was just an lucky accident that it was working.

with a windsock that is rotating and spinning around i get a weird animation too.

what i think:
the animation is better if you have square faces not crazy long rectangles.
it is working way better if the animation is just moving from left to right (what my working flag is doing)

edit: i checked the exported gltf file with the gltf viewer extension from visual studio code. there the animation is correct. so it looks like msfs is working with modified animation definitions and not the default .gltf definitions for animations.
 
Last edited:
HOLY COW :D i think i have the solution :D

to make the animation there is the step where you parent the object to the armature and it looks like this:
with this step you can start the weight paint:
1614811756515.png


BUT!

if you have everything done the whole animation push down to the nla track. then select the cylinder and the armature and parent it to an empty so that the cylinder and the armature is on the same level parented under the empty. then it looks almost "perfect" :)

1614812316785.png


1614812274252.png
 
Last edited:
that was a lucky accident too. i was allready at that point that it is not possible. :D
rotation and scales applied?
weightpainting done with constant offset? that you really get "1" as wight on the vertex?
 
This is not my thread but since we all have the same issue about bone animation in msfs2020, here is my two blender file (one with pushed animation, other one just with the cloth on it check the modifiers)
Again, thanks for your time ;)
 

Attachments

  • flags.zip
    653.3 KB · Views: 20
Top