FSX:SE Debugging SimConnect with FSX SE

#1
I am developing a SimConnect add-on, and I'd like to debug it. I've set everything up in Visual Studio, but the FSX SE refuses to start, giving me a message that "the FSX SE wasn't started through Steam".

I also have the "old" retail FSX SP2, and I can get the debugger going just fine when my DLL is called through the FSX SP2. As a fallback, I can always use FSX SP2 to work with, but since I'm working with FSX SE, I'd like to debug with it too, instead of switching back and forth... very annoying :mad:

I'm sure solution is somewhere in the settings - any tips on how to debug a SimConnect DLL with FSX SE? Thanks!

(I also posted this in the Steams FSX SE "Non-Steam Add-Ons Forum")
 
#3
Hi Misho.

I need to have the Steam app running in the background in order to get FSX:SE to run.
Oh I know about that - and I do. But when you debug DLL, you need to specify the "calling application" (which is FSX) in Visual Studio. In effect, Visual Studio starts the main application (FSX) and then lets the DLL module run in debug mode. I can get it going with "plain" FSX (SP2), but Steam edition has some kind of a blocker/checker that puts up a fight when it is started through Visual Studio.
 

ddawson

Resource contributor
#4
When I'm debugging gauges, I start FS and then use the "Attach to Process" menu option on the debug menu.
Just tested it now and FSX-SE let me attach the VS2012 debugger.
 
#5
When I'm debugging gauges, I start FS and then use the "Attach to Process" menu option on the debug menu.
Just tested it now and FSX-SE let me attach the VS2012 debugger.
Thanks! - I did what you suggested and it works!! The downside is, I have to do this for every debug session, and the process dialog takes a while to show up. I'll investigate a bit further to see if there is a way to expedite this, perhaps someone on the Steam forum might have an answer. I'll report here if they do!
 
Top