• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSX:SE Fan animation issue

Messages
221
Country
unitedkingdom
I've started modeling AI aircraft in Blender and am using the Blender2P3D/FSX plugin to export my aircraft to FSX and the first one to be released is the Cessna Citation I.

All animations apart from the fan animations seem to work ok in FSX.

I've tried to both use the .mdl file generated by the B2P/F plugin and to open the .x file generated by B2P/F in MCX and then export the model as an FSX .mdl file.

So far for the left engine I have three duplicate objects with identical animations. The animations have been set as linear in Blender.
The objects, Fan Blades - Left - Blurred, Slow and Still have been given the animation tags N1_0_blurred, N1_0_slow and N1_0_still respectively with the corresponding visibility attachment tags.

The Fan Blades - Left - Blurred object has been mapped to the blurred fan blade texture on the texture map, and the Slow and Still objects have been mapped to the still fan blade texture on the texture map.

When opening them model in MCX, the still fan blade texture is displayed and the blades are rotating when playing the animation, however when viewing the aircraft in FSX, the blurred fan blade texture is showing no matter which state the aircraft is in and the blades are not rotating.

For reference, the right engine only has one object mapped to the still fan blade texture and which has been given the N1_1_blurred animation tag, and does not have any visibility attachment tags. This isn't rotating either.

Any idea where I've gone wrong?

Blender.PNGFan MCX.PNGFan.PNG
 
Top