Hangar lights?

Hello...

Let me see what you did with the textures. I only have your previous ones, I still think its the textures... otherwise, it's the model and I saw nothing wrong with the model. I understand what you are referring to. Also, is there a reason why the floor of the hangar doesn't or is not reaching the walls?

Concerning the previous psd files as well... within the "layer0" layer there appear to be "hairline" lines black in color.
The floor of the hangar is reaching the walls. The 4 vertices of the floor are "welded" (merged) at the two inner wall corners. The floor is not connected to the doors. I'm assuming (yes, I know) that you're using Blender. If so, select the floor "face" and pull down. You'll see where it's attached. Should have no affect on the phantom line though.

TB2
 
One thing that I just thought of. I was having an issue getting the alphas to work on a different object, and sought help on this forum. I was instructed to:
  1. In Texture “influence” area, make sure “Alpha” and “color” are checked.
  2. In Materials, Make sure “Transparency” is checked.
  3. In Materials, under “FSX/P3D Material Params” click “set transparent” button.
That made my Alpha work for that texture, but in my hangar(s), I do not have any of these parameters set. If I do set them, I can see through my hangar, so I'm fairly convinced the alphas are not coming into play here, but I could be wrong.

TB2
 
It's not a P3D Model
I'm making this airport (hangars) for both P3D and FSX. I belong to a Flight Sim club and the members have all kinds of flavors of Flight Simulator (not X-Plane). So I have to make it for FSX to be used in both.

I JUST DISCOVERED THAT IT ONLY FAILS IN FSX (Steam)! I do not see any issues in P3D!

I've been doing some research and all faces are made of 5 edges. I've dissolved the center edge, this is where the line is showing up. Interestingly enough, I've managed to reduce it somewhat by converting the quad faces to triangles but not significantly.
 
Last edited:
Just an update. "Pyscen" is helping me with the blender exporting issue elsewhere, so I won't cover that here.

As stated before, this issue happens on ALL of my hangars, not just the one above and ONLY in FSX-SE. Since I cannot export from Blender using the P3D SDK 1.4 yet, I did plug that SDK into MCX (in place of the FSX SDK) and saved the model as an FSX model using the P3D 1.4 SDK. I still had the same result, indicating it wasn't MCX that is causing it. I (personally) don't think that it's a blender issue either, but perhaps ADE or even blender2FSXP3D. Just a thought.

What I can attempt to do is eliminate ADE by plugging in the coordinates in blender and exporting directly to that. I saw a YouTube video somewhere and will attempt to follow that. IF it works, then MCX and ADE will have been eliminated. Heck, it might even be a FSX-SE issue. I'm (personally) 99% convinced it's not textures, only from what experience I've had historically with textures. (never had this issue...)

Enough for now.

TB2
 
Seems like a rendering issue. The face is too close and causing some bleed though. You notice it because of the large difference in colour. You might just have to find a workaround at this point.

Why not use LODs to make a version that will be seen at a distance, and make the gap between the inside wall and the outside wall larger.
 
Seems like a rendering issue. The face is too close and causing some bleed though. You notice it because of the large difference in colour. You might just have to find a workaround at this point.

Why not use LODs to make a version that will be seen at a distance, and make the gap between the inside wall and the outside wall larger.
My walls (inner and outer) are a full "inch" apart (measured by creating a cube, resizing it and comparing it to the gap between the inner and outer walls). I do not believe any of my faces are too close. NONE of my inner / outer walls touch or are joined together. (box in a box example). I purposefully provided an adequate gap. You can download my model and textures here https://www.dropbox.com/s/azeo82bn97f6ds3/Hangar issues.zip?dl=0 and look at them up close if you desire.

Not sure how to use LOD's. My hangars are already seen at a distance. If you can clarify, or point me in the right direction that would be appreciated.

Thanks,

TB2
 
Hi TB:

If I:

* Import your latter attached MDL into MCX

* Export from MCX to FSX scenery BGL format (using P3Dv1.4x SDK XtoMDL at its default path auto-detected by MCX)

* Add that FSX scenery output to an active scenery layer in FSX scenery library GUI

...I see NO Face Diagonals in the following screenshot from FSX Acceleration at run time in default DirectX-9 mode:



FYI: I also attached a screenshot below from a kind fellow who has just re-installed FSX_SE on a new Windows 10 install:



Please note that his FSX_SE also does NOT show Face Diagonals on your hangar at run time in default DirectX-9 mode.

The same kind fellow also took a screenshot in FSX_SE in DX-10 mode:



Please note that his FSX_SE also does NOT show Face Diagonals on your hangar at run time in default DirectX-10 mode.


This raises questions as to how your 3D scenery object MDL is being 'rendered' in FSX_SE at run time ...on your computer. :scratchch


As you may know, DirectX 3D geometry utilizes Triangles, so a quad Face always has a 'Diagonal' (usually "hidden"), because each such quad Face is made of (2) co-planar Triangles after a 3D model is compiled to a MDL via SDK XtoMDL.

[EDITED]

http://www.directxtutorial.com/Lesson.aspx?lessonid=9-4-7


The vertex sequence direction (clockwise versus counter-clockwise) of Triangles is also a factor in 3D modeling:

https://www.blender.org/forum/viewtopic.php?t=24944

[END_EDIT]


While technically such integral geometry is always a part of the 3D object MDL within a FS scene as in MCX' preview:



...co-planar Face vertices in 3D object MDL geometry 'normally' prevents these from being visible in FS at run time. :pushpin:


In order to see these in FS, special methods must be used to allow such Face Diagonals to be visible at run time ex:



http://www.fsdeveloper.com/forum/threads/dx-10-tweaks-wireframe-cool-stuff-from-paul-roussin.432720/

Note that the example 3D MDL for the aircraft shows all quads as Triangles.


One might wonder if Blender2FSXP3D Toolset enables an exported *.MDL to display Face Diagonals in FS. :alert:

If so, one might also wonder whether there may be issues affecting Shaders utilized by FSX_SE on your computer ? :oops:


PS: Please document for this extended troubleshooting process, which of your testing results and screenshots above are:

* DX-9 mode

...versus:

* DX-10 'preview' mode

...and if using DX-10 mode, whether you have installed a freeware or payware version of "DX-10 Scenery Fixer." ;)

GaryGB
 

Attachments

Last edited:

Pyscen

Resource contributor
Hello Gary...

Thanks for proving that there isn't anything wrong with the .mdl file. The .mdl file was compiled using Blender2FSXP3D Toolset [though if I understand correctly was using FSX SDK Box set - not sure though that it was the lastest of the updated SDK box set (Sp1a)]. Also, the problem could be caused by (within MCX) compiling into a library file using the wrong compiler, such as P3D4.5 or thinking that there isn't any difference in using the P3D SDK v4.5 version of. TB was wanting to set up a library file of many models for this airport. In doing so he needed to use ADE to add the library into LOM and then placing the models from the library into ADE. I'm not sure but he may have tried to use only 1 version of the Library (such as P3D v4.5), which would of possibly cause problems within FSX: SE.

What his current problem is trying to use P3D SDKv1.4 within Blender with the Toolset. He is getting an error when attempting to compile (Error: File or Directory not found). The Toolset has been updated to include the use of P3D SDK v1.4 (about 3 weeks now). There hasn't been a problem reported such as this with the Toolset. Mine works and I know of a few others that have used it with no problems.

@TBryson2

What you could try since Gary has now proven that the model is a-OK (which we already determined that as well), You can run MCX and load up your model (the 1 in question) and try using the P3D SDK v1.4 (make sure to set up within MCX, of course) and see if you receive an error message (that better explains what is happening). If you don't receive an error, Then we have a bigger problem which could include the Toolset.
 
I’ll have to get back with “you” in a few days. Sorry for putting you on hold. I have taken my model and using SDK 1.4 in MCX and compiled it into a FSX.BGL file and still saw the lines. But, I recently uninstalled FSX-SE and will reinstall it when I return and try again.

GaryGB thank you for your efforts and explanation. I’ll study it up as soon as I am able. I used to have DX 10 fixer on my system until I got P3D, and may have uninstalled it. Hmmm...
 
Hi TB:

While you "study up", here are some links to info on DX10 Scenery Fixer (payware):

https://www.nzfsim.org/fsx-p3d-tweaks/dx10-fixer-for-fsx/

Note that the (payware) version does not call for a manual rebuild of FSX Shaders after installation or un-installation.

However, if the included un-installation routine was not used, or was not allowed to work sucessfully and completely, one may need to restore the default FSX Shaders manually (see link to replacement file set below).


The last DX10 Shader Fixers V3.2.2 (freeware) version update is here:

https://library.avsim.net/search.php?SearchTerm=shader_release_v3.2.2.zip&CatID=root&Go=Search


Note that the freeware version 3.2.2 has a tool to manually rebuild FSX Shaders after installation or un-installation.


You may also utilize the set of FSX default Shaders to replace modified and/or corrupted FSX Shaders ...linked here:


https://www.nzfsim.org/fsx-p3d-tweaks/dx10-fixer-for-fsx/

ShadersHLSL

Details ...
The default shaders – in case your install fails or has become corrupted.
Size: 141Kb
2618 Downloads

https://www.nzfsim.org/?smd_process_download=1&download_id=1420


[EDITED]

PS: The "active" copy of Shaders used at run time by FSX is a 'cached' in a Windows 'system' folder chain which may- or may not- be removed during un-installation / re-installation ...as discussed in this thread:

https://fsxtimes.wordpress.com/2011/07/11/clean-up-shader-cache/


...and in other threads found by this search:

https://www.google.com/search?source=hp&ei=NNpeXZy2AYqSsAWj2Jt4&q=FSX+Shader+cache+folder+rebuild&oq=FSX+Shader+cache+folder+rebuild&gs_l=psy-ab.3...17338.37326..38326...2.0..0.237.2949.30j2j1......0....1..gws-wiz.......0i131j0j0i22i30j33i22i29i30.G0Qh9I-aTQs&ved=0ahUKEwicoJGoiZfkAhUKCawKHSPsBg8Q4dUDCAc&uact=5

[END_EDIT]

Hope this helps. :)

GaryGB
 
Last edited:
Gary, I KNOW I replied to your post, but not sure why it's not there. Wasn't ignoring you!

I only use FSX-SE for testing purposes. I belong to a flight sim club and our members stretch from (probably) FS9 to P3D v4. I used to have the DX10 fixer on my system prior to P3D. (Great program by the way!) But I've removed all traces of FSX and simply installed the vanilla FSX-SE for testing so I can share my creations with my sim members. I'm working on an airport that was previously payware, (KOCF) but the author cannot be found anywhere and it seriously needed updating. So my KOCF will be going to the members only so I don't infringe on the original authors rights. (They got it for free from him originally).

sorry, got long winded there. In any case, I do not plan on re-installing the DX10 fixer or anything other than FSUIPC in FSX-SE. I do thank you for your efforts and perhaps someone "listening" can take advantage of your help one day.

Now I have to re-read all of the above posts and see where I left off. Interestingly enough, I just re-installed FSX-SE and all of the hangars (except for the Sheriff's hangar) are not showing signs of the leakage! not sure what happened, but I'll play with it some more and get back to "you".
 
Hi TB:

If I:

* Import your latter attached MDL into MCX
* Export from MCX to FSX scenery BGL format (using P3Dv1.4x SDK XtoMDL at its default path auto-detected by MCX)
* Add that FSX scenery output to an active scenery layer in FSX scenery library GUI

...I see NO Face Diagonals in the following screenshot from FSX Acceleration at run time in default DirectX-9 mode:

(edited out)

This raises questions as to how your 3D scenery object MDL is being 'rendered' in FSX_SE at run time ...on your computer. :scratchch


As you may know, DirectX 3D geometry utilizes Triangles, so a quad Face always has a 'Diagonal' (usually "hidden"), because each such quad Face is made of (2) co-planar Triangles.


While technically such integral geometry is always a part of the 3D object MDL within a FS scene as in MCX' preview:



...co-planar Face vertices in 3D object MDL geometry 'normally' prevents these from being visible in FS at run time. :pushpin:


In order to see these in FS, special methods must be used to allow such Face Diagonals to be visible at run time ex:



http://www.fsdeveloper.com/forum/threads/dx-10-tweaks-wireframe-cool-stuff-from-paul-roussin.432720/

Note that the example 3D MDL for the aircraft shows all quads as Triangles.


One might wonder if Blender2FSXP3D Toolset enables an exported *.MDL to display Face Diagonals in FS. :alert:

If so, one might also wonder whether there may be issues affecting Shaders utilized by FSX_SE on your computer ? :oops:


PS: Please document for this extended troubleshooting process, which of your testing results and screenshots above are:

* DX-9 mode

...versus:

* DX-10 'preview' mode

...and if using DX-10 mode, whether you have installed a freeware or payware version of "DX-10 Scenery Fixer." ;)

GaryGB
Hello GaryGB, finally got around to reading and studying this post. I've removed most of it for my reply and to make it easier to follow.

1. VERY interesting that you and your friend did not experience the same issue I'm (still) experiencing. (Thank your friend for me ;)). Knowing this, I can go ahead with this project and let some of my club members test it for me also. Would be curious if they see the same thing I do.
2. Couldn't agree more about how my computer is rendering it. Not sure how to go about isolating it out, other than share information. I do NOT use DX10 fixer (used to, payware). No reference to it in the registry either.

TB2
 
Yeah, I’m saying one inch might not be enough. I don’t have FSX SE to try but what happens if the walls are further apart. Like 6 inches?
"Nz255", I separated one wall by at least 6 inches, still no joy.

You mentioned using LOD's. Do you have any information on how to use LOD's? I'm interested in doing this right.
 
Top