Mesh creation with QGis

#1
Hello. I am trying to create a simple mesh of an small island on Spain. First, i download the *.asc dem file from IGN, that is a 5 meters resolution. Then, on QGis, this file is added as raster layer, and everything is going fine. I change the coordinate system to WGS84, and then when i try to save as geotiff, and run resample, it tells me that 0 blocks processed. No blocks-> No BGL. My question is if QGis is valid to develop a mesh on FSX, and if the answer is yes, how do you do it. Thanks in advance, and sorry for my english.
(I have no problem on GlobalMapper, just trying QGis).

Juan L
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

You should be able to use QGIS for this as well. As long as you output a valid GeoTIFF file, it doesn't matter which tool you used to create it. Resample will be able to process it.

Can you show the INF file you used? And the GeoTIFF properties?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
Hi,

Two things. Looking at the extends I would say the geotiff is not saved with WGS84 coordinates. Also your data uses float64 datatype, so you need to specify that in the inf file.
 
#5
Hi.
Well, I have the impression that QGis is not my friend. It seems that the software does what it thinks is most convenient at the moment, but I do not have any control. Sometimes it exports in FLOAT64, sometimes in FLOAT32. Sometimes it does not let me export in Geotiff, and it exports in DTED. The coordinates should be in WGS84, but it seems that it does not. It really is a devilish software.
 
#6
Hello:

SDK Resample requires source files to be in a Geographic (Lat-Lon) projection / WGS84 datum (aka "EPSG:4326") GIS cartographic 'projection' format.

Also, if the source data is in 5 Meter resolution, is there a reason you want SDK Resample to limit resolution to LOD-11 (19.2 Meters between elevation data points) in the resulting terrain mesh BGL ?

If not, I would recommend using "LOD-4,13" or "LOD=4,Auto" ...in your INF file.

GaryGB
 
Last edited:
#7
Hi Gary. Im gonna tell how i did, step by step
1.Open QGis, then Project->New
2. Layer->Add Layer->Add Raster Layer. Then, select the base archive "PNOA_MDT05_ETRS89_HU30_0038_LID.asc". Its supposed this file is on ETRS89 coordinates, but QGis automatically converted in WGS84 EPSG:4326.
FSDEV01.jpg



3. Raster-> Extract -> Clipper, to crop the image around island. Select the raster layer as input and choose "izaro_mdt05.tif" as output file, on Geotiff format. I draw a rectangle, selecting "Extension". But i need to manually change on the lower window (i dont know why), the format "DTED" to "GTiff".

FSDEV02.jpg

4. Click Accept, and on this point, sometimes it creates the layer right and sometimes not.
5. On Properties, this is that i get:
Code:
Driver: GTiff/GeoTIFF
Files: C:/Users/Admin1/Desktop/IZARO MESH/izaro_mdt05.tif
Size is 127, 106
Coordinate System is:
LOCAL_CS["unnamed",
    UNIT["unknown",1]]
Origin = (525287.500000000000000,4808322.500000000000000)
Pixel Size = (5.000000000000000,-5.000000000000000)
Metadata:
  AREA_OR_POINT=Point
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  (  525287.500, 4808322.500)
Lower Left  (  525287.500, 4807792.500)
Upper Right (  525922.500, 4808322.500)
Lower Right (  525922.500, 4807792.500)
Center      (  525605.000, 4808057.500)
Band 1 Block=127x16 Type=Float32, ColorInterp=Gray
  NoData Value=-999
6. Throw the "elevation_data_izaro.inf" on resample.
Code:
[Source]
Type                = GeoTIFF
Layer               = Elevation
SourceDir           = "."
SourceFile          = "izaro_mdt05.tif"

[Destination]
DestDir             = "."
DestBaseFileName    = "izaro_mesh"
DestFileType        = BGL
LOD                 = Auto
7. Resample dont make a bgl, and tells me this error (sorry for the quality):
fsdev03.jpg



I am thinking that the problem is something related to "NO DATA" values, but im not sure.

Thanks.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#8
Why do you use the clipper? You can just zoom into the region you want and then do right mouse click save as. On the form you get then you can select the output projection as well.
 
#11
I think the problem could be something related to projection system on QGis. On GlobalMapper everything going OK when i use Geographic Projection (Lat/Long). With Ortographic Projection i get the same error on resample that on Qgis. But i dont know how to change. Anyways, do you know an alternative way to build mesh, not QGis or Global Mapper?
 
#12
You selected WGS84 for the output projection?
Yes Arno, i try with WGS84 EPSG 4326, and i try too with WGS84 UTM zone 30N, but no results. It suppose that when i change projection on Qgis, the image on screen would change his aspect, but i always see the same aspect.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#13
No, you can see a different projection on screen than what you save. Those two are not related at all.

Trying UTM makes no sense, the SDK requires WGS84, so anything else will not work.

Since your input data seems to use float64 you also need to tell resample that's the datatype of your data. Else it will not process it correctly.
 
#14
Yes Arno, i tell resample that data are float64. On .inf i write SampleType=FLOAT64. Im sure that is something related with projection or with no data valued. Or not sure
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#15
If you reopen your saved GeoTIFF file in QGIS and then look at the attributes, does it show the right projection?
 
#16
Hi. I think now is solved. Problem was that SRC on QGis is not really the coordinates system. Step by step again:
1. The base file obtained from IGN (Spanish Geographic Institute) is a ASCII/Grid format .asc, with projection ETRS89 HU30N.
2. When is inserted on QGis as a raster layer, automatically SRC change to EPSG 4326, BUT IS NOT THE COORDINATE SYSTEM of the file. I need to change the coordinate to native ETRS89 (EPSG 25830).
3. Next RASTER->PROJECTIONS->REPROJECT, and choose source SRE and end SRE. (EPSG 25830 to EPSG 4326). I dont know why, but when i select save as geotiff, i must to change manually on the lower window, from DTED to GTiff. Assign a name.
4. Close QGis and open it again (I dont know why too)
5. New raster layer and load the reprojected file, now in 4326.
6. Right click on the layer-> SAVE AS-> GTiff and select extension map view to crop around de island....ACCEPT
7. Close QGIS and resample the inf file............ et voila:
fsdev04.jpg

I need to test on FSX, but i think is right.
Thanks Arno and GaryGB. See you!!!
 
Top