FS2004 missing object library error msg

Hello

I hope someone can suggest a solution. I have a "missing library object" warning when I load my sim at a particular airport. I have isolatd the two offending scenery directories but I am wondering is there any way to find out which objects/libraries are missing? The listing is a hex# I think and is in the form 0x followed by 8 alphanumerics, eg 0x4DBB61CE.

I have the "MISSINGLIBRARYALERT=1" in my fs9.cfg, otherwise I get a CTD at this airport and lose my sim altogether with a reboot needed.

Help would be gratefully appreciated.

Cheers

Andrew
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Since the objects are missing it might be hard to find them. Do the specific sceneries maybe require some third party object library that's not installed?

The GUID number shown in the error is used to identify the object. But since FS can't find it, it won't be part of the scenery.
 
Thanks for the reply Arno. Yes much forum searching has led me to the conclusion that I may need to reisntall my sim from scratch:eek: . A lengthy job, but hey its been around 10 years since I have done a fresh/fresh install rather than a backup refit so maybe its time......... :scratchch

I wish there were a great masterlist of these things but I guess third party add ons are what complicates the matter.

Cheers

Andrew
 
I wouldn't recommend a reinstall simply because of a missing object notice.

I know for a fact that the default FS9 will give that error if you are in the right spot.

If you wanted to spend the time you could locate which file is calling the object by process of elimination.

That might help pin down what you are missing.

If you cannot look at an airport and say "something is missing" I would not worry about it.

And I speak from experience, I went through a phase of trying to fix all of those errors and IMO it quickly becomes a waste of time.

I have also seen some addons that included all custom objects and needed no 3rd party libraries that threw a bunch of those warnings. I suspect the designer never got rid of old placement code when updating to newer models.

I doubt that a few missing objects would have a negative impact on performance.

cheers,
Lane
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
I agree, a reinstall is not needed and might not even solve it. In general missing objects don't give much issues, they won't lead to crashes or so. It's only the scenery might look weird.

If you can locate the placement bgl you could maybe remove the calls to the missing objects.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Or you could make a dumny object with the same guid to suppress the errors.
 
Top