FSX no lights on my models?

#1
I’m trying out AFLT for the first time. Hopefully someone can help. I have compiled the 3d lights and I can see the 3d modeled light in my FSX airport, they just have no “light” attached to it at night. I selected the “standard effect” when compiling. When I slew away a few hundred feet, there is no light bloom or halo with the model at all. It’s completely dark on the runway, taxi, approach light models. I’ve read the user guide but can’t figure out why I have no halo. I placed the .fx and texture folder in main fsx effects folder. I’ve placed the included .bmp halo files in the main fsx texture folder. I placed the rest of the generated texture files into my airports texture folder.

Additionally, I’m also having an issue with the popup screen for the approach lighting edit, I can’t see the “save” or “place light” button at the bottom to click it when I edit. I’ve changed my screen resolution, but still can’t see all the way to the bottom of the popup window to click the button, it won’t resize for me either. Many thanks if anyone can help.

Thnx, JP
 

gadgets

Resource contributor
#2
I presume you are using AFLT Version 4.2.07. If not, please download that version (Latest General Release) from http://stuff4fs.com.

Without seeing your Project folder (please see user manual), I have no way of knowing what's going on.

But, I placed the .fx and texture folder in main fsx effects folder.
Why? Effects used by AFLT are created on-the-fly and copied to your Effects folder for you . There should be no need for you to copy anything. Please check your FSX\Effects folder after the compile operation. There should be a bunch of effects there with names starting with "fx_AFLT4_"

I can’t see the “save” or “place light” button at the bottom to click it when I edit. I’ve changed my screen resolution, but still can’t see all the way to the bottom of the popup window
That dialog requires about 900 pixels vertically. What is the vertical pixel size of your display?

Please zip up your Project Folder and attach it to your response.

Don
 
#3
Nevermind most of my previous post.....got it mostly working a while ago.

Yes, using latest version. I was not putting the folders in the right places after compiling. (I compile into the projects folder)

The only thing I notice now is that I can only see the light halo’s if I select the bgl light option compile. I tried compiling with the other two options for the lights, the “halo’s/lights” do not show up in FSX.

My laptop max resolution is 1366x768. Is there a workaround or key press to substitute for the button since I can’t see it?

JP
 

gadgets

Resource contributor
#4
JP, as I said above
Without seeing your Project folder (please see user manual), I have no way of knowing what's going on.

Please zip up your Project Folder and attach it to your response.
I also asked
Please check your FSX\Effects folder after the compile operation. There should be a bunch of effects there with names starting with "fx_AFLT4_"
If I'm going to help you, you're going to have to give me the information I need to do so.

As for the button, there is no workaround at the moment since Windows won't let you move the top of a window off-screen. I can easily add a keypress for it, but I fear that would be quite frustrating since you wouldn't be able to see when it was enabled.

Don
 
#5
Don, thanks for responding. I haven’t had a chance to zip the trial project folder I am working on yet. I do have everything working and visible in FSX now but only when I select “bgl light” as the output. If I select either “effect”or “reverse mip” option, I get a model, just no light. So, eventually I’ll get a zip to you to look at.
My only concern now with the bgl lights option is my visibility distance to see approach/papi/runway lights at night is only about 6nm from the airport. Am I correct in reading that is about the max distance away that effects will show up in FSX? Would either the regular “effect” or “reverse mipped” option give a greater light visibility distance?

Thnx again,
JP
 

gadgets

Resource contributor
#6
but only when I select “bgl light” as the output. If I select either “effect”or “reverse mip” option, I get a model, just no light
That's why I need to know whether or not the custom effects are making it into your Effects folder. Please also check that the textures AFLT_Mipped.bmp, fx_2.bmp and halo.bmp are in your FSX\Effects\Textures folder.
My only concern now with the bgl lights option is my visibility distance to see approach/papi/runway lights at night is only about 6nm from the airport.
BGL_Lights and standard effects have short visible range (max 10000m) and would only be used for special purpose. The other two alternatives have much longer range (if only you could see them).

Don
 
#7
Don,

OK, here's the trial airport project I've been testing. I compiled it this time as 'inverse mipped effects" and once again, I just see only the 3D model at the airport and not the associated light effect. Again, I get everything to work when I select the "bgl light" option when compiling, but I don't like that I can't see any of the the light sources until I'm 6nm away. As a clarification, when you mentioned the other alternative light source compile options, the fourth option of "LOD-variable size" is greyed out on my "make object library" pop up box. I compiled and saved everything into the projects folder, then later moved the associated files into appropriate folders. I am confused as to where the "Light" folder is supposed to go in FSX, maybe that is my problem? I've tried putting it in both the main FSX folder and the individual airport file in fsx addon scenery (not at the same time), but no joy on seeing the light effect. Anyway, here's my project zip file and a screenshot of my FSX effects folder after compiling.
Thanks for your help.

JP

Screenshot (1).png
 

Attachments

gadgets

Resource contributor
#8
Thanks, JP. BTW, are the effects in the Effects folder.

You certainly are doing things the hard way. Why don't you simply point AFLT to the scenery folder of concern and let it do the work.

I'll have a look at you project folder tomorrow. In the meantime, why not give my suggestion a try.

Don
 

gadgets

Resource contributor
#9
JP, I haven't heard back from you about whether or not the effects are in the FSX:SE Effects folder - which I expect they are not. Until I know the answer to that question there's not really anything for me to investigate.

Don
 
#10
Don,
I was just checking this forum moments ago and noticed your question. Yes, effects are in the folder, if you look at the screenshot of the effects folder from my last post you can see the 9 AFLT .fx files residing there.

Just a little bit ago I compiled the lights again using the "reverse mipped" option and this time, as you suggested, I directed AFLT to compile directly into my project airport scenery folder within FSX addon scenery. I did notice that I had to move the texture folder back outside the "scenery" folder to my project airport main folder as it compiled it into the "scenery" folder when it finished. I did note the AFLTxxxxxxx.fx files were once again compiled into the main FSX effects folder. I have placed AFLT_mipped, FX_2, and halo.bmp's into FSX/effects/texture folder also. But, when I start FSX and activate my project scenery, I still only see the 3D models at my project airport and no lights attached.

I notice a folder called "lights" within the project folder in AFLT. Am I suppose to do anything with that folder or it's contents and move it somewhere into FSX or does it just reside in the AFLT project folder only.

Again, as a reminder, when I compile as "BGL lights" option, the lights DO show up in FSX on the 3D models, but I don't like that they are only visible from 6 nm away.....kinda unrealistic visibilty when flying an approach at night. Hopefully you can help.

Thanks,
JP
 

gadgets

Resource contributor
#11
JP. I have tested your file and everything is normal on my system. I did not have your airport .bgl (since I didn't ask for it), so I substituted the stock KCGI. However, since I applied your lighting specifications without change, that would have made no difference.

In the post above you said
I did notice that I had to move the texture folder back outside the "scenery" folder to my project airport main folder as it compiled it into the "scenery" folder when it finished.
I believe this is the key to your difficulty. You told AFLT to copy the files to "scenery" (i.e., FSX\Addon Scenery\scenery). Given that, AFLT would have saved the required textures in FSX\Addon Scenery\texture. From your statement, it would seem FSX\Addon Scenery\scenery is not your "project airport main folder". It then appears you copied "the texture folder" (don't know which texture folder that is) into your "project airport main folder".

None of this copying is necessary. (That's the reason there are no instructions in the user manual for doing so. I designed it that way because a lot of copying is involved and, as you have discovered, it's error-prone when done manually.) All you have to do is specify your "project airport main folder" as the Scenery Folder Path on the Make Library dialog and click Compile. AFLT will put all the required files where they need to be.

Please give this a try. I think you'll be pleasantly surprised by the result.

Don
 
#12
I’m not at my computer at the moment, but I’ll try all that again later.

FWIW, my folder path in FSX IS setup as FSX/addon scenery/Kxxx/scenery folder and texture folder. I’ve never had a problem seeing any of the 3D models in my scenery. I just can’t see any light effect OTHER THAN the “Bgl light” option. If I didn’t place the scenery and texture files in their proper places I wouldn’t have been able to see the 3d models and the “bgl light”effects, but, I CAN. Am I missing something in FSX to be able to render the “inverse mipped” effect (for greater visual distance at night)? Maybe Graphics card?

Is the “lights” folder that is created within the AFLT “projects” folder suppose to go anywhere?

About ready to just give up, but thnx again for you help.
 

gadgets

Resource contributor
#13
I just can’t see any light effect OTHER THAN the “Bgl light” option. If I didn’t place the scenery and texture files in their proper places I wouldn’t have been able to see the 3d models and the “bgl light”effects, but, I CAN. Am I missing something in FSX to be able to render the “inverse mipped” effect (for greater visual distance at night)? Maybe Graphics card?
JP, without being at your console, I can't say what you should or should not see based on how you have copied the files. Your statement simply tells me you copied some of the files to the right place. I doubt the failure of the lights to illuminate has anything to do with your graphics card. This if pretty fundamental stuff.

What I can tell you is that when I compiled your files on my system and let AFLT handle the placement of the files, the lights were illuminated at night. So, it would seem during your copying you have missed one or more essential files.

As I have said on several occasions, there is no need for you to copy any files into scenery and texture folders. (The folder "Lights" is an internal working folder.) Just specify "FSX/addon scenery/Kxxx/scenery" as the Scenery Path on the Make Library dialog and AFLT will put files where they belong. If you are shy doing this routinely, then do it once as a test case and observe where AFLT puts the files. That way, you'll be able to see what goes where.

Don
 

gadgets

Resource contributor
#14
JP, shortly after making the previous post, I realized what's probably going on in your system.

You copied the AFLT-generated bgls to your main scenery folder. But you also (presumably inadvertently) also told AFLT to copy those same files to FSX\Addon Scenery\scenery. Since both those files are object libraries, and assuming the Addon Scenery\scenery folder is enabled in your Scenery Library, this created guid conflicts, i.e.,, each guid had two definitions. Flightsim doesn't like that and doesn't know what to display so, in certain circumstances, displays nothing.

Remove the two bgls from the FSX\Addon Scenery\scenery folder and I suspect you'll see the lights.

Don
 
Top