On fraction bits

After creating 10-meter terrain mesh for several states in the U.S., I have finally come across what appears to be a terracing effect. Not a very good example, but you can see below what looks like graph paper laid over the mountain.

2020-7-5_9-59-21-951.jpg


My source data is USGS 1/3 arc-second, 1-degree lat/long tiles. I convert to WGS84 and export via QGIS, then generate an INF file like this:

[Source]
Type=GeoTIFF
Layer=Elevation
SourceDir="."
SourceFile="N36W118.tif"
PixelIsPoint=0
NullValue=-32767

[Destination]
DestDir="."
DesFileType=BGL
DestBaseFileName="N36W118"
CompressionQuality=100
LOD=Auto

Here is an example of the tile as it appears on TMFViewer:

tmf.JPG


Is this the terracing effect that can be cured by including FractionBits in the INF file? I had started with FractionBits=3, but GaryGB advised that the quality of the USGS data was such that the FractionBits code didn't appear necessary -- when I was dealing with tiles in Missouri. Given that I am creating 1/3 arc-second mesh for the entire conterminous United States, will having scenery in some tiles generated with FractionBits in the INF file be consistent with those that do not have that code?

Thanks,
 
Hello Chris, try this ... for me it is satisfactory!

[Source]
Type=GeoTIFF
Layer=Elevation
SourceDir="."
SourceFile="N36W118.tif"

[Destination]
DestDir="."
DesFileType=BGL
DestBaseFileName="N36W118"
FractionsBits = 3
LOD=Auto,11
 
What I have attached to you is my .INF configuration, if then there are still those marked terraces it can also depend on the quality of the source DEM file.
 
Source quality could be it. Occasionally when I import USGS elevation data there is a warning that pops up asking to convert the data to another format with varying options of accuracy. Perhaps that's evidence that despite all data coming from the same source, some tiles are older and are of a different format and maybe that is when I get terracing. I'll probably have to re-examine each tile on TMFViewer and look for the grids/lines. As indicated above, it does show up when you zoom in close enough.
 
Top