Plane Maker Fuselage Creation Background Image Bug

#1
So, being the poster child of finding problems and bugs in SDK's and building tools, I found another.

Unfortunately, its all over the web as well and I have been wrestling with it a few days...

And I found a fix... heh heh... :]

Bug/Problem;
On my plane, I couldnt get the rear, last Cross Section (Section) to line up with my planes background image(s) in Fuselage mode in Plane Maker. It just wouldnt zoom out or in to fit. I had the length of my Cross Section set to 26'5", but on the background image, that was 2 or 3 feet farther out, and I couldnt zoom to adjust the image.

Idea 1...
I was at attempt E, with super long Background images, thinking somehow maybe I needed a massively wide image to zoom in and out farther with. But no... And then it occurred to me, my mesh was showing to full width. So I made a new Section for the back, about 3 feet past the last one, making it 3 feet oversize. yeah.... Now I could zoom the mesh and it fit my graphics, finally... Hooo rah... I would delete the last endcap later. My thoughts, anyways.

New problem...
I noticed that when I went to Cross Sections window or Sections window in Fuselage and then going back to Side/Top views, my outer edges were crimped flat. I thought about that. Why? My Fuselage Radius was set to 2 feet, so with a 3 feet wide fuselage, I had a foot left over to adjust with. But no... It wasnt enough. I increased Radius to 3 feet, went back in, fixed the flattened zones on the mesh (again, like several times until I noticed what was going on) and 'now' the mesh fit.

So now, with Fuselage Radius set way oversize, and adding a new rear end cap to make the mesh longer then it really is (fake back cross section, delete later) I now had my mesh working proper for the fuselage.

Deleting the endcap.....
Now to delete the endcap. I couldnt. It was there. What to do. So I clicked on the Cross Section vertice of the mesh (one vertice of the half ring) and it goes to zero point, one vertice, as it should, and I moved it to .01 inches from the back endcap, so now its like a neat, slightly dome shaped rear cap, instead of flat. Good enough, and DONE....!!!


This 'is' a bug. The mesh should zoom farther but it seems to have a limit. Increasing Fuselage Radius helped massively. Adding a extra cross section farther out helped also, before I found out about the fuselage Radius issue. But still, that made no sense.

Now, my graphics for the background is small, like under 300 pixels wide, line drawing, looks fair, but 'maybe' that has a part of the issue to it, like a minimum graphics size issue/bug. I dont know. But... Online, there are TONS of posts on forums for X-Plane developers having this same Fuselage background image issue. This helps. Glad I was able to find it, and figure out the issue. Thanks to the Lord. I prayed. Ive been stuck on this for 3 days now. Or was it 4... Time seems to have been tangled up during this detour.


Bill


Why.JPG

** See the issue above, the rear cross section at right is far off to the right, at the edge of the window. My ratio or the graphics was not reaching that far. Its height doesnt match the ratio in the window, so its stuck. I created a 'new' section, much farther back and that brought the 'last ACTUAL cross section' (the proper length point of the aircraft, 26 feet 5 inches marker) into alignment with the tail red-line graphics on the photo and enabled some reverse zoom for the Mesh to match the length on the photo precisely. BUG!!!!!!!!!!!!!!!!!


stprohet.JPG

Now I have matched up the mesh to the fuselage photo. The way you scale a Mesh is make the last Cross Section to the proper length, zero is the nose, the back here is 26 feet 5 inches. I made the last cross section like 36 feet. I zoomed, adjusted, then fit the mesh to the background image, then moved the last cross section 'back' to 26 feet and 6 inches (barely a dome shape. I could have gone flush). Now its proper.


t4et.JPG

Circled, the Fuselage Radius. I increased this another foot and that also helped. I might have only needed this one single thing to get things working right. I doubt it though. Perhaps I'll find out on my next plane. For now, I am not messing this up. 3 DAYS trying to get this to proper scale.

hethber.JPG

This is the main view in Plane Maker, the fuselage with the rear background image, not zoomed to adjustment. Just takes a minute.

Note; You can zoom things around and move the mesh right and left, up and down, but it has nothing to do with the mesh moving in space, its only your 'view', not the parts location. You arent moving the mesh when moving the view. When you drag around the Vertices in Fuselage/Sections mode/window, then..... you are moving things around. Zooming and moving the 'entire thing' means you are adjusting its fit over a background image, even if you have no image on.

Note; Bringing up images should usually be seen at the bottom left of the screens when you have that option available in a section you are working on.


Bill of the gray eyebrow people...
 
Top