P3D v3 Problem remove costum object from default.xml

#1
:(

I have strange problem, I wanted to try to take away my belongings from default.xml files that I created by adding my items, or tried to take away should be simple:
Load the file with default.xml AutogenEditor, I view these objects, select my 4 lights and Remove do, I save with the same name.

The file is generated but loses other items that I have not removed, in fact you no longer see two objects added previously.

Loading in annotator recognize them as library objects 2 remaining ... but not in P3D.

The removed items are part of 4 different classes from those always remained mine.
I tried to remove by hand default.xml objects by editing the file but it does not work.

There is a special procedure to remove objects?

Some idea?......
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

Why not just use Notepad or a text editor to remove the objects you added? It should be quite easy to find and remove the related code.
 
#3
:rolleyes:

Arno Hello, I tried to lift by hand with notepad strings related to my objects
but oddly once loaded into P3D other 2 classes are not
display, that's what I do not understand ....

Example:
I created in the past
1 streets lights class
1 high voltage class
Class 1 Traffic lights

I made my autogen

Now removing only the street lights class, P3D semaphores and the high voltage pylons no longer see well.
using both doing with AutogenEditor than doing it by hand with Notepad ... this is very strange.


If I delete only the objects and keep the lights class roads, the lights disappear
but my traffic lights and high voltage can still be seen, it is OK.
But as soon as I delete the empty class (which now contains nothing) street lights, here again the traffic lights and the high voltage poles also disappear.

I checked the default.xml files and looks good, is identical to the other without the part of the streets lights class. Mystery why does not work?




To work around this problem I had to redo a new default.xml adding only semaphores class and high class tension.

So now it works again, and you can still see my items on my autogen old, because I left the same guid old class.

What I can not explain is why raising only 1 class then I do not see the other does nothing ..... ok, now it goes well.
Thank you...:)
 
Last edited:
Top