• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Problem using MCx

#1
Hi,
I've been using MCx for a long time, but due to problems with my hardware, I had to reset Windows 10.
Now I can't get MCx to work...
This is the problem:
Captura de Ecrã (246).jpg
I tried getting the files in the options from v4 and from fsx, none work.
Tried installing directx 9, nothing.

I honestly don't know what to do. This happens when try to export the file to .mdl.
 

Attachments

Last edited:
#2
Think is a problem with xtomdl.exe. Tried V1, V3 and V4's version. All had the same problem. If I export it as a FSX .bgl file (using the respective SDK) the problem is different:
 

Attachments

Pyscen

Resource contributor
#3
Hello,...

Since you have reset Windows 10 to default (so to speak),... what have you reinstalled since then,... try going to the directly to the directory where the xtomdl.exe located,... right-click on it. Then, move to "properties" and click. from within the "General" tab -- show a screen shot of it.

What is meant by tried to installing directx 9, nothing. DirectX 9 should install when you reinstalled FSX or P3D.
 
#5
Hello,...

Since you have reset Windows 10 to default (so to speak),... what have you reinstalled since then,... try going to the directly to the directory where the xtomdl.exe located,... right-click on it. Then, move to "properties" and click. from within the "General" tab -- show a screen shot of it.
Well, referring to simulation, I installed P3Dv4 and the SDK... Also checked if .net and C++ were installed.
Untitled-1.jpg
I think this is what you're looking for.
 

Pyscen

Resource contributor
#7
Hello,...

OK! Check ModelConverterX also, the same way you checked the xtomdl.exe,... (right-click on it, etc.). Make sure it doesn't have the "unBlock" option.

the only other option I can think of is attached the dae file.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#8
Hi,

The error seems to indicate MSXML4 is not installed, it's used by BGLComp.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#11
It might be the P3D v4 SDK that uses MSXML 6.0, but I'm quite sure the FSX SDK uses MSXML 4.0.
 
#12
I tried both MSXML 4 and 6, and I get the same error. Actually, I think there's a slight difference to it:

(Thank you for trying to help me. I'm so advanced on my scenery, and this problem is just holding everything down...)
 

Attachments

Pyscen

Resource contributor
#13
Well... I'm at a loss,.... except now your getting XToXML error... do you have the SDK for P3Dv4 installed? or have you updated to v4.1 yet?

If you update the SDK, make sure you update the actual simulator also.

Make sure that MCX is pointing to the correct SDK Version as well.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#14
This error is related to DirectX. Make sure version 9.0c is installed.
 
#15
Arno, when I try to install Direct x 9.0c it says I must be running Windows 98, XP, 7... Not 10.
Although, I found a way online to install it. But didn't fix.

Pyscen, actually I'm still on p3d V4.0, and the SDK is 4.1. But I downloaded the 1.4 SDK and FSX's, and the error is the same.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#16
I had that problem on a new machine recently as well. In the end I found a DirectX 9.0 installer for windows 10. But I forgot to save the link unfortunately.
 

Pyscen

Resource contributor
#17
Ok,... before I ask anything else... lol

What simulator or game do you have installed (ex. FS9, FSX, FSX:SE, P3Dv3, P3Dv4 and/or P3Dv4.1) and not the SDK?

You might want to update to P3Dv4.1 of the simulator or game. You shouldn't need any other SDK that you don't have the game or simulator for,...
 
#18
Arno, I want to fix it so hard that I checked online again, found a few installers, but nothing changes to the error. On System32 folder there's the .dll's of DX9...

Pyscen, I only had installed V4, with 4.1 SDK (it's the only available on the website). After all this I tried to install V1.4 SDK as well, and FSX's.
Now I updated P3D to 4.1 to be the same as the SDK, and reinstalled the SDK again, but same error...

I literally don't know what to do anymore...
 

Pyscen

Resource contributor
#19
Ok...

Were the installs of all applications, installed with administrative rights?

Meaning installed by right-click on the application and selected as administrator install? I can't think of anything else to do....