• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Resample.exe problem

I have spent the last 2 days trying to create a photoreal bgl with SbuilderX315 and Adobe Photoshop and Notepad++ getting as far as the background.bmp; landwatermask.bmp and the blendermask.bmp. I wrote the INF from a detailed sample from an AVSIM download of How To Create Photoreal Scenery and then all my frustration begins. When I drag the GLV.INF onto the Resample.exe from the SDK it blinks for a fraction of a second and no bgl. I am so much a novice at this photoreal stuff that I don't even know where to start aside from pulling what little hair I have left, out. Is there someone here willing to help look at this? I have attached a mediafire of the folder because it was too large to attach here. I have everything in because to me it all looks right but doesn't work with the Resample.exe Thank you

 
Your .bmps are simply called out wrong in the .inf. First the .inf is looking for GLV.BMP and yours is named GLV.bmp.BMP, next it's looking for GLVLM.BMP and yours is named GLV_LM.bmp. You can either rename the .bmps or change the .inf to reflect the current filenames. Lastly you have SourceDir = "Golovin_Airport_Photoreal" but at least in the .zip file your .inf is already in that directory so you should be using SourceDir = "." which means "this directory". Other than that it compiled fine once I fixed those errors although your blendmask seems to not be blending anything and your watermask appears to be attempting to do what your blendmask should do. Watermask needs to be pure black (#000000 or 0,0,0) where you want water and pure white (#ffffff or 255,255,255) where you don't - with no feather delineating the two colors. You'd use the blendmask to feather the photoreal water out onto the landclass water. Something like this:

landwatermask.jpg blendmask.jpg

When you're having problems getting something to compile run resample from a command line and the resample window will stay open so you can read the error(s). In this case where resample.exe and your .inf were both in the same folder do this: right-click off in the white space in the folder window while holding the shift key down (make sure no files are selected), choose "open a command window here", at the prompt type resample glv.inf and press "Enter".

Jim
 
Last edited:
Your .bmps are simply called out wrong in the .inf. First the .inf is looking for GLV.BMP and yours is named GLV.bmp.BMP, next it's looking for GLVLM.BMP and yours is named GLV_LM.bmp. You can either rename the .bmps or change the .inf to reflect the current filenames. Lastly you have SourceDir = "Golovin_Airport_Photoreal" but at least in the .zip file your .inf is already in that directory so you should be using SourceDir = "." which means "this directory". Other than that it compiled fine once I fixed those errors although your blendmask seems to not be blending anything and your watermask appears to be attempting to do what your blendmask should do. Watermask needs to be pure black (#000000 or 0,0,0) where you want water and pure white (#ffffff or 255,255,255) where you don't - with no feather delineating the two colors. You'd use the blendmask to feather the photoreal water out onto the landclass water. Something like this:

View attachment 58923 View attachment 58924

When you're having problems getting something to compile run resample from a command line and the resample window will stay open so you can read the error(s). In this case where resample.exe and your .inf were both in the same folder do this: click off in the white space in the folder window while holding the shift key down (make sure no files are selected), choose "open a command window here", at the prompt type resample glv.inf and press "Enter".

Jim
thank you for the quick reply. I thought that I HAD done the watermask and blendermask correctly but I can FIX those in Photoshop. I will also fix the file names in the INF as you say to correct. I will also save this post for future if I have another problem with another airport.

Richard
 
Top