Resample.exe problem

I have spent the last 2 days trying to create a photoreal bgl with SbuilderX315 and Adobe Photoshop and Notepad++ getting as far as the background.bmp; landwatermask.bmp and the blendermask.bmp. I wrote the INF from a detailed sample from an AVSIM download of How To Create Photoreal Scenery and then all my frustration begins. When I drag the GLV.INF onto the Resample.exe from the SDK it blinks for a fraction of a second and no bgl. I am so much a novice at this photoreal stuff that I don't even know where to start aside from pulling what little hair I have left, out. Is there someone here willing to help look at this? I have attached a mediafire of the folder because it was too large to attach here. I have everything in because to me it all looks right but doesn't work with the Resample.exe Thank you

 
Your .bmps are simply called out wrong in the .inf. First the .inf is looking for GLV.BMP and yours is named GLV.bmp.BMP, next it's looking for GLVLM.BMP and yours is named GLV_LM.bmp. You can either rename the .bmps or change the .inf to reflect the current filenames. Lastly you have SourceDir = "Golovin_Airport_Photoreal" but at least in the .zip file your .inf is already in that directory so you should be using SourceDir = "." which means "this directory". Other than that it compiled fine once I fixed those errors although your blendmask seems to not be blending anything and your watermask appears to be attempting to do what your blendmask should do. Watermask needs to be pure black (#000000 or 0,0,0) where you want water and pure white (#ffffff or 255,255,255) where you don't - with no feather delineating the two colors. You'd use the blendmask to feather the photoreal water out onto the landclass water. Something like this:

landwatermask.jpg blendmask.jpg

When you're having problems getting something to compile run resample from a command line and the resample window will stay open so you can read the error(s). In this case where resample.exe and your .inf were both in the same folder do this: right-click off in the white space in the folder window while holding the shift key down (make sure no files are selected), choose "open a command window here", at the prompt type resample glv.inf and press "Enter".

Jim
 
Last edited:
Your .bmps are simply called out wrong in the .inf. First the .inf is looking for GLV.BMP and yours is named GLV.bmp.BMP, next it's looking for GLVLM.BMP and yours is named GLV_LM.bmp. You can either rename the .bmps or change the .inf to reflect the current filenames. Lastly you have SourceDir = "Golovin_Airport_Photoreal" but at least in the .zip file your .inf is already in that directory so you should be using SourceDir = "." which means "this directory". Other than that it compiled fine once I fixed those errors although your blendmask seems to not be blending anything and your watermask appears to be attempting to do what your blendmask should do. Watermask needs to be pure black (#000000 or 0,0,0) where you want water and pure white (#ffffff or 255,255,255) where you don't - with no feather delineating the two colors. You'd use the blendmask to feather the photoreal water out onto the landclass water. Something like this:

View attachment 58923 View attachment 58924

When you're having problems getting something to compile run resample from a command line and the resample window will stay open so you can read the error(s). In this case where resample.exe and your .inf were both in the same folder do this: click off in the white space in the folder window while holding the shift key down (make sure no files are selected), choose "open a command window here", at the prompt type resample glv.inf and press "Enter".

Jim
thank you for the quick reply. I thought that I HAD done the watermask and blendermask correctly but I can FIX those in Photoshop. I will also fix the file names in the INF as you say to correct. I will also save this post for future if I have another problem with another airport.

Richard
 
Top