• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

SAMM2 Doesn't locate aircraft

Hi, everyone. I am a first time user of SAMM2.1 and I had a question for you.

When I open SAMM2, I can only navigate to C:/Program Files (86):/Microsoft Games:/Microsoft Flight Simulator X, and when I get there, there are no other folders to choose from and no aircraft, with the exception of my OH-58D that some how shows up, and it gets errors for textures.

The manual says to navigate further to "sim objects:/ aircraft", but I see no way to do that.

The tic for FSX is checked in the upper right hand corner (Automatically). I have even checked the "Other" tic and tried to navigate that way, but it doesn't work either.

It has to be something that I'm doing because I see that all of you are using SAMM2. What could it be?!?!
 
Last edited:
I actually typed in the rest of the address to show "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes, but it tells me that there are noAI aircraft in that folder.

There are a LOT of AI aircraft in that folder.

Any ideas out there would be wonderful;)
 
I suppose you are using Windows 7 or Vista no? Then you may be aware of that UAC. Just execute SAMM2 as administrator and look if it works.

Another possibility (and how I am doing it), copy the airplane with the corresponding texture to a "workfolder" and work within that folder. Then you will not have problems if something screwed up or if you did something wrong.

hope this helps!
 

gadgets

Resource contributor
Boatco, when you click on the aircraft Select button, SAMM will let you go anywhere Windows allows. So scKevin's suggestion may be "right on the mark". The FS9, FSX and Other radio buttons only control the staring point (so that, for FS9 and FSX, you don't have to navigate to their aircraft/simobjects folder.)

it tells me that there are noAI aircraft in that folder.
I can't find that error message anywhere in SAMM's code. What was the specific message you received?

Don
 
Thanks for the help, guys! I did need to move the aircraft to a new folder and then navigate to it, but it worked just as the two of you said it would!:cool:
 

gadgets

Resource contributor
The problem likely is the location of your FSX folder - i.e., on the C: drive. I know that's the default location, but unless you run as administrator, Win 7 and Vista are "particular" about letting applications (such as SAMM) navigate there.

Do yourself a favor if you ever have to re-install FSX and place it one a drive other than C:.

Don
 
Okay, I'll do it when the time comes.

Hey, I have noticed something, and I would like your comments.

I converted an aircraft to a static model, added it to FSX objects and then to my ADE, but after adding it to an airport and then compiling the airport to FSX, I don't see the plane. No black figure or anything.

Why not?
 

gadgets

Resource contributor
There's a whole host of possibilities - most of them "finger-trouble" related

Try placing your static aircraft using SAMM's built-in placement facility. This will confirm that SAMM has done it's job. Once you've confirmed that, you can then look for procedural problems in the other things you did. (Presumably, you are handling the static model as any other scenery model - save for the two-tiered texture folder unless you elected to save all your textures toi the main texture folder.)

Don
 
Hey, I tfixed it. LOL! Well...I think I found out what I was doing wrong.

I was collecting the .bdl from a location other than FSX.

Thanks again for everything, guys!!!
 
Having trouble with SAMM2. When I first used it all work well and placed a couple of aircraft now when I bring it up as soon as it click on FSX it brings up the attachment marked samm1 and then it brings up samm2. I have went so far as deleting it and downloading it but nothing changed. Well now its telling me my screen shot file is to large so will try to explain. I click FSX and Microsoft flight sim pops up the aircraft folder is not opened as it was at first soI click airplanes and it sticks "c182" in the title line and I get a error message "texture folder not found" I click ok on that and it opens to the airplane I want to work with then I get another error message "unable to restore parameters or materials etc.. Their must be a file or files thatare left behind when I unstall that keeps me form getting a clean reinstall? Help Please

Regards
 

Attachments

  • samm1.png
    samm1.png
    440.6 KB · Views: 367
  • samm2.png
    samm2.png
    673.5 KB · Views: 384

gadgets

Resource contributor
Robert, first of all, while I don't think it has anything to do with your issue, I assume you are using either SAMM 2.2.03 or the latest development release 2.2.03(e).

You report that it used to work and now it doesn't. Since no one else is reporting such an issue and you didn't re-install SAMM until after you experienced the problem, the question I would ask is "what have you done on your system since it last worked that may have impacted the SAMM folder, the library folders, the FSX aircraft folders or the fsx.cfg file.

I have no idea what could be the source of an "attachment marked samm1" nor do I have any idea what would be in it. SAMM Version 1 was superseded nearly 2 years ago by SAMM Version 2. SAMM Version 2 "knows nothing" about SAMM 1. Did you first download SAMM 1 from a library such as Avsim, then update to SAMM 2 in the same folder and now have inadvertently started SAMM 1? Or, could "samm1" and "samm2" possibly be library folders you have created?

You state that you reinstalled SAMM "but nothing changed". Then you describe a completely different set of symptoms. The second time, did you attempt to open a static model rather than an aircraft model? (That might account for the FSX aircraft folder not opening and "c182" displayed on the ------------ or open static model ------------ textbox. Is that what you are referring to by "title line"?)

In order for me to help you, I need to know exactly what you are doing (i.e., what buttons are you pressing/what are you entering into text boxes - by name) and what is the result at the completion of each problematic operation.

Don
 
Thanks for the Fast reply Don - the two attachments marked saam1 and 2 are titles I gave the screen shots I am running the latest version of SAMM2.
My problem started when I wanted to put a cessna 182 in a parking space. theC182 is a old Coronado model with a patch that allows it to run in FSX.
SAMM2 did handle that plane and I placed it on the airport. After that the airplane fold stoped coming up expanded and when I click on the airplane folder to expand it that is when I get what is shown in the two attachments. Form what you stated in your reply my problem has nothing to do with SAMM2 but a file or folder I corupted, I thouth about that so I removed all the Cessna airplane folders for FSX and tried SAMM2 again their was no change. know little about how to handel files or folders so I have not made any changes in them. If is not SAMM2 please tell me your thoughs on what files or folders I should look at I have FSX on a backup drive so I could compair the files or folders.

Regards
 

gadgets

Resource contributor
SAMM does not display screenshots, so I'm still at a loss as to what's happening or why.

SAMM has no independent "route" to aircraft folders. When you click on the FSX radio button, for example, SAMM simply opens a directory tree at the last location accessed from that radiobutton. If the last folder accessed was a FSX aircraft top folder, SAMM will re-open that folder. If something else was opened in the interim, it's up to you to locate the aircraft folder of interest. (That's what the instructions on te Select Aircraft Folder dialog are telling you to do.)

Don
 
Don:
Sorry I was a sorce of trouble to you, but after your last post I started diging thru files and folders assocated with SAMM2. I found a world document in the airplanes folder and it was on the C182. I pulled it out of FSX and your very fine easy to use tool for static aircraft is working normal and this old man is Happy. Thank you for your great gift to us Sim Pilots.

Regards
 
Top