• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Scenproc and Annotator

Messages
57
Hi
With the help of Arno I get the autogens (AGN) in scenproc, but when I open the annotator to edit and remove some thing does not appear 10% of the footprints, does anyone have this problem?
In FSX appear all, as show in the pictures below.

Footprint in GlobalMapper SHP.
ann1h.jpg


After Scenproc FSX.
ann3.jpg


In Annotator SDK, only has footprint around the red lines.
ann2d.jpg

Regards
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Hi,

I haven't seen this before. There were some bugs before, but then nothing showed up.

Just as a test, if you save the agn files in annotator, do you only see that 10% in FS as well? That might indicate there is something wrong in the agn file.
 
Messages
57
Hi
Arno
If I save in the annotator, appears in fsx as is pictured above(annotator), with only 10%
How do I know if you have something wrong in the AGN?
Thanks
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Hi,

Could you send me one of the agn files that show this problem? Maybe I can see something from the file.
 
Messages
3,278
Country
spain
Working with the Fsx SDK autogen annotator I know there are zones wich can't be populated with buildings. I have seen this in my sceneries, why? I have no idea. With Scenproc I haven't observed such situation.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Hi,

I think I have found the problem now. Another user also reported the same issue and together we found the reason.

The problem happens when buildings are just crossing the border between two terrain tiles. In that case the SPLITGRID step will make a very tiny polygon for the part that is in the other cell. It seems Annotator can't handle such small buildings and therefore it does not display everything.

Fortunately the solution is in scenProc already. You can give the splitgrid step an additional argument that tells it to not slice certain features. So if you add FROMFILE=building.shp or building=* (or something similar depending on your data) the houses will not be sliced up. Instead they are put in the cell where the center of the building is.
 
Messages
57
Hi
I did not understand
What do I have to change or add below?
IMPORTSHP|Vitoria.shp|*|NOREPROJ
#
SPLITGRID|AGN
#
SETAGNBUILDINGHEIGHT|*|1.0;0.0;0.0;0.0
CREATEAGNGENBUILD|FTYPE=POLYGON;FROMFILE=Vitoria.shp;FWIDTH<20|{5ae04eb6-934c-4f63-bb48-5e7dee601212}|MAXRATIO=2
CREATEAGNGENBUILD|FTYPE=POLYGON;FROMFILE=Vitoria.shp;FWIDTH>20|{6089A0BD-CED1-4c47-9A9E-64CDD0E16983}
#
WRITEAGNFILES|FSX|C:\scenproc

Best Regards
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Hi,

Assuming the shapefile only has buildings and no forests, etc. I would use it like this:

Code:
IMPORTSHP|Vitoria.shp|*|NOREPROJ
#
SPLITGRID|AGN|FROMFILE=Vitoria.shp
#
SETAGNBUILDINGHEIGHT|*|1.0;0.0;0.0;0.0
CREATEAGNGENBUILD|FTYPE=POLYGON;FROMFILE=Vitoria.s hp;FWIDTH<20|{5ae04eb6-934c-4f63-bb48-5e7dee601212}|MAXRATIO=2
CREATEAGNGENBUILD|FTYPE=POLYGON;FROMFILE=Vitoria.s hp;FWIDTH>20|{6089A0BD-CED1-4c47-9A9E-64CDD0E16983}
#
WRITEAGNFILES|FSX|C:\scenproc
 
Messages
57
Hi
I used the code you sent me but still does not appear all the footprints, increased only around 30%, in your Annotator appeared all footprints?
Best Regards
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Hi Paulo,

I don't have a photo scenery for your area, so that makes it hard to test. But another user send me a test scenery for his area and there the fix worked fine.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Sascha, he contacted me by email that he had the same problem.

Did you double check your data to make sure there are no small polygons in there that would result in tiny houses? It seems Annotator doesn't like those.
 
Top