• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 Textures for Lights maybe wrong?

Messages
1,468
Country
germany
EDMO_4.5.3.3.jpg
 
That looks like the display one should see on the AFLT display when Menu View-Illumination is selected.

Are you sure the new textures found their way into the AFLT\Textures\Illum folder and the earlier ones were deleted? (Most of the names are the same. To do otherwise would have meant you would have had to reprogram the lights._ You would, of course need to recompile with the new textures. Also, please check the scenery-associated Texture folder to ensure the latest texture found their way there as well.

The supplied textures are the ones I am using and all is well on my system.
 
I tested it with 2 independent airports, but I have to check if there are same named texures in the main texture folder (or anywhere preloaded first?)
 
Perhaps this could help?
your CYYJ 2006 has a illum_flood.bmp like this:

illum_flood_cyyj.jpg



And 4.5.3.3. textures like this:

illum_flood_4.5.3.3.jpg


And the illum.bgl was not copied from work folder to scenery folder
 
The provided textures are not for FS9.

I had to change the Alpha Channel to solve the problem:


illum_flood_9.jpg
 

Attachments

  • illum_color_white.zip
    18.4 KB · Views: 99
Hello Don,
sorry, I have to report another problem.

I created a user mdl light standard and updated the standard txt as described in the manual.
Works very fine.
But then I copied this light sometimes.
It worked fine for the 3D model, but all the flood lights stayed at the first location.

copy light standard.jpg
 

Attachments

  • ETHA.zip
    43.2 KB · Views: 98
I received no notification of the last several posts in this thread. Hence the delay in responding.

Attached is a new .exe. It SHOULD fix the FS9 texture issue and well as the copy issue. Also, .dds textures are no longer copied for FS9. Please confirm.

As for files not being copied, they seem to copy fine on my system - both the .bgl (renamed AFLT_projectID_IllumGPs.bgl) and the required textures.
 

Attachments

  • AFLT_4533(a).zip
    328.1 KB · Views: 105
Hi Don,
please do not restrict the colors of Light Standards for FS9 to white.

All worked fine yesterday when I used all textures with the corrected Alpha Channels.

Of course you know the textures for fs9 should have the bright color (white, orange or what ever) and the Alpha Channel is dark like on post #7.

With 4.5.3.3(a) I had to cheat a little, rename the fog texture to illum_flood and illum_base:

ESNZ6.jpg




it is all only a matter of the correct Alpha Channel for FS9.

Your FSX(?) textures and program parts are fine, if the Alpha Channel are changed.
It is easy with DXTBMP.
 
Last edited:
please do not restrict the colors of Light Standards for FS9 to white
it is all only a matter of the correct Alpha Channel for FS9.

Your FSX(?) textures and program parts are fine, if the Alpha Channel are changed.
It is easy with DXTBMP.
Yes, I know its easy. But, it requires a complete set of textures for each color - just as you had to rename some textures.

Given the limited user base with FS9, I doubt anyone but you would take advantage of the feature. However, you already have the custom colored textures. So, just substitute your textures for mine.
 

Attachments

  • Textures_Illum_FS9.zip
    135.8 KB · Views: 117
Sorry Don,
your texture doesn't contain a illum_flood.bmp nor a illum_base.bmp, which are used in AFLT_ESNZ_IllumGPs.bgl.
 
I was working on ADE-GP at the time and sent you that package by mistake. Attached hereto the AFLT FS9 textures. Place this folder beside "Illum" in "Textures".
 

Attachments

  • AFLT_Illum_FS9.zip
    29.8 KB · Views: 118
Hi Don,
I tried to use a single light "obstruction" on top of a building or Ramplight Standard, but I cannot specify the altitude...
 
I have just posted Development Release 3.4.3.5, which should do what you want.

WhiIe I have tested that the new functions operate as intended, I strongly suggest you give this release a good workout to ensure it doesn't create additional difficulties.
 
I have just posted Development Release 3.4.3.5, which should do what you want.

WhiIe I have tested that the new functions operate as intended, I strongly suggest you give this release a good workout to ensure it doesn't create additional difficulties.
Don...

Just updated to: v4.5.3.5, yet the top bar still reads as v4.5.3.4.
 
Thanks for letting me know, Doug. I recently changed the .zip configuration file, but forgot to make a required update. Try it now, please
 
Back
Top