• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Totally Bricked

connomar

Resource contributor
5th May, came home from a trip, FS working fine. Following morning it dumped me into Microsoft Store for an update, but the update didn't do a thing. Having wasted 2 days reading everything I can find. I submitted a ticket to Asobo , but their ideas didn't work. I am now at the "I have to totally rebuild the machine stage", so this is a last ditch effort to see if anyone else has experienced this? I eventually hit reset during troubleshooting and wiped the entire flight sim, so I reformatted the drive it was on.

What it does:

I go into Microsoft Store and list my owned packages. It can happily download and install other stuff, just not flight sim. (This is Microsoft Flight Simulator Premium Deluxe) This package has Manage next to it. I hit manage and get Manage - Install, then Bundle Contents, the standard version, the Deluxe upgrade, the Premium Deluxe Upgrade and Digital Ownership.

I select Manage Install and it asks me where to install it. Long Pause with the Install button now missing. This morning, the button eventually appears again as if it timed out. On other occasions, it has displayed a list if items it wants to install, then got to about 80% and gone to Error. Task manager shows no network traffic on network.

Switching to Xbox App:

Go to startup settings to ensure I have the right drive selected for installs. I have a blank dropdown box, so I cannot tell it where to install. Try to install anyway from their simpler menu, and I get 0 Unknown available - so it doesn't know where to put it, and is as much use as a chocolate teapot.

This makes me think the whole problem is with the XBox part of the system, but how to fix it I have no clue. I've deleted the xbox app and reinstalled it, but to no avail. I feel there must be something left in the registry that is messing things up. I've tried deleting the xbox related registry entries, then reinstalling xbox and trying to log in. From this I discovered that the lack of install drives is related to my user profile, since when not logged in, I can change it, but then of course, I cannot download anything.

So, I am now at the stage of despairingly considering formatting the master drive and reinstalling.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
You might try an administrator commandline. then enter sfc /scannow to verify and repair any windows issues, I was forced to do that myself today in an unrelated issue. It did repair some files. and the issue I had resolved.
 

connomar

Resource contributor
Thanks for your reply Dick. It took 2 days, but eventually I got it running as full Administrator, then back onto my normal login. I can't be sure, but I noticed a large number of errors from Bonjour. Since I have no Apple Based stuff on my network, and never will have, I uninstalled it. After that, Microsoft Store downloaded the loader and off it went. However, it was on the wrong user id and in a folder that was non standard. In my efforts to a) Get it back on the correct user and b) Get the default file paths, I managed to destroy it again, so my ISP has seen 400Gb of data over the last 2 days, but it is working correctly now.

Doing a Robocopy moved the files and authentication information fine, but I left out a folder. i.e. X:\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\OneStore instead of Official\OneStore . File Explorer successfully moved it, and it was accepted okay. Then I tried to get too clever and also run it from the other user. That screwed something up and I had to reinstall, but fortunately not via the loader on Microsoft Store.

The moral of this tale is: Don't give up and reformat your OS Drive.

Martin
 
Top