• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSX TS Pro - Unable to Decompile CVX BGLs

Hi folks - I suspect I'm missing something or doing something really stupid. Or both.

I'm using TS Pro for the first time (I've previously used SBX for terrain building/modification). I was attracted to TS Pro because of its ability to import terrain BGLs. What I want to do is import a default FSX CVX BGL and modify it. I think I should be able to do this ?

So I open up TS Pro (version 2104, but I get the same problem on 2100, 0100, 0109) and select File/Import BGL as Project. I navigate to the FSX\Scenery\0501\scenery folder and attempt to import file cvx4715.bgl. In the window that pops up, "All Data In File" is checked, and I don't change anything. I click Continue.

A DOS window opens and processing begins. I see messages like Processing Roads, Processing Streams etc, and then there is a red error message which flashes up too quickly for me to read, The a window pops up to tell me TS Pro cannot decompile the bgl file.

I have tried many other CVX bgl files in other folders with the same result. What am I doing wrong ?
 
Forgot to mention - I ran CVX Extractor standalone on the same files and it seems to complete without error.
 

gadgets

Resource contributor
Dick, I suggest you first give recently-released TS Pro 2.1.05 a try. It has a couple CVX Import/Export fixes.

If that doesn't work then please post the CVX file you are attempting to import
 
Hi Don - thanks, where do I get 2105 ? I can only find 2104.

EDIT: Found it (I think)
 
Last edited:
Downloaded the development release, which I guess is 2105, and it gives the same result. It seems that many CVX files in FSX/scenery/nnnn/scenery fail - but not all, as I first thought. I have attached two files - cvx4813 which fails and cvx4615 which works.

I do notice that some of these 'original' FSX CVX files have different timestamps, so possibly modified by other products (I have UTX EU and ORBX FTX installed). But I can't see a correlation in timestamps between the files that work and those that don't, so that may be a red herring.
 

Attachments

  • cvx4813.bgl
    2.6 MB · Views: 49
  • cvx4615.bgl
    71.4 KB · Views: 50
No problem - I'm not going anywhere :)

I did think for a while that there might be a correlation between CVX file size and this problem - most of the failing files seemed to be 1Mb or more. But that's not solid either.
 

gadgets

Resource contributor
Thought I'd take a quick look at the issue. The problem you encountered was fixed with updated CVX Extractor.

However, while it now successfully imports both files, the larger one contain railroad data which TS Pro doesn't "seem to like".

I'll let you know when I have a fix.
 
Hi Don - just tried to download the new release from your site, but neither the general release nor the development release download links seem to work ?

EDIT: Automatic update to 2.5.1 when starting TS Pro failed also. Unable to connect with your site.
 
Last edited:
The problem you encountered was fixed with updated CVX Extractor.
not in vain earlier, I suggested updating it)))
I often had a similar error , so I manually used newest CVX Extractor;)

Unable to connect with your site.
I confirmed this earlier, I’m sure as soon as Don sees that, it will be fixed :stirthepo
 
Sorry Niksan - didn't see your post. I don't tend to read P3D labelled threads as I am FSX only.

I'm sure Don will fix.
 
Hi Don - downloaded and installed 2105 OK. But when I attempt to import cvx4813 (file attached above) I get a message saying there are 47547 items in the file but only the first 1000 gave been processed. As far as I can tell, the only data displayed is for rivers and streams even though the View options are set to Display All. Is there another setting/option I need to change ?
 
I don't tend to read P3D labelled threads as I am FSX only.
there is practically no difference in vector data ;)

I attempt to import cvx4813 (file attached above) I get a message saying there are 47547 items in the file but only the first 1000
my personal opinion, it’s better to work with such large vector files only with layers, in the sculptor only with flattening, and then add the rest of the layers(via SBuilderX, unfortunately we still need use several tools) :stirthepo

Please try again
Thx!

The problem you encountered was fixed with updated CVX Extractor.
now in for the sculptor, tool CVX Extractor version 1.0.1.7.
but a separate, tool CVX Extractor is available in a newer version 1.0.3.1, does it make sense to update in for the sculptor to this version?
 
Last edited:

gadgets

Resource contributor
Dick, the time I takes for AIFP to import items from CVX files increases exponentially with the number of vertices imported. The time it takes to import nearly 5000 vertices is measured in tens of minutes. (It's not the import that takes the time; it's the processing of the imported data to be useable.)

I figured there's no useful function in TS Pro that would make use of anything like that amount of data, so I limited the points to 1000 - rather than field reports that TS Pro had gone into an endless loop.

I can get rid of that limit but, before doing so I'd like to know its just not for curiosity's sake. If all you want is to see what's there, tmfViewer will display such a file in a few seconds.
 
Hi Don - that's a fair question ! In this case I do want to do more than look. I want to change the topography. This area includes some famous cliffs which are not depicted properly in my version of FSX. Having looked at TS Pro and its import capability, I thought it would be easiest (!) to import the default terrain file and modify that rather than create a separate CVX file. But happy to go that route if you'd rather keep the limit in TS. Your call.
 

gadgets

Resource contributor
Try limiting the bounding box to just the area of interest (in the dialog at the start of the import operation). 1000 is an arbitrary limit and it can be changed. But I can assure you the processing time on both ends of the operation would be unacceptable with ~5000 vertices.
 
Thanks Don - I'll give that a try. If it doesn't work I'll revert to Plan B. I've had some thoughts about how I can take some shortcuts.

Thanks for your help.
 
Top