• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Unhandled Exception

For some reason now when I go to right click and add a sculpt node, I get a message saying "unhandled exception has occurred in your application"

This is what I see when I click "details":


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at Terrain_Sculptor_Pro.Nodes.Nodes_AddNewList(List`1& listNodelist, Int32 fType, Int32 fStyle, Single nAll_M, String sName, Guid guidTerrain, Int32 fMode)
at Terrain_Sculptor_Pro.MainPanel.cmnuAddNode_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3163.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
TS Pro
Assembly Version: 0.1.0.0
Win32 Version: 0.1.0.0
CodeBase: file:///C:/Users/Jon/Documents/The%20Airport%20Guys/Programs/Terrain%20sculptor/TS%20Pro.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 14.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3151.0 built by: NET472REL1LAST_B
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3160.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
FSUIPCClient
Assembly Version: 2.4.4910.2
Win32 Version: 2.4.4910.2
CodeBase: file:///C:/Users/Jon/Documents/The%20Airport%20Guys/Programs/Terrain%20sculptor/FSUIPCClient.DLL
----------------------------------------
Accessibility
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Microsoft.GeneratedCode
Assembly Version: 1.0.0.0
Win32 Version: 4.7.3056.0 built by: NET472REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 

gadgets

Resource contributor
After all you've done and since it just happened (and nothing else has changed, I assume), this issue must be data dependent. The error message tells me the program module in which the error occurs and the general nature of the problem. But, without your file, I'd just be taking "stabs in the dark".

Please send me the related files and tell me in as much detail as possible what you were trying to do - and where - so that I can attempt to repeat your situation.

Don
 
Well here's the thing... I tried it with a totally new TS download and a completely new file as well. It's the same result.
 
It's the latest release from your site. At the top for some odd reason it says Terrain Sculptor Pro 0.1.00, I thought it was a lot later version than that. But it's what I get when I download either the general or development release. Before, I'm pretty sure I was still using the latest release.
 

gadgets

Resource contributor
Thanks. 1.00 is the latest release. It's supposed to be just 0.0.32 relabelled. Is there any way you can determine the release number of the file you were using previously.

And can you revert to that release?
 
Unfortunately not. Yesterday was the first time I'd fired it up in a while and it was doing it then. It had otherwise been months and months since I'd opened the program.

The issue seems to be anything related to sculpt nodes, whether attempting to create them or convert other nodes to sculpt nodes, it throws that.
 

gadgets

Resource contributor
OK, I'll take that stab in the dark. In the mean time, I've re-enabled the development release link for 0.0.32.

Please download it and see if you have the same problem.

Don
 

gadgets

Resource contributor
I've wound it back to 0.0.30. Please try that one.

I was working closely with you at the time and you weren't having this issue. So one of these has got to be OK.

Have you made any changes to your system recently?
 
Indeed you were! That one doesn't seem to be working either... for what it's worth, I had to step away from scenery design for a bit back in March. I'm not thinking of any changes I've made to my system at all.
 

gadgets

Resource contributor
And, as you can see, the date-time stamp on those files shows last March.

I've just fired-up 0.1.00 and added a few sculpts to both an old project and a newly-started project. No issues.

Please send my your TS Pro folder and at least one existing project.

E-mail to don at stuff4fs dot com.


It may be a day or so before I get to it.

Don
 
I'll send them along, but all of this is making me think there has to be a problem on my end somewhere. I just have no idea what it could possibly be.
 

gadgets

Resource contributor
My guess would be on a missing file, or NET 4.5 not being installed. But, send your stuff along and I'll take a look.

Don
 
My thought was .NET issues. I have 4.7 installed, when I try to specifically install 4.5 it says it's already there. Windows 10 also doesn't seem to want to easily let me remove it and re-install it completely.
 
Top